Kodi Community Forum
v17 LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Linux (https://forum.kodi.tv/forumdisplay.php?fid=52)
---- Thread: v17 LibreELEC Testbuilds for x86_64 (Kodi 17.0) (/showthread.php?tid=269815)



RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - fritsch - 2016-09-20

(2016-09-19, 23:34)dellas60 Wrote:
(2016-09-19, 23:21)Milhouse Wrote:
(2016-09-19, 23:03)dellas60 Wrote: hi,

when iam on live tv (tvheadenend) and when i active vdpau i notice artifictes and jerky on some sd channel. please help me.

http://sprunge.us/DMCS

Try the latest build, your build is 2 weeks old.

Also, what version of tvheadend are you using? I provide current tvheadend42 builds here: http://milhouse.libreelec.tv/builds/addons/Generic/service.tvheadend42

thanks for your reply,

but i have the same issue with kodi on ubuntu with tvh 4.2

Recordings from file are fine?


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - dellas60 - 2016-09-20

(2016-09-20, 07:16)fritsch Wrote:
(2016-09-19, 23:34)dellas60 Wrote:
(2016-09-19, 23:21)Milhouse Wrote: Try the latest build, your build is 2 weeks old.

Also, what version of tvheadend are you using? I provide current tvheadend42 builds here: http://milhouse.libreelec.tv/builds/addons/Generic/service.tvheadend42

thanks for your reply,

but i have the same issue with kodi on ubuntu with tvh 4.2

Recordings from file are fine?

yes,the record file is fine

when iread from record or stream file from tvh with simple iptv no issue.


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - fritsch - 2016-09-20

So tvheadend bug when using it with the pvr.hts addon? -> I think you can file a bug with them.


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Milhouse - 2016-09-20

New LibreELEC.tv Krypton build #0920: Generic
(Supercedes previous build)

Code:
# uname -a
Linux NUC 4.7.4 #1 SMP Tue Sep 20 21:11:59 BST 2016 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse) - Version: devel-20160920211046-#0920-g631bb96 [Build #0920]

Based on tip of LibreELEC.tv master (631bb961, changelog) and tip of XBMC master (efce317d, changelog) with the following modifications: Build Highlights:
  1. VideoPlayer exceptional keyframe fix
  2. libnfs updates
Build Details:
  1. LibreELEC.tv:
    • kodi: post beta2 patches, crash and mem leak fixes (PR:756, 2 commits, 6 files changed)
    • init: pre-create /dev/console (PR:751, 1 commit, 8 files changed)
    • Cleanup advanced settings in WeTek projects (#755) (f8f514b4)
  2. XBMC:
    • [PVR][guiinfo] Optimize implementation of System.HasPVRAddon. Also fixes possible deadlock on PVR startup. (PR:10506, 1 commit, 2 files changed)
    • VideoPlayer: allow deinterlacing methods specific to renderer (PR:10493, 4 commits, 12 files changed)
    • kodi.guilib: fix version in generated addon.xml (PR:10517, 1 commit, 1 file changed)
    • drop some unneeded ifdefs related to ffmpeg (PR:10514, 1 commit, 1 file changed)
    • [python] fix dialog documentation (PR:10511, 1 commit, 1 file changed)
    • VideoPlayer: handle exceptional case where distance between keyframes… (PR:10516, 2 commits, 2 files changed)
    • [win32] fix appx manifest Visual C++ Redistributable for Visual Studio 2015 dependency (efce317d)
  3. libnfs:
    • Added the ability to bind to a specific interface with the (5f75307a)
    • Conditionally include unistd.h from libnfs-zdr.c a some platforms lack this header (b0c3cb34)
  4. Additional commits/pull requests/changes not yet merged upstream:



RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Karnis - 2016-09-21

(2016-09-20, 00:22)Milhouse Wrote: This weeks 4.8-rc7 kernel release, #0919x: Generic

This build swaps the Chris Wilson patch for the 4K patch.

I read back a few pages but didn't see anything....what's the 4K patch? << crosses fingers for what I hope it is >> Big Grin

TIA


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Milhouse - 2016-09-21

(2016-09-21, 01:34)Karnis Wrote: I read back a few pages but didn't see anything....what's the 4K patch? << crosses fingers for what I hope it is >> Big Grin

TIA

Not sure what you hope it is...

2414448 (post)


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Karnis - 2016-09-21

Nope, that's not it. I've been using a build from fritsch that limits playback refresh rate when Kodi detects 1080p @ 120 Hz and plays media at its' native refresh rate instead of forcing it to the highest supported rez. In my case, because my 4K set does 1080p @ 120 Hz, it plays all media at 120 Hz....which normally wouldn't be a bad thing but I get stuttering at that refresh rate and I haven't had the time to diagnose whether or not its the display or Kodi. 2160p isn't an option because (1) Kodi upscale of 1080p to 2160p doesn't look as good as my set doing the upscaling and (2) my Beebox HDMI is only 1.4 so that limits all my 60 Hz media to 30 Hz. I believe fritsch has stated that my patch doesn't work for PAL video so I was hoping that was the 4K patch you mentioned.

Thanks for your feedback and sorry to go OT.


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - fritsch - 2016-09-21

My pr concerning this is still open. Still issues with double switching of interlaced content.


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - atoulmin - 2016-09-21

@millhouse I havea Intel NUC i3 "skylake" I've been using your test builds and everyhting has been great so far. However i've noticed a weird bug in build #920. It seems the video picture will "switch" colors during playback and put a "slight green" tint on and off while playing. I then tried chromium and it has the same issue.

In build #917 I don't get this issue.

Its a weird one.


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Milhouse - 2016-09-21

@atoulmin: Can you try #0918 and #0919 too, and confirm if they have the same issue?


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - atoulmin - 2016-09-21

(2016-09-21, 13:18)Milhouse Wrote: @atoulmin: Can you try #0918 and #0919 too, and confirm if they have the same issue?

Ok will do


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - tinzarian - 2016-09-21

@Milhouse @fritsch
I was running #919x for a while, as I said kernel 4.8 fixes my power on issue, which is nice, but with this build I have another problem: all audio disappears compleely. I did a clean install of 7.02, updated to#919x and all was fine. The next time I powered up I got no audio whatsoever. I have no idea if this is a LE, kodi or kernel issue, but attached are:
journalctl
dmesg
debug log


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - _Spook_ - 2016-09-21

No green tint on video and video works fine on #0920 for me on NUC6i5SYK


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - atoulmin - 2016-09-21

I'm just going to put it down to "one of those things" I have gone through build #917,#918,#919 and no issues with the "green tint" as mentioned earlier.

However i have since reinstalled #920 and i'm not having any issues.


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - normy62 - 2016-09-22

quick question am thinking of purchasing the new minix neo z83-4 which has Intel® Atom x5-Z8300 Processor ( cherry trail) with windows 10 64 bit pre installed. i dont know if this machine is 32bit uefi or 64 bit uefi.. i would prefer to get rid of windows and install libreelec i need to know which build ( if any) i can install on this..or if anyone knows of a better box i would welcome your suggestions
thank you in advance