Kodi Community Forum
v17 LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Linux (https://forum.kodi.tv/forumdisplay.php?fid=52)
---- Thread: v17 LibreELEC Testbuilds for x86_64 (Kodi 17.0) (/showthread.php?tid=269815)



RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - jjslegacy - 2016-10-21

Seems random when stopping. Will play more tomorrow


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - badaas - 2016-10-21

Anyone testing on SQL with smb?
Suddenly not working will try backtrack to working build.

Also audio is not restored from suspend (GUI sounds or videoplayer).

PHP Code:
13:39:54 698.860718 T:140610438088768  NOTICEVideoPlayerOpeningsmb://NSA320S/films/Howard.the.Duck.1986.1080p/Howard.the.Duck.1986.1080p.mp4
13:39:54 698.860840 T:140610438088768 WARNINGCDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
13
:39:54 698.861389 T:140607724099328  NOTICECreating InputStream
13
:42:41 865.624084 T:140607724099328   ERRORSMBDirectory->GetDirectoryUnable to open directory 'smb://USERNAME:[email protected]/films/Howard.the.Duck.1986.1080p'
                                            
unix_err:'6e' error 'Connection timed out'
13:42:41 865.624207 T:140607724099328   ERRORGetDirectory Error getting smb://NSA320S/films/Howard.the.Duck.1986.1080p/ 

passwords.xml is set btw


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - badaas - 2016-10-21

Okay, this version works fine:
#1011, 11-Oct-2016: Generic -- Release post (Cherry Trail/Bay Trail audio support for 4.8 kernel; peripheral.joystick updates)


...let me check others...


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - badaas - 2016-10-21

This broke it:
#1018, 18-Oct-2016: Generic -- Release post (Samba fixes; inputstream.mpd updates)

This ok up to here:
#1017, 17-Oct-2016: Generic -- Release post (New 4.8.2 kernel)


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Milhouse - 2016-10-21

Hmm. The Samba changes should have no effect on smb:// as they relate entirely to the configuration of the Samba server in LibreELEC, and not the way in which Kodi communicates with your NAS.


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Milhouse - 2016-10-21

@badaas if you run the following command in #1020 and reboot, the Samba server will be back to the pre-#1018 configuration - does it make any difference?
Code:
wget -q "https://raw.githubusercontent.com/LibreELEC/LibreELEC.tv/master/packages/network/samba/config/smb.conf" -O /storage/.config/samba.conf



RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - porkchop999 - 2016-10-21

Hi Milhouse, are there any advantages with Mesa 13.0?


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Milhouse - 2016-10-21

When it's released we can find out, is there anything in particular that needs fixing by 13.0?


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - porkchop999 - 2016-10-21

Just curious


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - john.cord - 2016-10-21

(2016-10-21, 14:47)badaas Wrote: Anyone testing on SQL with smb?
Suddenly not working will try backtrack to working build.

Also audio is not restored from suspend (GUI sounds or videoplayer).

PHP Code:
13:39:54 698.860718 T:140610438088768  NOTICEVideoPlayerOpeningsmb://NSA320S/films/Howard.the.Duck.1986.1080p/Howard.the.Duck.1986.1080p.mp4
13:39:54 698.860840 T:140610438088768 WARNINGCDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
13
:39:54 698.861389 T:140607724099328  NOTICECreating InputStream
13
:42:41 865.624084 T:140607724099328   ERRORSMBDirectory->GetDirectoryUnable to open directory 'smb://USERNAME:[email protected]/films/Howard.the.Duck.1986.1080p'
                                            
unix_err:'6e' error 'Connection timed out'
13:42:41 865.624207 T:140607724099328   ERRORGetDirectory Error getting smb://NSA320S/films/Howard.the.Duck.1986.1080p/ 

passwords.xml is set btw

i use smb with sql and no problems...


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - john.cord - 2016-10-21

(2016-10-20, 23:09)Roby77 Wrote: This a kernel issue

Black screen when ?

i got this blackscreen problem too and i use a chromebox (Haswell Celeron).


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Milhouse - 2016-10-21

New LibreELEC.tv Krypton build #1021: Generic
(Supercedes previous build)

Code:
# uname -a
Linux NUC 4.8.2 #1 SMP Fri Oct 21 21:11:27 BST 2016 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse) - Version: devel-20161021210421-#1021-g7fe628e [Build #1021]

# Kodi version
Kodi (17.0-BETA4 Git:e143904). Platform: Linux x86 64-bit

Based on tip of LibreELEC.tv master (7fe628ef, changelog) and tip of XBMC master (e143904b, changelog) with the following modifications: Build Highlights:
  1. Minors
Build Details:
  1. LibreELEC.tv:
    • changed url from openelec.tv to libreelec.tv (PR:857, 1 commit, 1 file changed)
    • dvb-tools: add w_scan (PR:855, 1 commit, 3 files changed)
    • kodi: fix aml audio patch (PR:851, 1 commit, 1 file changed)
    • samba: fix browsing and clean up smb.conf (PR:849, 1 commit, 1 file changed)
    • installer: replace dialog with whiptail (PR:854, 8 commits, 9 files changed)
  2. XBMC:
    • Use new add-on hooks to enable/disable peripheral add-ons (PR:10734, 1 commit, 3 files changed)
    • [filesystem/nfs] - ensure that the last access time of a context is u… (PR:10737, 1 commit, 1 file changed)
    • disable debug in depends in Release builds (PR:10728, 2 commits, 9 files changed)
    • [skin.estuary] Fix mute icon (PR:10742, 1 commit, 1 file changed)
  3. pvr.vdr.vnsi:
    • send wol on system resume (PR:92, 1 commit, 2 files changed)
  4. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [pkg] PR:10739: Fixed OnPlayBackResumed not getting fired anymore.



RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Roby77 - 2016-10-21

(2016-10-21, 01:55)jjslegacy Wrote: Seems random when stopping. Will play more tomorrow

please add a comment to

https://bugs.freedesktop.org/show_bug.cgi?id=98354


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Roby77 - 2016-10-21

(2016-10-21, 21:20)john.cord Wrote:
(2016-10-20, 23:09)Roby77 Wrote: This a kernel issue

Black screen when ?

i got this blackscreen problem too and i use a chromebox (Haswell Celeron).

please add your comment and logs to

https://bugs.freedesktop.org/show_bug.cgi?id=98354


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Maverick-DBZ- - 2016-10-22

I'm having the same issue @badaas is having with smb, I reverted back to #1017 build and everything is back to normal, no issues accessing smb share from a Windows 10 PC and NAS. All builds after #1017 and #1021 today exhibit the same issue.