Kodi Community Forum
v17 LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Linux (https://forum.kodi.tv/forumdisplay.php?fid=52)
---- Thread: v17 LibreELEC Testbuilds for x86_64 (Kodi 17.0) (/showthread.php?tid=269815)



RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Milhouse - 2016-05-03

(2016-05-03, 07:40)Hitcher Wrote: RPi?

Thanks - fixed. Blush


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - samehvirus - 2016-05-03

after this latest update, i have a problem with online video streaming .. only 15mb will cache ahead , not enough for hd video streaming . i checked my advancedsettings.xml file , the cachemembuffersize value still as i set it before .

<?xml version="1.0" encoding="utf-8"?>
<advancedsettings>
<network>
<cachemembuffersize>629145600</cachemembuffersize>
</network>
<splash>false</splash>
</advancedsettings>

whatever , it looks like kodi now ignoring this value or reading it from somewhere else after the latest update. it will stop caching on 15mb , and i saw a notification that the reading rate is slow for continuous playback , never saw this before .


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - samehvirus - 2016-05-03

oh, okay .. i didn't see this coming .. based on https://github.com/xbmc/xbmc/pull/9681/files
value names was changed in latest update and i should update my as.xml with this new names.

i noticed that the included as.xml in your build didn't updated yet ( the one in system folder , not in userdata )
usr/share/kodi/system/advancedsettings.xml

have this code

<?xml version="1.0" encoding="UTF-8"?>
<advancedsettings>
<showexitbutton>false</showexitbutton>
<cputempcommand>cputemp</cputempcommand>
<gputempcommand>gputemp</gputempcommand>
<video>
<latency>
<delay>0</delay>
<refresh>
<min>23</min>
<max>24</max>
<delay>175</delay>
</refresh>
</latency>
<busydialogdelayms>750</busydialogdelayms>
</video>
<samba>
<clienttimeout>30</clienttimeout>
</samba>
<network>
<readbufferfactor>4.0</readbufferfactor>
</network>
</advancedsettings>


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - samehvirus - 2016-05-03

this what i did in my as.xml in userdata folder :
<advancedsettings>
<cache>
<memorysize>629145600</memorysize>
</cache>
</advancedsettings>

working fine now


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Milhouse - 2016-05-03

(2016-05-03, 21:04)samehvirus Wrote: oh, okay .. i didn't see this coming .. based on https://github.com/xbmc/xbmc/pull/9681/files
value names was changed in latest update and i should update my as.xml with this new names.

Thanks - in tonight's build I'll change:
Code:
<readbufferfactor>4.0</readbufferfactor>
to:
Code:
<readfactor>4.0</readfactor>



RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - walkerx - 2016-05-03

Installed: LibreELEC-Generic.x86_64-8.0-Milhouse-20160502225252-#0502-g0b27675 on Asus Chromebox upgraded from OpenElec

Interface is nice and clean, just got to get used to it

Using the default skin I have noticed when go into TV Series, every episode is listed twice - not sure which title to remove from this as when press i or c on remote to see the information I'm unable to see the file it is pointing to


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - porkchop999 - 2016-05-03

I might be being dumb but can't find the chromium add-on anywhere. Running #502 Generic, Addon- Libreelec add-ons been through all of the categories but can't find it.


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Milhouse - 2016-05-03

(2016-05-03, 22:46)walkerx Wrote: Installed: LibreELEC-Generic.x86_64-8.0-Milhouse-20160502225252-#0502-g0b27675 on Asus Chromebox upgraded from OpenElec

Interface is nice and clean, just got to get used to it

Using the default skin I have noticed when go into TV Series, every episode is listed twice - not sure which title to remove from this as when press i or c on remote to see the information I'm unable to see the file it is pointing to

Not seeing this myself. Is this the first time you've used any of these builds, or has it just started with the #0502 build?

Can you dump the metadata for one of your problem tvshows:
Code:
texturecache.py jd tvshows "<showname>" | pastebinit
Replace "<showname>" with the name of one of your problem tv shows, then paste the link.

A screenshot of the same show would also be useful.


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Milhouse - 2016-05-03

(2016-05-03, 23:01)porkchop999 Wrote: I might be being dumb but can't find the chromium add-on anywhere. Running #502 Generic, Addon- Libreelec add-ons been through all of the categories but can't find it.

The package has been added to the LibreELEC source code repository (which is what you saw in the changelog), but the package now needs to be built and added to the 8.0 repository. It will be built and added as and when someone finds the time to do it.


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Milhouse - 2016-05-03

(2016-05-03, 22:00)Milhouse Wrote: Thanks - in tonight's build I'll change:

I ballsed up the change - in addition to the property name changing, the category has also changed from network to cache which I completely missed so this won't be fixed until Fridays build.


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Milhouse - 2016-05-03

New LibreELEC.tv Krypton build #0503: Generic
(Supercedes previous build)

Code:
# uname -a
Linux LibreELEC 4.6.0-rc5 #1 SMP Tue May 3 21:16:14 BST 2016 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse) - Version: devel-20160503211458-#0503-g0b27675 [Build #0503]

Based on tip of LibreELEC.tv master (0b276752, changelog) and tip of XBMC master (fa16b76a, changelog) with the following modifications: Build Highlights:
  1. NOTE: DVD playback remains temporarily disabled
  2. Minors
Build Details:
  1. XBMC:
    • Update settings.xml (PR:9738, 1 commit, 1 file changed)
    • VideoPlayer: inputstream, check status of Create (PR:9739, 1 commit, 1 file changed)
    • guilib: update items of GUIMediaWindow after adding a media source (PR:9736, 2 commits, 2 files changed)
    • [guilib] - fix for multiimage controls in case imagepath switches to empty (PR:9715, 1 commit, 1 file changed)
    • [gui] Use SelectDialog for SortMethod selection (PR:9647, 2 commits, 3 files changed)
    • [python] - whitelist some GUI_MSG_NOTIFY_ALL messages for WindowXML windows (PR:9727, 1 commit, 1 file changed)
  2. inputstream.smoothstream:
    • add depends::expat::platform.txt (352b14eb)



RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - walkerx - 2016-05-03

(2016-05-03, 23:06)Milhouse Wrote:
(2016-05-03, 22:46)walkerx Wrote: Installed: LibreELEC-Generic.x86_64-8.0-Milhouse-20160502225252-#0502-g0b27675 on Asus Chromebox upgraded from OpenElec

Interface is nice and clean, just got to get used to it

Using the default skin I have noticed when go into TV Series, every episode is listed twice - not sure which title to remove from this as when press i or c on remote to see the information I'm unable to see the file it is pointing to

Not seeing this myself. Is this the first time you've used any of these builds, or has it just started with the #0502 build?

Can you dump the metadata for one of your problem tvshows:
Code:
texturecache.py jd tvshows "<showname>" | pastebinit
Replace "<showname>" with the name of one of your problem tv shows, then paste the link.

A screenshot of the same show would also be useful.

Hi yes, gone straight to 502 from OpenElec

Images here - Battlestar Galactica, Game of Thrones, Babylon 5

Links for the output from the command line for each title, I think I have noticed the problem. On OpenElec I had told it to remove non-existent titles (as moved distro location for media) but it seems it is still showing the old location for media titles as well as the new location.

Battlestar Galactica
Game of Thrones
Babylon 5

Other thing noticed, but nothing major as cosmetic error, if go into the Libre menu and choose about, some of the text is overlayed or not aligned correctly (using 1920x1080P resolution)


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Milhouse - 2016-05-03

(2016-05-03, 23:12)Milhouse Wrote: I ballsed up the change - in addition to the property name changing, the category has also changed from network to cache which I completely missed so this won't be fixed until Fridays build.

And apparently 4.0 is the default anyway, so this setting will be dropped.


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Milhouse - 2016-05-04

(2016-05-03, 23:24)walkerx Wrote: Links for the output from the command line for each title, I think I have noticed the problem. On OpenElec I had told it to remove non-existent titles (as moved distro location for media) but it seems it is still showing the old location for media titles as well as the new location.

Looks like you've got the same episodes scraped from two different sources, eg.:
Code:
"file": "smb://FREENAS/TV Series/Battlestar Galactica (2003)/Specials/Battlestar Galactica (2003) - S00E01E02.mkv",
...
"file": "smb://MEDIASERVER/TVSeries/Battlestar Galactica (2003)/Specials/Battlestar Galactica (2003) - S00E01E02.mkv",

Drop "smb://FREENAS" or drop "smb://MEDIASERVER".


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Milhouse - 2016-05-04

(2016-05-03, 23:24)walkerx Wrote: Other thing noticed, but nothing major as cosmetic error, if go into the Libre menu and choose about, some of the text is overlayed or not aligned correctly (using 1920x1080P resolution)

Yes, it's on the list. The Settings addon will be getting an overhaul for LE8.0 and the new Estuary skin.