Kodi Community Forum
v17 LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Linux (https://forum.kodi.tv/forumdisplay.php?fid=52)
---- Thread: v17 LibreELEC Testbuilds for x86_64 (Kodi 17.0) (/showthread.php?tid=269815)



RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - MacUsers - 2016-11-28

(2016-11-28, 06:17)lrusak Wrote: You can run the "createlog" command via ssh, then the zip will appear in /storage/logfiles
createlog worked just fine.
I got the log but how do get it to you? Tried to send you a private msg with the zip but don't see any file attach option in PM as well. Is there any specific thing we do for attaching file?

-S


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - vbat99 - 2016-11-28

Upload log to drop box, Google Drive or the likes, post like in your pm


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - MacUsers - 2016-11-28

(2016-11-28, 08:17)Milhouse Wrote: Can any other AMD RX4x0 users confirm the current state of play with this hardware, is HDMI sound working or not?

I don't have exactly that device but I see another issue playing video with ATI Radeon card. This is the one I have:

Code:
VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Caicos [Radeon HD 6450/7450/8450 / R5 230 OEM] (prog-if 00 [VGA controller])
    Subsystem: PC Partner Limited / Sapphire Technology Caicos [Radeon HD 6450/7450/8450 / R5 230 OEM] (Radeon HD 6450 1 GB DDR3)
    Flags: bus master, fast devsel, latency 0, IRQ 28
    Memory at d0000000 (64-bit, prefetchable) [size=256M]
    Memory at fe9c0000 (64-bit, non-prefetchable) [size=128K]
    I/O ports at c000 [size=256]
    Expansion ROM at 000c0000 [disabled] [size=128K]
    Capabilities: [50] Power Management version 3
    Capabilities: [58] Express Legacy Endpoint, MSI 00
    Capabilities: [a0] MSI: Enable+ Count=1/1 Maskable- 64bit+
    Capabilities: [100] Vendor Specific Information: ID=0001 Rev=1 Len=010 <?>
    Capabilities: [150] Advanced Error Reporting
    Kernel driver in use: radeon

I can hear the sound but no video at all - player starts, sound comes out but it get stuck on the same screen. Is it another issue or I'm doing something wrong/stupid?

-San


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - MacUsers - 2016-11-28

(2016-11-28, 06:17)lrusak Wrote: You can run the "createlog" command via ssh, then the zip will appear in /storage/logfiles

Thanks vbat99! Here is the log:
https://www.dropbox.com/s/4ug0a3elrxs3a4a/log-2016-11-28-20.34.27.zip?dl=0


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - aatoledano - 2016-11-28

(2016-11-28, 21:13)sw4y Wrote:
(2016-11-28, 20:54)aatoledano Wrote: I have an strange problem. Samba is enabled and I can browse Samba from Kodi, but I am unable to browse the libreelec folders from my PC (windows 10) with \\<libreelec IP>. So I wasn't able to browse the update folder and update libreelec. Thank god I could use WinSCP to upload the file, maybe this should be explained on the tutorials as a third alternative.

Had the same problem - this helped me out

https://forum.libreelec.tv/thread-1252.html

Problems with Samba started with version #1018 I guess, at least I first had problems since that version.

Will give it a try, thanks!


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - _matt_ - 2016-11-28

Are there known issues currently with screensavers? Here's a debug log with my attempt at using the Solarwinds screensaver:

http://sprunge.us/MFaE

I just get a black screen.


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Milhouse - 2016-11-29

New LibreELEC.tv Krypton build #1128: Generic
(Supercedes previous build)

Code:
# uname -a
Linux NUC 4.8.11 #1 SMP Mon Nov 28 21:06:15 GMT 2016 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse) - Version: devel-20161128210447-#1128-g4d4fe5d [Build #1128]

# Kodi version
(17.0-BETA6 Git:17.0-beta5-e92818a). Platform: Linux x86 64-bit

Based on tip of LibreELEC.tv master (4d4fe5db, changelog) and tip of XBMC master (c5d944c1, changelog) with the following modifications: Build Highlights:
  1. New Chorus2 web interface
  2. Added pvr.octonet (Digital Devices Octopus NET Client) add-on
  3. Added Synaptics touchpad driver
Build Details:
  1. LibreELEC.tv:
    • packages/linux-drivers/wetekdvb: Update to wetekdvb-20161127 (PR:993, 1 commit, 1 file changed)
  2. XBMC:
    • New default webinterface Chorus2 (PR:10989, 2 commits, 115 files changed)
    • Fix GetFilter SQL for music artists, albums and songs nodes (PR:10974, 1 commit, 3 files changed)
    • Song Info Dialog contributors in control list (PR:10951, 1 commit, 4 files changed)
    • Fix processing of Performer/TMCL/TIPL Tag values (PR:10994, 1 commit, 4 files changed)
    • [Estouchy] Song Info Dialog contributors in control list (PR:11005, 1 commit, 1 file changed)
    • [estuary] sync (PR:11002, 1 commit, 107 files changed)
    • [listprovider] Refresh list when job was not finished (PR:10957, 1 commit, 4 files changed)
    • [DirectoryNodes] override GetChildType() for Episode DirectoryNodes (PR:11007, 1 commit, 2 files changed)
  3. kodi-theme-Estuary:
  4. inputstream.adaptive:
    • fix debian packaging (PR:2, 1 commit, 7 files changed)
    • cleanup (1ac4f839)
  5. pvr.hts:
    • 3.4.10. Adpated to pvr addon api 5.2.1 (3.4.9 was just to ake it compile again). (PR:251, 1 commit, 7 files changed)
  6. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] patch: kodi-binary-addons: pvr.octonet initial package
    • Added: [env] PR:997: xorg-server: add Synaptics driver if using evdev



RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Milhouse - 2016-11-29

(2016-11-28, 23:56)_matt_ Wrote: Are there known issues currently with screensavers? Here's a debug log with my attempt at using the Solarwinds screensaver:

http://sprunge.us/MFaE

I just get a black screen.

The problem is with the addon and the way it is packaged/built for Linux in the Team Kodi repository (ie. this is not a LibreELEC issue):
Code:
15:46:32.022 T:140715961202816   DEBUG: ADDON: Dll Initializing - Solarwinds
15:46:32.022 T:140715961202816   ERROR: ADDON: Could not locate screensaver.rsxs.solarwinds.so.1.3.0

It should be reported to the add-on maintainer.

The following will fix it, al least temporarily until any future add-on update breaks it again:
Code:
cd /storage/.kodi/addons/screensaver.rsxs.solarwinds
mv screensaver.rsxs.solarwinds.so screensaver.rsxs.solarwinds.so.1.3.0



LibreELEC Testbuilds for x86_64 (Kodi 17.0) - lrusak - 2016-11-29

(2016-11-29, 00:45)Milhouse Wrote:
(2016-11-28, 23:56)_matt_ Wrote: Are there known issues currently with screensavers? Here's a debug log with my attempt at using the Solarwinds screensaver:

http://sprunge.us/MFaE

I just get a black screen.

The problem is with the addon and the way it is packaged/built for Linux in the Team Kodi repository (ie. this is not a LibreELEC issue):
Code:
15:46:32.022 T:140715961202816   DEBUG: ADDON: Dll Initializing - Solarwinds
15:46:32.022 T:140715961202816   ERROR: ADDON: Could not locate screensaver.rsxs.solarwinds.so.1.3.0

It should be reported to the add-on maintainer.

The following will fix it, al least temporarily until any future add-on update breaks it again:
Code:
cd /storage/.kodi/addons/screensaver.rsxs.solarwinds
mv screensaver.rsxs.solarwinds.so screensaver.rsxs.solarwinds.so.1.3.0


We package this add-on so it's probably our issue. Not sure if we are installing symlinks or not (not sure of that's needed).


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Milhouse - 2016-11-29

(2016-11-29, 00:49)lrusak Wrote: We package this add-on so it's probably our issue. Not sure if we are installing symlinks or not (not sure of that's needed).

Ah, I thought it was coming from the Team Kodi repo - my bad. And thanks.


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Milhouse - 2016-11-29

Weekly kernel 4.9-rc7 test build #1128x: Generic

Note: Still waiting for an updated 340.xx nvidia-legacy driver, so don't use this build on nvidia-legacy hardware.

You can confirm your Nvidia driver with:
Code:
dmesg | grep "NVIDIA UNIX"
If the reported version is 340.98 then you're using the legacy driver and will want to avoid #1128x.


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - _matt_ - 2016-11-29

(2016-11-29, 00:49)lrusak Wrote:
(2016-11-29, 00:45)Milhouse Wrote:
(2016-11-28, 23:56)_matt_ Wrote: Are there known issues currently with screensavers? Here's a debug log with my attempt at using the Solarwinds screensaver:

http://sprunge.us/MFaE

I just get a black screen.

The problem is with the addon and the way it is packaged/built for Linux in the Team Kodi repository (ie. this is not a LibreELEC issue):
Code:
15:46:32.022 T:140715961202816   DEBUG: ADDON: Dll Initializing - Solarwinds
15:46:32.022 T:140715961202816   ERROR: ADDON: Could not locate screensaver.rsxs.solarwinds.so.1.3.0

It should be reported to the add-on maintainer.

The following will fix it, al least temporarily until any future add-on update breaks it again:
Code:
cd /storage/.kodi/addons/screensaver.rsxs.solarwinds
mv screensaver.rsxs.solarwinds.so screensaver.rsxs.solarwinds.so.1.3.0


We package this add-on so it's probably our issue. Not sure if we are installing symlinks or not (not sure of that's needed).

I tried the ShaderToy screensaver as well. It causes a restart of Kodi every time I try to preview it. Same issue?

http://sprunge.us/QdCY


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Milhouse - 2016-11-29

Upload your crashlog (see note #4, first post)


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - _matt_ - 2016-11-29

Sorry, Milhouse. Here it is (hopefully): http://sprunge.us/AZXe


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Milhouse - 2016-11-29

(2016-11-29, 05:28)_matt_ Wrote: Sorry, Milhouse. Here it is (hopefully): http://sprunge.us/AZXe
Thanks. What version of the screensaver.shadertoy add-on are you using? I suspect the version in the repo may be incompatible, and the last version I uploaded on 1 April certainly is, so it could just be crashing due to some binary incompatibility.

I've uploaded a new version of screensaver.shadertoy here - please install this new #1128 version and see if it works any better.

If it continues to crash, install this debug-enabled build #1128y as this will provide a more informative crashlog.

If you also plan on using visualization.shadertoy be aware that this add-on crashes (crashlog) quite regularly and as there's no way to report issues to the developer my advice is just don't use it.