Kodi Community Forum
v17 LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Linux (https://forum.kodi.tv/forumdisplay.php?fid=52)
---- Thread: v17 LibreELEC Testbuilds for x86_64 (Kodi 17.0) (/showthread.php?tid=269815)



RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - FreakinSyco - 2016-12-01

I'm attempting to update to the most recent release. Looks like my partition is too small for the update on my ChromeBox

/dev/sda1 is 230MB with 8MB free
/dev/sda2 is 14GB with 8GB free

I'm assuming sda1 is the partition I need to resize... is that possible without reinstalling? I see the parted utility is available, but I don't think it's possible to resize a partition while its in use.

I guess I could use a linux image on a USB drive and do it, but before I do all that: Is there an easier way?


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Milhouse - 2016-12-01

Booting from a Linux USB key and using gparted to resize both partitions (shrink and move sda2, expand sda1) is the easiest option. Alternatively backup your data using the LE Settings add-on > Backup option, reinstall from a disk image, then restore your data.


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Milhouse - 2016-12-01

Now that Kodi 17 has branched for release, Kodi 18 test builds continue here: 298462 (thread)

Thanks everyone for all the testing and feedback.


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - TopSideControl - 2016-12-02

so will you have any further builds with the current 17 version?


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Milhouse - 2016-12-02

(2016-12-02, 14:20)TopSideControl Wrote: so will you have any further builds with the current 17 version?

No. Kodi 17 is only going to see (hopefully minor) bug fixes from now on as it progresses towards final release. If you want further Kodi 17 releases then you should switch to the official LibreELEC 8 alpha and beta releases.


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - aatoledano - 2016-12-03

Which is the last version safe to use with an Nvidia Ion? I'm asking because of this comment: "Note: Still waiting for an updated 340.xx nvidia-legacy driver, so don't use this build on nvidia-legacy hardware."


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - dannyau - 2016-12-03

(2016-11-21, 00:59)pacoma2610 Wrote: @Milhouse

TVH PVR Addon can not be activated (Version #1120 TVH #1120) on #1119 work everything correkt

23:56:03.244 T:140440935237696 ERROR: ADDON: Dll Tvheadend HTSP Client - Client returned bad status (6) from Create and is not usable
23:56:05.262 T:140440935237696 ERROR: UpdateAddons - failed to create add-on Tvheadend HTSP Client, status = 6

Is that fix in the latest build?


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Milhouse - 2016-12-03

(2016-12-03, 01:40)dannyau Wrote: Is that fix in the latest build?

Yes, fixed in #1121 (PR:768).


LibreELEC Testbuilds for x86_64 (Kodi 17.0) - blokkie - 2016-12-04

(2016-12-02, 16:35)Milhouse Wrote:
(2016-12-02, 14:20)TopSideControl Wrote: so will you have any further builds with the current 17 version?

No. Kodi 17 is only going to see (hopefully minor) bug fixes from now on as it progresses towards final release. If you want further Kodi 17 releases then you should switch to the official LibreELEC 8 alpha and beta releases.


Where can we find these Libreelec alpha and beta releases?
I'm running beta 5 with autoupdate "on" so I'll just wait and the update will come in time..?


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Milhouse - 2016-12-04

(2016-12-04, 00:37)blokkie Wrote: Where can we find these Libreelec alpha and beta releases?

https://libreelec.tv/

(2016-12-04, 00:37)blokkie Wrote: I'm running beta 5 with autoupdate "on" so I'll just wait and the update will come in time..?

"beta 5" (Kodi 17 Beta 5) is LibreELEC 7.90.008.

7.90.009 will be released in a few days (early next week) and will include Kodi 17 Beta 6.

Your device will update itself automatically once the new build is pushed to the public servers and made available for automatic installation - there's usually a 24 hours "canary period" before new builds are made available for automatic installation. From the LibreELEC 7.0 Beta announcement:

Quote:LibreELEC operates a 24-hour ‘canary’ period between major release files being posted to the download page and the release being available via the auto-update system. This is for two reasons: First, if we find a problem we can pull the files before too many users grab the update. Second, it allows time for the release to propagate among our global network of download mirrors.

If you are running @Milhouse or other community builds your system will not auto-update to the beta release. You must first perform a manual update to the beta release. Your system will then auto-update to any further beta releases (although none are planned) and/or the final v7.0.0 release.



RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - GoodOmens - 2016-12-04

I'm getting a blank screen upon upgrading to the latest version in this thread. Kodi boots with the splash screen then immediately goes to a completely black screen with the mouse icon in the center.

http://sprunge.us/ZACM
http://sprunge.us/chZS
http://sprunge.us/TdPD


Any ideas? I've tried deleting guisettings.xml to no effect.


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - fritsch - 2016-12-04

Mind removing your piracy addons and try again?


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - GrimGriefer - 2016-12-05

Hi Milhouse,

Thanks for your efforts with these nighties.

I've been using multiple versions of your nightlies over the past few weeks with a Zotac EN1070 which features an nVidia GTX 1070 and have these issues from a fresh build.

1) Playback of x264 works fine with the hardware decoder but h.264 10-Bit and x265 always playback with the software decoder.
2) Suspend mode puts the system to sleep but auto turns back on within three seconds. The system dual boots with Windows 10 at the moment and when I put it to sleep in Windows it works fine.
3) When returning from suspend mode the gigabit LAN NIC stops working. A reboot fixes it again.


Any ideas or info I can provide to aid diagnosis?


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Milhouse - 2016-12-05

(2016-12-04, 22:27)GoodOmens Wrote: Any ideas? I've tried deleting guisettings.xml to no effect.

Code:
rm -fr /storage/.kodi/addons/inputstream.*



RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Milhouse - 2016-12-05

(2016-12-05, 00:11)GrimGriefer Wrote: Hi Milhouse,

Thanks for your efforts with these nighties.

I've been using multiple versions of your nightlies over the past few weeks with a Zotac EN1070 which features an nVidia GTX 1070 and have these issues from a fresh build.

1) Playback of x264 works fine with the hardware decoder but h.264 10-Bit and x265 always playback with the software decoder.
2) Suspend mode puts the system to sleep but auto turns back on within three seconds. The system dual boots with Windows 10 at the moment and when I put it to sleep in Windows it works fine.
3) When returning from suspend mode the gigabit LAN NIC stops working. A reboot fixes it again.


Any ideas or info I can provide to aid diagnosis?

1) 10-bit hardware decode is not yet supported - work-in-progress
2) not sure, are you on the latest BIOS etc. for your hardware?
3) again not sure, possibly related to #2

Presumably suspend/resume has never worked for you with any of my test builds? Have you tried the 4.9-rc7 test build #1128x? Also make sure you try #1203 as that includes the latest nvidia driver.