Kodi Community Forum
v17 LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Linux (https://forum.kodi.tv/forumdisplay.php?fid=52)
---- Thread: v17 LibreELEC Testbuilds for x86_64 (Kodi 17.0) (/showthread.php?tid=269815)



RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - sunnyfunny - 2016-05-19

(2016-05-19, 07:44)the-dreamer Wrote: this patch seems to be working. braswell is not freezing anymore so far.

Best news today Cool


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - cypher242 - 2016-05-19

(2016-05-19, 00:39)startv Wrote:
(2016-05-18, 23:52)Milhouse Wrote: Braswell owners please test #0518. This includes a fix that should eventually appear in kernel 4.6.1.
#0518 running more than 30 mins, all fine.
@Milhouse,@fritsch thank you.
same here, thank you!


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - MariusB - 2016-05-19

(2016-05-18, 23:52)Milhouse Wrote: Braswell owners please test #0518. This includes a fix that should eventually appear in kernel 4.6.1.

I will test on my NUC in coming days and will let you know.
Responses from other Braswell owners look promising.


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - john.cord - 2016-05-19

(2016-05-17, 21:58)Roby77 Wrote: really strange no issue for me on braswell n3150 in 8 day testing...

funny

check my signature. I dont use braswell devices...


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Roby77 - 2016-05-19

ah ok but we were speaking about braswell kernel bug, my friend with chromebox also no problem and it use it in shop 12/7

sorry for misunderstanding


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Wingfat - 2016-05-19

(2016-05-18, 23:52)Milhouse Wrote: Braswell owners please test #0518. This includes a fix that should eventually appear in kernel 4.6.1.

All systems nominal : NUC 5PPYH Braswell Pentium N3700 Build #0518

Thank You so much..


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - m_gl - 2016-05-19

(2016-05-19, 08:38)Milhouse Wrote: Is auto-repeat still an issue with #0518?

Auto-repeat is still broken with #518
Gpu hang seems fixed, nice!! Big Thx.


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - lazyman - 2016-05-19

FernetMenta recommended to go Kryton for solving my pvr/vdr problems. Therefore one question regarding this form post #1

Quote:You need a working system in order to install a test build.

I am currently on OE7.0.b3 and want to install a LE krypton generic build (on nuc and ASRock V3D, nvidia). Do I need to first upgrade to LE7.0 ("a working _LibreELEC_ system") and after that go for the testbuilds? Or will a straight OE to LE testbuild approach work, too?

Thanks


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Milhouse - 2016-05-19

OE (any version) to LE (any version, including these test builds) will work just fine.


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - lazyman - 2016-05-19

thanks for clarifying, Milhouse!


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Roby77 - 2016-05-19

Damn, kernel 4.6 and for me black screen bug after stop a movie return back

Have to wait 20/30 seconds for handshake again (edid forced in tv+avr config)

I have ordered dr hdmi to see if problem still occur


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - fritsch - 2016-05-19

(2016-05-19, 22:42)Roby77 Wrote: Damn, kernel 4.6 and for me black screen bug after stop a movie return back

Have to wait 20/30 seconds for handshake again (edid forced in tv+avr config)

I have ordered dr hdmi to see if problem still occur

And all the rcs were fine? I cannot believe that.


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Roby77 - 2016-05-19

No you are right

Me as Sherlock find out that to another user with same problem you linked that

https://bugs.freedesktop.org/show_bug.cgi?id=93714

In reply of
2223462 (post)

Sadly maybe with dr hdmi i will not solve using it

And my avr is not so guilty

Sherlock mode off Wink


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Milhouse - 2016-05-19

New LibreELEC.tv Krypton build #0519: Generic
(Supercedes previous build)

Code:
# uname -a
Linux LibreELEC 4.6.0 #1 SMP Thu May 19 21:07:51 BST 2016 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse) - Version: devel-20160519210544-#0519-g2f86163 [Build #0519]

Based on tip of LibreELEC.tv master (2f86163b, changelog) and tip of XBMC master (c603f070, changelog) with the following modifications: Build Highlights:
  1. NOTE: DVD playback remains temporarily disabled
  2. Updated LibreELEC Settings add-on - now Estuary compliant.
  3. HSW fix: drm/i915/psr: Try to program link training times correctly
Build Details:
  1. LibreELEC.tv:
    • LibreELEC-settings: update to latest master (PR:360, 1 commit, 1 file changed)
    • script.moonlight: initial add-on (PR:299, 6 commits, 8 files changed)
    • settings: bump to 0.8.0 (PR:361, 1 commit, 1 file changed)
    • LibreELEC-settings: drop obsolete patch (PR:363, 1 commit, 1 file changed)
    • docker: add kodi notifications (PR:356, 1 commit, 6 files changed)
    • connman: remove temp-fix-kernel-headers-bug patch (PR:365, 1 commit, 1 file changed)
  2. XBMC:
    • [addon] binary add-on library rework for API level system (PR:9659, 11 commits, 476 files changed)
    • [win32][test] Fix linking of the test suite (PR:9810, 1 commit, 2 files changed)
    • Fix using albumartist tag rather than artist (PR:9837, 1 commit, 1 file changed)
    • [linux] redirect stderr when calling lsb_release fixes #16729 (PR:9832, 1 commit, 1 file changed)
    • [cmake] Force Python version to 2.7 (PR:9818, 1 commit, 1 file changed)
    • fix 'unknown sources' setting visibility when opened from dialog (PR:9830, 2 commits, 4 files changed)
    • [network] CWebServer: fix bad log messages (a49f32c3)
  3. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [pkg] patch: drm/i915/psr: Try to program link training times correctly (HSW fix) (linux)



RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - john.cord - 2016-05-20

(2016-05-19, 12:40)Roby77 Wrote: ah ok but we were speaking about braswell kernel bug, my friend with chromebox also no problem and it use it in shop 12/7

sorry for misunderstanding

with a media database shared vie network and a mysql database serverHuh

The choppy playback issue is still present with current build. I can trigger it by playing a file and stop it. After resuming the File i get choppy playback with dropped frames after a few seconds. I will capture a log tomorrow asap.