Kodi Community Forum
v17 LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Linux (https://forum.kodi.tv/forumdisplay.php?fid=52)
---- Thread: v17 LibreELEC Testbuilds for x86_64 (Kodi 17.0) (/showthread.php?tid=269815)



RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Roby77 - 2016-05-26

Seems that my problem it's worse LOL

Now i get black screen random also at start of a film

Btw captured new log that show a black screen of two minuts after movie stop

Log http://xbmclogs.com/pkne1vfty

Film.stopped.at 00.38.xx.and screen reappeared at 00
40.xx

There are several errors reported


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - fritsch - 2016-05-26

It's a kernel bug which has nothing to do with kodi. So in your case, we always need dmesg | pastebinit - best booted with drm.debug=0xe - you can always add a copy to your fdo bugreport.


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - fritsch - 2016-05-26

@John.cord: This should fix your issue: https://github.com/FernetMenta/xbmc/commit/47230c83b1c70a89299be45303e6b36295f26dc8


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Roby77 - 2016-05-26

(2016-05-26, 07:44)fritsch Wrote: It's a kernel bug which has nothing to do with kodi. So in your case, we always need dmesg | pastebinit - best booted with drm.debug=0xe - you can always add a copy to your fdo bugreport.

thank you @fritsch as always Blush


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Roby77 - 2016-05-26

Having same problem with 0509x (4.4.7) so maybe a file get corrupted /system dirty or avr get drunked definetely Big Grin

Now i'm curious to test win10 next days


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - livs - 2016-05-26

Something different as problem:
I have an htpc with MSI FM2 + A6 and I update from OE (I dont recall the version) to #522 of LE.
The strange thing is after this I have a bootloop.
I manage to boot the system in a laptop with old AMD and hdd from htpc as usb drive.
Is a kernel issue related to AMD or something else?

I have no logs.


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - john.cord - 2016-05-26

(2016-05-26, 12:15)fritsch Wrote: @John.cord: This should fix your issue: https://github.com/FernetMenta/xbmc/commit/47230c83b1c70a89299be45303e6b36295f26dc8

ok thx, i will test it as soon as a updated build is posted by milhouse


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Milhouse - 2016-05-27

New LibreELEC.tv Krypton build #0526: Generic
(Supercedes previous build)

Code:
# uname -a
Linux LibreELEC 4.6.0 #1 SMP Thu May 26 21:07:09 BST 2016 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse) - Version: devel-20160526210501-#0526-g454d0a5 [Build #0526]

Based on tip of LibreELEC.tv master (454d0a54, changelog) and tip of XBMC master (c34d9e80, changelog) with the following modifications:
  • Includes FernetMenta "VideoPlayer" patches
  • Includes latest kodi-platform master (c8188d82, ahead +4)
  • Includes latest libcec master (6d68d212)
  • Includes latest libnfs master (00d9ba15, ahead +19)
  • Includes latest p8-platform master (041a8c6c, ahead +1)
  • Includes latest addons: adsp.basic (2ae604e5, +8), adsp.biquad.filters (01236bbe, +7), adsp.freesurround (34f50406, +7), asplib (da66f517), inputstream.mpd (3ac19c39, +11), inputstream.smoothstream (32275717, +2), peripheral.joystick (83371862, +30), pvr.argustv (5f48dcec, +4), pvr.demo (0fa9e1d0, +4), pvr.dvblink (a92f1264, +5), pvr.dvbviewer (3d0bea9a, +4), pvr.filmon (8743511d, +4), pvr.hdhomerun (b5ce9309, +4), pvr.hts (acd1a6ac, +5), pvr.iptvsimple (7a5a43f8, +4), pvr.mediaportal.tvserver (172a273c, +4), pvr.mythtv (e2b60252, +8), pvr.nextpvr (150698b7, +4), pvr.njoy (b5d65655, +4), pvr.pctv (feed5990, +4), pvr.stalker (4244220f, +12), pvr.vbox (c6594819, +4), pvr.vdr.vnsi (5498a8c1, +7), pvr.vuplus (ea3b33f6, +4), pvr.wmc (77af8daf, +4)
  • Includes commits from xbmc/master, ahead +8 (FernetMenta)
  • Exclude [env] kodi-999.10-aarch64-support.patch: Merged upstream
  • Include [env] e7cbe9cb: xf86-video-intel: Explicitely disable TearFree and TripleBuffer
  • Include [env] ed774729: Intel: Implement Passthrough-Range
  • Include [env] 98c65e6a: Kodi: Use Limited Range by default
  • Include [env] patch: xf86-video-intel: bump to 3fafabe
  • Include [env] patch: Fix SIGTERM patch after PR9748
  • Include [env] patch: Fix cmake after PR9750
  • Include [env] patch: Add extra headers needed by 3D BD MVC
  • Include [env] patch: Disable -werror as libnfs won't build 32-bit without it
  • Include [env] patch: Bump libbluray - include MVC support
  • Include [env] patch: Add experimental splash video for RPi
  • Include [env] patch: HACK: Disable multiple PVR addons during migration. Always enable inputstream.*, os.* and peripheral.*
  • Include [env] patch: Enable pvr addons, disable pvr updates
  • Include [env] patch: Enable other binary addons
  • Include [env] PR:353: plymouth-lite: add bilinear interpolation patch
  • Include [env] PR:366: mysql: update to 5.7.12
  • Include [env] PR:381: splash: Select splash image based on native resolution
  • Include [env] PR:382: systemd: update to 230
  • Include [env] PR:388: xf86-video-nvidia: update to xf86-video-nvidia-361.42
  • Revert [env] 46b9b7b3: rtmpdump (Reason: use newclock5 bump)
  • Include [pkg] dd81c2f1: [librtmp] Update to 15-Dec-2015 from http://stream-recorder.com/forum/customized-rtmpdump-binaries-patch-file-t16103.html (kodi)
  • Include [pkg] 441217d8: logging: Add microsecond timer to log messages (kodi)
  • Include [pkg] patch: [skin.estuary] Hide watched items on home (kodi-theme-Estuary)
  • Include [pkg] patch: drm/i915: Extend Fake HDMI live status to Valley View (linux)
  • Include [pkg] patch: drm/i915/psr: Try to program link training times correctly (HSW fix) (linux)
  • Include [pkg] patch: Revert "drm/i915: Exit cherryview_irq_handler() after one pass" (BSW fix) (linux)
  • Include [pkg] patch: CSC: Remove average logic when saving NV12 surface on IVB+ (VAAPI fix) (libva-intel-driver)
  • Include [pkg] PR:8645: [video] Add season/TV show artwork to episodes/seasons even if they have their own fanart.
  • Include [pkg] PR:8824: videodb: fix smart playlists not honoring "Show empty TV shows" setting.
  • Include [pkg] PR:8922: [guiinfo] extend ranges for listitem properties
  • Include [pkg] PR:9803: [PeripheralCecAdapter] fix playback stopping on screensaver deactivated
  • Include [pkg] PR:9847: [PVR] Feature: Make instant recording behavior configurable
Build Highlights:
  1. NOTE: DVD playback remains temporarily disabled
  2. Drop Roby77 vblank patch
Build Details:
  1. LibreELEC.tv:
    • nvidia: Enable USLEEP to reduce CPU load while rendering (PR:393, 1 commit, 1 file changed)
  2. XBMC:
    • [PVR] Fix deadlock in PVR channel window. (PR:9880, 1 commit, 5 files changed)
    • [cmake][Windows] Fix wrong output directory of add-on callback libraries for Windows (PR:9868, 1 commit, 1 file changed)
    • [guilib] remove deprecated controls (PR:9848, 5 commits, 21 files changed)
  3. xbmc/master (FernetMenta):
    • New commits in this build:
      • VideoPlayer: fix CheckEnableClockSync (47230c83)
      • VideoPlayer: remove some useless code (3c554a61)
      • VideoPlayer: improve skipping frames (7712899e)



RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - flipside101 - 2016-05-27

HI I've been playing with the LE8 builds since I tested Irusaks Retroplayer build . I had an issue where the game addons where marked as incompatible and to fix I had to hard reset. This fixed the issue but stopped the IR remote from working . I came to millhouses build to double check if it was something to do with the retroplayer and found the same issue after a full reset. I've been seeing if a side by side comparison of the logs from a working version and non working could show me the issue but im afraid I'm a little out of my depth. Can anyone have a look and see if you can point me in the right direction.

Build 523 IR not working
LOG - http://xbmclogs.com/pgg9floz4
DMESG - http://xbmclogs.com/peyquyerh
LSUSB - http://xbmclogs.com/paao17miw

Build 523 IR working
LOG - http://xbmclogs.com/pv9sh8aqy
DMESG - http://xbmclogs.com/p6ft8ktce
LSUSB - http://xbmclogs.com/pat3y21qd


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - number6 - 2016-05-27

Hi, first time poster, long time lurker...
I wonder if there are news on when DVD playback will be working again?
Apologize if it's the wrong place or the wrong question to ask, it's just that I'm itching to test LE+Krypton, and even with OE 6.0.398-Intel_EGL (which I currently use) DVDs drop frames like hell (maybe false positive, but I do notice some playback issue). tbh, I've always had some kind of problems with DVDs in every Kodi version I've used.
Anyway, back to the question: did I choose the wrong day to sell my DVD player? Smile


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Roby77 - 2016-05-27

Why don't you just convert your dvd to avi, mkv etc ?

(Yes i don't like dvd menĂ¹ Big Grin)

Btw last build less problem for me

Thank you


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Milhouse - 2016-05-28

New LibreELEC.tv Krypton build #0527: Generic
(Supercedes previous build)

Code:
# uname -a
Linux LibreELEC 4.6.0 #1 SMP Fri May 27 21:05:35 BST 2016 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse) - Version: devel-20160527210329-#0527-g454d0a5 [Build #0527]

Based on tip of LibreELEC.tv master (454d0a54, changelog) and tip of XBMC master (e18bd8d8, changelog) with the following modifications:
  • Includes FernetMenta "VideoPlayer" patches
  • Includes latest kodi-platform master (c8188d82, ahead +4)
  • Includes latest libcec master (6d68d212)
  • Includes latest libnfs master (00d9ba15, ahead +19)
  • Includes latest p8-platform master (041a8c6c, ahead +1)
  • Includes latest addons: adsp.basic (2ae604e5, +8), adsp.biquad.filters (01236bbe, +7), adsp.freesurround (34f50406, +7), asplib (da66f517), inputstream.mpd (3ac19c39, +11), inputstream.smoothstream (32275717, +2), peripheral.joystick (83371862, +30), pvr.argustv (5f48dcec, +4), pvr.demo (0fa9e1d0, +4), pvr.dvblink (a92f1264, +5), pvr.dvbviewer (3d0bea9a, +4), pvr.filmon (8743511d, +4), pvr.hdhomerun (b5ce9309, +4), pvr.hts (acd1a6ac, +5), pvr.iptvsimple (7a5a43f8, +4), pvr.mediaportal.tvserver (172a273c, +4), pvr.mythtv (e2b60252, +8), pvr.nextpvr (150698b7, +4), pvr.njoy (b5d65655, +4), pvr.pctv (feed5990, +4), pvr.stalker (4244220f, +12), pvr.vbox (c6594819, +4), pvr.vdr.vnsi (5498a8c1, +7), pvr.vuplus (ea3b33f6, +4), pvr.wmc (77af8daf, +4)
  • Includes commits from xbmc/master, ahead +8 (FernetMenta)
  • Exclude [env] kodi-999.10-aarch64-support.patch: Merged upstream
  • Include [env] e7cbe9cb: xf86-video-intel: Explicitely disable TearFree and TripleBuffer
  • Include [env] ed774729: Intel: Implement Passthrough-Range
  • Include [env] 98c65e6a: Kodi: Use Limited Range by default
  • Include [env] patch: xf86-video-intel: bump to 3fafabe
  • Include [env] patch: Fix SIGTERM patch after PR9748
  • Include [env] patch: Fix cmake after PR9750
  • Include [env] patch: Add extra headers needed by 3D BD MVC
  • Include [env] patch: Disable -werror as libnfs won't build 32-bit without it
  • Include [env] patch: Bump libbluray - include MVC support
  • Include [env] patch: Add experimental splash video for RPi
  • Include [env] patch: HACK: Disable multiple PVR addons during migration. Always enable inputstream.*, os.* and peripheral.*
  • Include [env] patch: Enable pvr addons, disable pvr updates
  • Include [env] patch: Enable other binary addons
  • Include [env] PR:353: plymouth-lite: add bilinear interpolation patch
  • Include [env] PR:366: mysql: update to 5.7.12
  • Include [env] PR:381: splash: Select splash image based on native resolution
  • Include [env] PR:382: systemd: update to 230
  • Include [env] PR:388: xf86-video-nvidia: update to xf86-video-nvidia-361.42
  • Revert [env] 46b9b7b3: rtmpdump (Reason: use newclock5 bump)
  • Include [pkg] dd81c2f1: [librtmp] Update to 15-Dec-2015 from http://stream-recorder.com/forum/customized-rtmpdump-binaries-patch-file-t16103.html (kodi)
  • Include [pkg] 441217d8: logging: Add microsecond timer to log messages (kodi)
  • Include [pkg] patch: [skin.estuary] Hide watched items on home (kodi-theme-Estuary)
  • Include [pkg] patch: drm/i915: Extend Fake HDMI live status to Valley View (linux)
  • Include [pkg] patch: drm/i915/psr: Try to program link training times correctly (HSW fix) (linux)
  • Include [pkg] patch: Revert "drm/i915: Exit cherryview_irq_handler() after one pass" (BSW fix) (linux)
  • Include [pkg] patch: CSC: Remove average logic when saving NV12 surface on IVB+ (VAAPI fix) (libva-intel-driver)
  • Include [pkg] PR:8645: [video] Add season/TV show artwork to episodes/seasons even if they have their own fanart.
  • Include [pkg] PR:8824: videodb: fix smart playlists not honoring "Show empty TV shows" setting.
  • Include [pkg] PR:8922: [guiinfo] extend ranges for listitem properties
  • Include [pkg] PR:9803: [PeripheralCecAdapter] fix playback stopping on screensaver deactivated
  • Include [pkg] PR:9847: [PVR] Feature: Make instant recording behavior configurable
Build Highlights:
  1. NOTE: DVD playback remains temporarily disabled
  2. Minors
Build Details:
  1. XBMC:
    • [PVR] add recording id to recording path (PR:9879, 1 commit, 3 files changed)



RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Milhouse - 2016-05-28

(2016-05-27, 21:58)flipside101 Wrote: HI I've been playing with the LE8 builds since I tested Irusaks Retroplayer build . I had an issue where the game addons where marked as incompatible and to fix I had to hard reset. This fixed the issue but stopped the IR remote from working . I came to millhouses build to double check if it was something to do with the retroplayer and found the same issue after a full reset. I've been seeing if a side by side comparison of the logs from a working version and non working could show me the issue but im afraid I'm a little out of my depth. Can anyone have a look and see if you can point me in the right direction.

Build 523 IR not working
LOG - http://xbmclogs.com/pgg9floz4
DMESG - http://xbmclogs.com/peyquyerh
LSUSB - http://xbmclogs.com/paao17miw

Build 523 IR working
LOG - http://xbmclogs.com/pv9sh8aqy
DMESG - http://xbmclogs.com/p6ft8ktce
LSUSB - http://xbmclogs.com/pat3y21qd

Unfortunately your Kodi logs are indecipherable as you've posted a folder full of logs.

Can you clarify what you mean by "hard/full reset" - do you mean you re-installed from img? Or executed the hard reset function in the Settings addon? Or something else?

In the "not working" lsusb I see the following devices:
Code:
Bus 002 Device 011: ID 06cb:0009 Synaptics, Inc. Composite TouchPad and TrackPoint
Bus 002 Device 010: ID 04b3:3019 IBM Corp.
Bus 002 Device 009: ID 04b3:3016 IBM Corp. UltraNav Keyboard Hub
These aren't present in the "working" system - were you blacklisting or otherwise disabling these devices previously?

I don't see the above devices present in the "working" dmesg either, but they are present in the "non-working" system, so as long as you can disable or not connect these devices then maybe your IR will work.


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Milhouse - 2016-05-28

(2016-05-27, 22:39)number6 Wrote: I wonder if there are news on when DVD playback will be working again?

It was fixed 2 weeks ago but I thought I'd keep it to myself. j/k

No, there's no news. That's why the last release continues to announce there is no DVD support.


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - flipside101 - 2016-05-28

(2016-05-28, 00:35)Milhouse Wrote:
(2016-05-27, 21:58)flipside101 Wrote: HI I've been playing with the LE8 builds since I tested Irusaks Retroplayer build . I had an issue where the game addons where marked as incompatible and to fix I had to hard reset. This fixed the issue but stopped the IR remote from working . I came to millhouses build to double check if it was something to do with the retroplayer and found the same issue after a full reset. I've been seeing if a side by side comparison of the logs from a working version and non working could show me the issue but im afraid I'm a little out of my depth. Can anyone have a look and see if you can point me in the right direction.

Build 523 IR not working
LOG - http://xbmclogs.com/pgg9floz4
DMESG - http://xbmclogs.com/peyquyerh
LSUSB - http://xbmclogs.com/paao17miw

Build 523 IR working
LOG - http://xbmclogs.com/pv9sh8aqy
DMESG - http://xbmclogs.com/p6ft8ktce
LSUSB - http://xbmclogs.com/pat3y21qd

Unfortunately your Kodi logs are indecipherable as you've posted a folder full of logs.

Can you clarify what you mean by "hard/full reset" - do you mean you re-installed from img? Or executed the hard reset function in the Settings addon? Or something else?

In the "not working" lsusb I see the following devices:
Code:
Bus 002 Device 011: ID 06cb:0009 Synaptics, Inc. Composite TouchPad and TrackPoint
Bus 002 Device 010: ID 04b3:3019 IBM Corp.
Bus 002 Device 009: ID 04b3:3016 IBM Corp. UltraNav Keyboard Hub
These aren't present in the "working" system - were you blacklisting or otherwise disabling these devices previously?

I don't see the above devices present in the "working" dmesg either, but they are present in the "non-working" system, so as long as you can disable or not connect these devices then maybe your IR will work.

EDIT 4 - reset to LE 7.01 booting from USB and writing a new image , FLIRC is working , will try an upgrade

EDIT 5 - OK after time response degraded. Time to try other avenues

OK I think I see what you mean by a folder full of logs. I cut and paste the full text from the kodi.log file in the zip create in the Log directory as I thought that's what the Log uploaded did, but looking again this includes a number of log traces rather than just one. I cut and paste as I thought I'd save time and do it whilst the TV the LE box is attached to was in use. I'll edit and just use the last log trace in the kodi.log file.

By soft/hard reset I'm referring to the items of the same in the libreelec settings - system menu . All upgrades have been done my placing the new build into the upgrade folder and rebooting

The USB devices present are the keyboard I have to directly attach after the reset to be able to use LE no Ir/Bluetooth remote functions work and until I get past the initial setup I can't use IP based remotes either.

I have just borrowed an FLIRC dangle and am going to test with that