Kodi Community Forum
v17 LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Linux (https://forum.kodi.tv/forumdisplay.php?fid=52)
---- Thread: v17 LibreELEC Testbuilds for x86_64 (Kodi 17.0) (/showthread.php?tid=269815)



RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - mule1 - 2016-06-01

(2016-06-01, 06:11)fritsch Wrote: Please reproduce once again, but this time please enable debug logging before starting. As I don't see which audio device it wanted to open.
Now with debug logging enabled:
http://pastebin.com/Yz2gZ1M6

Edit: Just had a look at the log. Am I right that Kodi chooses the wrong ALSA device (1 instead of 2) although device 2 has been setup under system/audio?


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - _Spook_ - 2016-06-01

Not getting any sound on the NUC6i7KYK.

Logs:
LibreELEC (community) Version: devel-20160531210311-#0531-gb6370f0
LibreELEC git: b6370f0cbda27c171cc8d0080745ea32d8cb661f
LibreELEC:~ # dmesg |paste
http://sprunge.us/JGDT
LibreELEC:~ # cat /storage/.kodi/temp/kodi.log | pastebinit
http://sprunge.us/OLHT
LibreELEC:~ #
LibreELEC:~ #


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Milhouse - 2016-06-01

(2016-06-01, 21:53)_Spook_ Wrote: Not getting any sound on the NUC6i7KYK.

Have you ever had sound on the NUC6i7KYK? If so, is #0531 the first build without sound? The only significant change is the mesa bump. Can you confirm you have sound with #0530.


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - _Spook_ - 2016-06-01

I tried the 0530 build first. No sound. I got the box today so haven't had a chance to play much with it. Just moved the drive from my NUC6i5SYK to test.

EDIT: I did not expect it work straight away. I will get an extra SSD and memory tomorrow so I can try a clean install just to be sure. But don't think it will work until 4.7 kernel.


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Milhouse - 2016-06-01

New LibreELEC.tv Krypton build #0601: Generic
(Supercedes previous build)

Code:
# uname -a
Linux LibreELEC 4.6.0 #1 SMP Wed Jun 1 21:05:51 BST 2016 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse) - Version: devel-20160601210320-#0601-gb4f3545 [Build #0601]

Based on tip of LibreELEC.tv master (b4f3545f, changelog) and tip of XBMC master (97039b48, changelog) with the following modifications: Build Highlights:
  1. NOTE: DVD ISO/disk playback remains temporarily disabled
  2. gcc, python, systemd, mysql updates (clean build)
Build Details:
  1. LibreELEC.tv:
    • gcc: compile with -std=gnu++98 to fix build with gcc6 (PR:384, 1 commit, 1 file changed)
    • Python: don't build curses and readline modules for host (PR:390, 1 commit, 1 file changed)
    • systemd: update to 230 (PR:382, 1 commit, 4 files changed)
    • mysql: update to 5.7.12 (PR:366, 1 commit, 4 files changed)
  2. XBMC:
    • [PVR] Feature: Make instant recording behavior configurable (PR:9847, 4 commits, 12 files changed)
    • Add-on helper: add foreign buildsystem support (PR:9829, 2 commits, 1 file changed)
    • [cmake] Cosmetics: change commands to lowercase (PR:9833, 5 commits, 18 files changed)
    • configure.ac: do not check for libpng (PR:9850, 1 commit, 1 file changed)
    • configure.ac:Changing android ndk directory existence test (PR:9873, 1 commit, 1 file changed)
    • [cmake] get rid of ManageString.cmake (PR:9878, 1 commit, 4 files changed)
    • [texturepacker] Updated texturepacker to vs2015 and all libs with it, remove dependen… (PR:9856, 1 commit, 14 files changed)
    • [cmake] Reuse version.txt and add-on API parsing across buildsystems (PR:9845, 1 commit, 2 files changed)
    • [depends] lzo 2.09 (PR:9789, 1 commit, 2 files changed)
    • [depends] giflib 2.1.4 (PR:9790, 1 commit, 1 file changed)
    • SendClick() should operate on the focused window/dialog (PR:9884, 1 commit, 1 file changed)
    • fix library-music settings label (PR:9890, 1 commit, 1 file changed)
  3. peripheral.joystick:
    • Fix build on windows (099d406e)
    • [buttonmaps] Add missing analog stick directions to linux buttonmaps (2db8029e)
  4. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] PR:405: init: Parse resolution after splash.conf



RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - john.cord - 2016-06-01

With the latest builds i dont get that choppy video playback error via normal Plaback. But if i enable the NextUp Addon (228435 (thread)) and start the next Episode of a TV Show via the On Screen Popin displayed by the Addon i got the Issue again. Constantly dropped frames and choppy Plaback.

After that happend i tried to reproduce the issue with debug logging enabled but no luck. I did exactly the same as before except that i started the video, skipped to the end and waited for the NextUp Addon Popin and pressed the Play Button. Before tryin to reproduce i watched two episodes without skipping. Maybe that made a differnece?


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Roby77 - 2016-06-02

About playback choppy i had this problem solved in 0509X fixed by PR:9778

That come back again in last build, anyone noticed it ?

Edit: no issue with 601


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - john.cord - 2016-06-02

I think there is a problem in the way Kodi reads Data for Video Playback. My Setup is a NAS with some internal and some external Harddrives. I used this without problems for a long time.

With current Libreelec Builds there is a problem if i pause a video (read fom a external harddrive) for a longer period of time. I thinkt the harddrive spins down and if playback is continued the drive spins up but kodi does not read the data correctly. I tested this and the Value at codec info for "forward" is at 100% before pausing, after unpausing the value is 2% and i get choppy plaback/dropped frames.

I will try to reproduce this tomorrow after some sleep. :-)

EDIT: Seagate Tool says that the HDD is set to no spindown. Funny.


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - _Spook_ - 2016-06-02

So an update on the NUC6i7KYK and no sound issue.

I did a clean install of Libreelec 7.9.0.001 Alpha and the udate to #0601. And the only way I can get sound is if I set Speaker channels to 2.0. If I set it to anything else there is no sound on any videos. I get GUI sound though. So strange issue.

New logs:
LibreELEC (community) Version: devel-20160601210320-#0601-gb4f3545
LibreELEC git: b4f3545fd7a85c7fcac25567f146e06eafa3342c
NUCTest:~ # dmesg | paste
http://sprunge.us/fHZe
NUCTest:~ # cat /storage/.kodi/temp/kodi.log | paste
http://sprunge.us/EjDd
NUCTest:~ #


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - john.cord - 2016-06-02

Today i tried everything to reproduce the problem but no luck. The only thing i noticed is that the "Forward" Value in the Codec Info Overlay is 100% before i pause the video and 2% after i unpause the video. After a skip of 10sek the value gets back to 100%.


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Milhouse - 2016-06-03

New LibreELEC.tv Krypton build #0602: Generic
(Supercedes previous build)

Code:
# uname -a
Linux LibreELEC 4.6.0 #1 SMP Thu Jun 2 21:05:25 BST 2016 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse) - Version: devel-20160602210319-#0602-gb4f3545 [Build #0602]

Based on tip of LibreELEC.tv master (b4f3545f, changelog) and tip of XBMC master (91a1cd50, changelog) with the following modifications: Build Highlights:
  1. NOTE: DVD ISO/disk playback remains temporarily disabled
  2. Minors
Build Details:
  1. XBMC:
    • [cmake] Make CMake aware of textfiles that configure the build (PR:9876, 1 commit, 3 files changed)
    • [cmake] KodiConfig.cmake is the name (PR:9894, 1 commit, 2 files changed)
    • [cmake] Code block termination cleanup (PR:9893, 3 commits, 13 files changed)
    • Add a method to retrieve video tags (PR:7369, 1 commit, 6 files changed)
  2. pvr.stalker:
    • vs2015 fixes (PR:63, 1 commit, 2 files changed)



RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - mule1 - 2016-06-03

(2016-06-01, 08:02)mule1 Wrote:
(2016-06-01, 06:11)fritsch Wrote: Please reproduce once again, but this time please enable debug logging before starting. As I don't see which audio device it wanted to open.
Now with debug logging enabled:
http://pastebin.com/Yz2gZ1M6

Edit: Just had a look at the log. Am I right that Kodi chooses the wrong ALSA device (1 instead of 2) although device 2 has been setup under system/audio?
@fritsch: Could you please have a look at the log. Any idea what's going on?


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - fritsch - 2016-06-03

(2016-06-03, 15:58)mule1 Wrote:
(2016-06-01, 08:02)mule1 Wrote:
(2016-06-01, 06:11)fritsch Wrote: Please reproduce once again, but this time please enable debug logging before starting. As I don't see which audio device it wanted to open.
Now with debug logging enabled:
http://pastebin.com/Yz2gZ1M6

Edit: Just had a look at the log. Am I right that Kodi chooses the wrong ALSA device (1 instead of 2) although device 2 has been setup under system/audio?
@fritsch: Could you please have a look at the log. Any idea what's going on?

Anything you are running on the machine? mpd / other audio apps? The issue goes away if you disable Adjust Refreshrate to match video?


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - mule1 - 2016-06-03

There is nothing additional being installed/running on the machine besides libreelec itself and some kodi addons. "Adjust refreshrate to display" has never been enabled.


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Milhouse - 2016-06-04

New LibreELEC.tv Krypton build #0603: Generic
(Supercedes previous build)

Code:
# uname -a
Linux LibreELEC 4.6.1 #1 SMP Fri Jun 3 23:36:01 BST 2016 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse) - Version: devel-20160603232424-#0603-gb4f3545 [Build #0603]

Based on tip of LibreELEC.tv master (b4f3545f, changelog) and tip of XBMC master (0a4f29e8, changelog) with the following modifications: Build Highlights:
  1. NOTE: DVD ISO/disk playback remains temporarily disabled
  2. New 4.6.1 kernel
  3. libnfs fixes (32-bit/gcc-5.3.0 build issues)
Build Details:
  1. XBMC:
    • VideoPlayer: init ffmpeg threads like LAVFilters does (PR:9899, 1 commit, 1 file changed)
    • Stop scanning directory if scan is cancelled. (PR:9620, 1 commit, 1 file changed)
    • VideoPlayer: remove now unused header from ffmepg (PR:9900, 1 commit, 1 file changed)
    • [builtins] fix build without non-free (PR:9901, 1 commit, 1 file changed)
    • Mrmc backports (PR:9858, 5 commits, 3 files changed)
    • Refresh controller profiles in gui thread (and 2 small improvements) (PR:9824, 3 commits, 5 files changed)
  2. libnfs:
    • For upstream (PR:150, 7 commits, 9 files changed)
  3. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] patch: Reset framebuffer from within Kodi
    • Added: [env] PR:408: Fix digital audio crackling when playing music on non Kodi based setups.
    • Added: [env] PR:410: linux: update to linux-4.6.1