Kodi Community Forum
v17 LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Linux (https://forum.kodi.tv/forumdisplay.php?fid=52)
---- Thread: v17 LibreELEC Testbuilds for x86_64 (Kodi 17.0) (/showthread.php?tid=269815)



RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Milhouse - 2016-06-18

New LibreELEC.tv Krypton build #0618: Generic
(Supercedes previous build)

Code:
# uname -a
Linux LibreELEC 4.6.2 #1 SMP Sat Jun 18 21:27:51 BST 2016 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse) - Version: devel-20160618212631-#0618-gf481b3d [Build #0618]

Based on tip of LibreELEC.tv master (f481b3d2, changelog) and tip of XBMC master (7a3b106e, changelog) with the following modifications: Build Highlights:
  1. inputstream.mpd updates
  2. No lirc bump in this build
Build Details:
  1. LibreELEC.tv:
    • chromium: enable build from clean (PR:460, 1 commit, 1 file changed)
    • hyperion: update to d2f4725 (PR:446, 3 commits, 6 files changed)
    • mono: create addon (PR:404, 5 commits, 14 files changed)
  2. XBMC:
    • [depends] remove libmodplug as it's now a binary add-on (PR:9995, 1 commit, 2 files changed)
    • [lang] handle disabled language addons in migration (PR:9969, 1 commit, 2 files changed)
    • Fix misc compiler warnings. (PR:9998, 1 commit, 4 files changed)
    • [CHG] Settings - Library: groupings (PR:9999, 2 commits, 2 files changed)
  3. inputstream.mpd:
  4. Additional commits/pull requests/changes not yet merged upstream:
    • Reverted: [pkg] PR:9999: [CHG] Settings - Library: groupings (reason: breaks newclock5)



RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Roby77 - 2016-06-18

Tried to update 617>618 using your built in addon ...no luck

(Click on build but it doesn't install)


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Milhouse - 2016-06-19

(2016-06-18, 23:48)Roby77 Wrote: Tried to update 617>618 using your built in addon ...no luck

(Click on build but it doesn't install)

Need a debug log.


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - qp9013625 - 2016-06-19

(2016-06-18, 23:40)Milhouse Wrote: Include [env] e7cbe9cb: xf86-video-intel: Explicitely disable TearFree and TripleBuffer

Why?


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Milhouse - 2016-06-19

(2016-06-18, 23:48)Roby77 Wrote: Tried to update 617>618 using your built in addon ...no luck

(Click on build but it doesn't install)

OK I've traced this error to the Generic releases.json file - it's updated now and you should be able to update after rebooting (to ensure you've downloaded the new releases.json file).


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - CandyLuv - 2016-06-19

(2016-06-18, 22:16)Milhouse Wrote:
(2016-06-18, 19:31)CandyLuv Wrote: Also is there an addon for "Official releases".

The forked version is the only option for now.

Hi,
OK I understand.
I Tried installing the fork v0.0.5 and I can go into configuration but when trying to launch I'm getting error "LIBREELEC DEV UPDATE ERROR
Check the log for more information"

The Openelec version still works so not sure what's causing my problem with this one.
Any additional help will be greatly appreaciated


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - nuc-LE - 2016-06-19

(2016-06-19, 02:16)Milhouse Wrote:
(2016-06-18, 23:48)Roby77 Wrote: Tried to update 617>618 using your built in addon ...no luck

(Click on build but it doesn't install)

OK I've traced this error to the Generic releases.json file - it's updated now and you should be able to update after rebooting (to ensure you've downloaded the new releases.json file).
Worked well for me, thank you!


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Milhouse - 2016-06-19

(2016-06-19, 03:10)CandyLuv Wrote: Hi,
OK I understand.
I Tried installing the fork v0.0.5 and I can go into configuration but when trying to launch I'm getting error "LIBREELEC DEV UPDATE ERROR
Check the log for more information"

The Openelec version still works so not sure what's causing my problem with this one.
Any additional help will be greatly appreaciated

Not sure. I don't support either version of this add-on, so a separate thread might be an idea where you can then discuss the issue(s) in more detail, providing your log etc. (as per the error message etc.).

Although once we have the update via Settings add-on working reliably, there will be less demand for the Dev Update add-on.


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - fritsch - 2016-06-19

(2016-06-19, 01:20)qp9013625 Wrote:
(2016-06-18, 23:40)Milhouse Wrote: Include [env] e7cbe9cb: xf86-video-intel: Explicitely disable TearFree and TripleBuffer

Why?

Cause we want Audio in Sync and have a default buffer level of 2 set. No need that the driver renders as many frames as it wants at an undefined time.


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Roby77 - 2016-06-19

@Milhouse downgraded to 0617 and tried again still no luck, kodi log uploader also crashed so if you want i can share only log via dropbox


Ok this is the log
http://sprunge.us/fQFU


@fritsch did you see my xorg log ?

2360520 (post)


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Milhouse - 2016-06-19

(2016-06-19, 10:25)Roby77 Wrote: @Milhouse downgraded to 0617 and tried again still no luck, kodi log uploader also crashed so if you want i can share only log via dropbox


Ok this is the log
http://sprunge.us/fQFU

Argh. releases.json updated again. Please reboot and try again - should work this time.


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Roby77 - 2016-06-19

Yes works! Thank you
Could be useful like oe/libre dev update a pop up that confirm update was installed


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - fritsch - 2016-06-19

(2016-06-19, 10:25)Roby77 Wrote: @Milhouse downgraded to 0617 and tried again still no luck, kodi log uploader also crashed so if you want i can share only log via dropbox


Ok this is the log
http://sprunge.us/fQFU


@fritsch did you see my xorg log ?

2360520 (post)

No - was unreadable for me. I asked you to use sprunge instead.


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - fritsch - 2016-06-19

Quote:10:37:02 41.596378 T:140398538233600 ERROR: ## LibreELEC Addon ## oe::download_file(http://milhouse.libreelec.tv/builds/master/GenericLibreELEC-Generic.x86_64-8.0-Milhouse-20160618212631-#0618-gf481b3d.tar, /storage/.kodi/temp/update_file) ## ERROR: (HTTPError())
10:37:02 41.598064 T:140398538233600 ERROR: Traceback (most recent call last):
File "/home/neil/projects/LibreELEC.tv/build.LibreELEC-Generic.x86_64-8.0-devel/LibreELEC-settings-168c183/.install_pkg/usr/share/kodi/addons/service.libreelec.settings/oe.py", line 284, in download_file
File "/usr/lib/python2.7/urllib2.py", line 154, in urlopen
File "/usr/lib/python2.7/urllib2.py", line 437, in open
File "/usr/lib/python2.7/urllib2.py", line 550, in http_response
File "/usr/lib/python2.7/urllib2.py", line 475, in error
File "/usr/lib/python2.7/urllib2.py", line 409, in _call_chain
File "/usr/lib/python2.7/urllib2.py", line 558, in http_error_default
HTTPError: HTTP Error 404: Not Found

That's a wait for network issue.


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Roby77 - 2016-06-19

(2016-06-19, 13:29)fritsch Wrote:
(2016-06-19, 10:25)Roby77 Wrote: @Milhouse downgraded to 0617 and tried again still no luck, kodi log uploader also crashed so if you want i can share only log via dropbox


Ok this is the log
http://sprunge.us/fQFU


@fritsch did you see my xorg log ?

2360520 (post)

No - was unreadable for me. I asked you to use sprunge instead.

These are uploaded to sprunge

2360520 (post)