Kodi Community Forum
v17 LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Linux (https://forum.kodi.tv/forumdisplay.php?fid=52)
---- Thread: v17 LibreELEC Testbuilds for x86_64 (Kodi 17.0) (/showthread.php?tid=269815)



RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Roby77 - 2016-06-19

(2016-06-19, 13:29)fritsch Wrote:
Quote:10:37:02 41.596378 T:140398538233600 ERROR: ## LibreELEC Addon ## oe::download_file(http://milhouse.libreelec.tv/builds/master/GenericLibreELEC-Generic.x86_64-8.0-Milhouse-20160618212631-#0618-gf481b3d.tar, /storage/.kodi/temp/update_file) ## ERROR: (HTTPError())
10:37:02 41.598064 T:140398538233600 ERROR: Traceback (most recent call last):
File "/home/neil/projects/LibreELEC.tv/build.LibreELEC-Generic.x86_64-8.0-devel/LibreELEC-settings-168c183/.install_pkg/usr/share/kodi/addons/service.libreelec.settings/oe.py", line 284, in download_file
File "/usr/lib/python2.7/urllib2.py", line 154, in urlopen
File "/usr/lib/python2.7/urllib2.py", line 437, in open
File "/usr/lib/python2.7/urllib2.py", line 550, in http_response
File "/usr/lib/python2.7/urllib2.py", line 475, in error
File "/usr/lib/python2.7/urllib2.py", line 409, in _call_chain
File "/usr/lib/python2.7/urllib2.py", line 558, in http_error_default
HTTPError: HTTP Error 404: Not Found

That's a wait for network issue.

Yes Milhouse solved

I attached to the same post logs for you


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - fritsch - 2016-06-19

Quote:Jun 18 23:03:53 LibreELEC kernel: [drm] Got external EDID base block and 1 extension from "edid/edid.bin" for connector "HDMI-A-1"
Jun 18 23:03:54 LibreELEC kernel: had: snd_intelhad_open: HDMI cable plugged-out

This is from your boot config txt:
Quote:drm_kms_helper.edid_firmware=HDMI-A-1:edid/edid.bin

Try:
Quote:drm_kms_helper.edid_firmware=HDMI-A-1:edid/edid.bin video=HDMI-A-1:[email protected]

So just appending the video= additionally, don't forget the last D it's not a typo


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Roby77 - 2016-06-19

Ok i will follow oe custom guide and append line with your mod

Thank you as always for your support


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Roby77 - 2016-06-19

@fritsch line appended

http://sprunge.us/ccLH

Now if the screen keeps black after syslinux i don't see libreelec kodi logo but after 10 second kodi gui is loaded!!!!

(In log still see hdmi plugged out)

You are a God! Smile Blush


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - fritsch - 2016-06-19

Test it for some days, please.


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - john.cord - 2016-06-20

Is there a better way to force 1080p50Hz as via autostart.sh? It seems that his is causing my chromebox to display a black screen after resuming from suspend.


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Milhouse - 2016-06-20

New LibreELEC.tv Krypton build #0619: Generic
(Supercedes previous build)

Code:
# uname -a
Linux LibreELEC 4.6.2 #1 SMP Sun Jun 19 21:21:42 BST 2016 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse) - Version: devel-20160619212021-#0619-gc6c222d [Build #0619]

Based on tip of LibreELEC.tv master (c6c222dc, changelog) and tip of XBMC master (08ec69b1, changelog) with the following modifications: Build Highlights:
  1. Bump lirc to 0.9.4
Build Details:
  1. LibreELEC.tv:
    • imagemagick: update version (PR:463, 1 commit, 1 file changed)
    • lirc: update to 0.9.4 (PR:449, 4 commits, 18 files changed)
  2. XBMC:
    • Updated Hungarian strings for XBMC and Confluence (PR:3, 2 commits, 2 files changed)
    • [EPG] Misc cleanup & fix for async epg events not respecting epg lingertime (PR:9997, 6 commits, 5 files changed)
    • [depends] jpeg lib isn't used anymore (PR:10002, 1 commit, 1 file changed)
    • [depends] rtmpdump commit version fa8646d (PR:9996, 1 commit, 1 file changed)
    • Move AudioDSP Sources (PR:9994, 7 commits, 41 files changed)
    • Fix 1000 warnings (PR:9857, 1 commit, 13 files changed)
    • Fix RPi settings xml after settings shuffle (PR:10003, 1 commit, 1 file changed)
    • [addons] package size metadata (PR:9971, 6 commits, 14 files changed)
    • [aml] Make CEGLNativeTypeAmlogic compatible with Amlogic S905 SoC (PR:10005, 1 commit, 1 file changed)
    • [xbmc][fix] Fix dll hooking for VS 2015 update 3 as there's some changes incoming (PR:10009, 1 commit, 1 file changed)
    • [addons] Preserve strings which are not string ids in enum lvalues (PR:8271, 1 commit, 1 file changed)
  3. inputstream.mpd:
  4. pvr.argustv:
    • [lang] updated language files from Transifex (e536f32e)
  5. pvr.demo:
    • [lang] updated language files from Transifex (01c68c88)
  6. pvr.dvblink:
    • [lang] updated language files from Transifex (5f9872ca)
  7. pvr.dvbviewer:
    • [lang] updated language files from Transifex (35902f5d)
  8. pvr.filmon:
    • [lang] updated language files from Transifex (efd379b8)
  9. pvr.hdhomerun:
    • [lang] updated language files from Transifex (a71e816d)
  10. pvr.hts:
    • HTSP v25 additions (PR:230, 4 commits, 8 files changed)
    • [lang] updated language files from Transifex (8d710909)
  11. pvr.iptvsimple:
    • [lang] updated language files from Transifex (1ea1f36e)
  12. pvr.mediaportal.tvserver:
    • [lang] updated language files from Transifex (369b0189)
  13. pvr.mythtv:
    • [lang] updated language files from Transifex (9141c6fc)
  14. pvr.nextpvr:
    • [lang] automatic syntax corrections for the en_GB language file (c38311ae)
    • [lang] updated language files from Transifex (7ed3111c)
  15. pvr.pctv:
    • [lang] updated language files from Transifex (12d8baf1)
  16. pvr.stalker:
    • [lang] updated language files from Transifex (acba9f12)
  17. pvr.vbox:
    • [lang] updated language files from Transifex (b24c3cac)
  18. pvr.vdr.vnsi:
    • [lang] automatic syntax corrections for the en_GB language file (4f7c5d19)
    • [lang] updated language files from Transifex (5d5bb64e)
  19. pvr.vuplus:
    • [lang] updated language files from Transifex (c988f849)
  20. pvr.wmc:
    • [lang] updated language files from Transifex (ef4cf3b1)



RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - startv - 2016-06-20

"libreELEC settings" - "system" is blank from #0610 to last build, #0609 is OK. is that normal?


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - fritsch - 2016-06-20

(2016-06-20, 00:26)john.cord Wrote: Is there a better way to force 1080p50Hz as via autostart.sh? It seems that his is causing my chromebox to display a black screen after resuming from suspend.

See what I suggested to Roby77 - this will force kms to 50 hz. And additionally you can use an xorg.conf with the 50 hz mode as Preferred Mode.


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - menno - 2016-06-20

I just hooked up a 15 year old USB Soundblaster LIve, and it worked out of the box hahaha. I hooked it up to my Odroid C2. Love this!!

Image


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Roby77 - 2016-06-20

(2016-06-19, 17:06)fritsch Wrote: Test it for some days, please.

Yes i will do, thank you again

I opened a bug on freedesktop about it


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - john.cord - 2016-06-20

(2016-06-20, 08:27)fritsch Wrote:
(2016-06-20, 00:26)john.cord Wrote: Is there a better way to force 1080p50Hz as via autostart.sh? It seems that his is causing my chromebox to display a black screen after resuming from suspend.

See what I suggested to Roby77 - this will force kms to 50 hz. And additionally you can use an xorg.conf with the 50 hz mode as Preferred Mode.

I did this but after wake up from suspend the used mode is 60Hz. With this changes Kodi shows 50Hz in the Menue but used mode is 60Hz.


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Milhouse - 2016-06-20

(2016-06-20, 08:22)startv Wrote: "libreELEC settings" - "system" is blank from #0610 to last build, #0609 is OK. is that normal?

No, not normal. If you'd posted your debug log that would help.

It's probably due to a corrupted (or now incompatible) setting of some kind - hard to say without a log. Try deleting the settings and restarting:
Code:
rm /storage/.kodi/userdata/addon_data/service.libreelec.settings/oe_settings.xml
systemctl restart kodi
You'll then need to reconfigure anything you had configured in the Settings add-on (hostname etc.)


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - fritsch - 2016-06-20

(2016-06-20, 12:08)john.cord Wrote:
(2016-06-20, 08:27)fritsch Wrote:
(2016-06-20, 00:26)john.cord Wrote: Is there a better way to force 1080p50Hz as via autostart.sh? It seems that his is causing my chromebox to display a black screen after resuming from suspend.

See what I suggested to Roby77 - this will force kms to 50 hz. And additionally you can use an xorg.conf with the 50 hz mode as Preferred Mode.

I did this but after wake up from suspend the used mode is 60Hz. With this changes Kodi shows 50Hz in the Menue but used mode is 60Hz.

Show me your xorg.conf. Remember: Suspend is pure luck and nothing in kodi makes it work correctly.


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Jdiesel - 2016-06-20

Was PR:9731 removed in yesterdays build due to issues or was it just forgotten? If it was forgotten could it be added back to future nightlies?