Kodi Community Forum
v17 LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Linux (https://forum.kodi.tv/forumdisplay.php?fid=52)
---- Thread: v17 LibreELEC Testbuilds for x86_64 (Kodi 17.0) (/showthread.php?tid=269815)



RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - _Spook_ - 2016-06-23

(2016-06-23, 10:43)fritsch Wrote:
(2016-06-23, 09:45)_Spook_ Wrote: @Milhouse ready for some new problems soon by using 4.7 kernel? Tongue

Nope - I just got the BSW fix into upcoming 4.6.3 kernel .... no mood for yet another fuckup.

http://git.kernel.org/cgit/linux/kernel/git/stable/stable-queue.git/tree/queue-4.6/revert-drm-i915-exit-cherryview_irq_handler-after-one-pass.patch

But that is fixed in 4.7 kernel so that spesific issue shouldn't be a problem Smile


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - b0mb - 2016-06-23

Btw does an EGL build of Jarvis exist?


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - fritsch - 2016-06-23

No.


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - fritsch - 2016-06-23

(2016-06-23, 12:05)_Spook_ Wrote:
(2016-06-23, 10:43)fritsch Wrote:
(2016-06-23, 09:45)_Spook_ Wrote: @Milhouse ready for some new problems soon by using 4.7 kernel? Tongue

Nope - I just got the BSW fix into upcoming 4.6.3 kernel .... no mood for yet another fuckup.

http://git.kernel.org/cgit/linux/kernel/git/stable/stable-queue.git/tree/queue-4.6/revert-drm-i915-exit-cherryview_irq_handler-after-one-pass.patch

But that is fixed in 4.7 kernel so that spesific issue shouldn't be a problem Smile
Yeah. Bring it on!


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Roby77 - 2016-06-23

ops was an external patch ? https://bugs.freedesktop.org/show_bug.cgi?id=95196

cause i declared as fixed in 4.6.1 Rofl


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - artur9 - 2016-06-24

Any way to boot LibreElec off a USB stick while OpenElec is installed on the internal drive?

Or is the issue with conflicting UUIDs insurmountable?


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Milhouse - 2016-06-24

(2016-06-24, 04:22)artur9 Wrote: Any way to boot LibreElec off a USB stick while OpenElec is installed on the internal drive?

Or is the issue with conflicting UUIDs insurmountable?

Shouldn't be a problem if you set your boot options correctly. I'd disable the internal HDD if you just want to trial LibreELEC.


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Milhouse - 2016-06-24

New LibreELEC.tv Krypton build #0623: Generic
(Supercedes previous build)

Code:
# uname -a
Linux LibreELEC 4.6.2 #1 SMP Fri Jun 24 03:38:47 BST 2016 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse) - Version: devel-20160624033724-#0623-g9b3d478 [Build #0623]

Based on tip of LibreELEC.tv master (9b3d4784, changelog) and tip of XBMC master (27313111, changelog) with the following modifications: Build Highlights:
  1. Bump ffmpeg 3.0.1 -> 3.0.2+HEAD
  2. ffmpeg rework package
  3. Fix JSON IMDB ratings/votes (PR:10020)
  4. Improved stability/resilience of LibreELEC Settings addon "System" page - it shouldn't be blank whenever the network is disconnected, or whenever other errors occurs (please report any further instances of blank pages, along with debug log)
Build Details:
  1. LibreELEC.tv:
    • vdr-addon: update all plugins to latest (PR:475, 1 commit, 8 files changed)
    • ffmpeg: Switch to revision based versioning, not release (PR:479, 1 commit, 1 file changed)
  2. XBMC:
    • Quell some warnings (PR:10023, 2 commits, 2 files changed)
    • Change ratings to reflect json art (and future uniqueid) structure (PR:10020, 2 commits, 8 files changed)
  3. inputstream.mpd:
  4. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] PR:474: lirc: replace parallel build fix
    • Added: [env] PR:477: ffmpeg: rework



RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Milhouse - 2016-06-24

Build #0623x is based on 4.7-rc4, the kernel being the only change from #0623. It seems to work fine on my Revo3700/ION2. It would be good to get feedback from those who have reported problems with the current 4.6.2 kernel (GPU issues, black screens, lack of IR auto-repeat etc.) in order that we can get early feedback on issues before we eventually switching to the 4.7-rcX branch in the near future. Anyone else that wants to test 4.7-rc4 is also welcome. Smile

Generic


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Roby77 - 2016-06-24

No auto repeat but all seems to works ok

LibreELEC:~ # dmesg | pastebinit
http://sprunge.us/VOiX
LibreELEC:~ # journalctl -a | pastebinit
http://sprunge.us/PQXd
LibreELEC:~ #


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Matt Devo - 2016-06-24

(2016-06-24, 09:17)Roby77 Wrote: No auto repeat but all seems to works ok

LibreELEC:~ # dmesg | pastebinit
http://sprunge.us/VOiX
LibreELEC:~ # journalctl -a | pastebinit
http://sprunge.us/PQXd
LibreELEC:~ #

2nd


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Milhouse - 2016-06-24

(2016-06-24, 09:17)Roby77 Wrote: No auto repeat but all seems to works ok

Dang. Sad

(2016-06-24, 09:17)Roby77 Wrote: LibreELEC:~ # dmesg | pastebinit
http://sprunge.us/VOiX
LibreELEC:~ # journalctl -a | pastebinit
http://sprunge.us/PQXd
LibreELEC:~ #

Thanks. Any issues with black/blank screens?


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Roby77 - 2016-06-24

(2016-06-24, 11:18)Milhouse Wrote:
(2016-06-24, 09:17)Roby77 Wrote: No auto repeat but all seems to works ok

Dang. Sad

(2016-06-24, 09:17)Roby77 Wrote: LibreELEC:~ # dmesg | pastebinit
http://sprunge.us/VOiX
LibreELEC:~ # journalctl -a | pastebinit
http://sprunge.us/PQXd
LibreELEC:~ #

Thanks. Any issues with black/blank screens?

At boot i don't see anymore in the logs
Code:
hdmi plugged out error

But i'm also forcing hdmi out using
Code:
video=HDMI-A-1:[email protected]
so until i remove it i can't verify if it works correctly (will try to edit it...or a fresh install)

At movie stop...will try better this night


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - _Spook_ - 2016-06-24

4.7 RC4 seems to work fine Smile


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - jjslegacy - 2016-06-24

On the latest build (23rd) I get connection timeout from the IOS app and the weburl. Happens on both my PI3 and chromebox.

Will a debug log show the problem?

*build from 22nd is fine*


Looks like it's documented but not known why yet:
10023 (PR)