Kodi Community Forum
v17 LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Linux (https://forum.kodi.tv/forumdisplay.php?fid=52)
---- Thread: v17 LibreELEC Testbuilds for x86_64 (Kodi 17.0) (/showthread.php?tid=269815)



RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Milhouse - 2016-07-12

New LibreELEC.tv Krypton build #0711: Generic
(Supercedes previous build)

Code:
# uname -a
Linux LibreELEC 4.7.0-rc6 #1 SMP Mon Jul 11 22:57:29 BST 2016 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse) - Version: devel-20160711225532-#0711-g1cfefd3 [Build #0711]

Based on tip of LibreELEC.tv master (1cfefd35, changelog) and tip of XBMC master (874b7bdc, changelog) with the following modifications: Build Highlights:
  1. PVR and ADSP change
Build Details:
  1. XBMC:
    • [PVR] Recordings window: make 'group items' setting persistent. (PR:10101, 1 commit, 6 files changed)
  2. xbmc/AudioDSP/V2/usability_core_fixes (AchimTuran):
    • New commits in this build:
      • [windows][buildtools] Add option to install add-ons into a seperate path (acadc2f0)



RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - piotrasd - 2016-07-12

(2016-07-11, 20:47)MadMeddler Wrote:
(2016-07-10, 17:46)piotrasd Wrote: ...

UPDATE:
here latest version with default LE linux config
...

piotrasd

Thanks for the update. I've finally gotten around to updating from the Milhouse #0703 to your Dev build from yesterday and everything seems to be working fine. I have audio, Ethernet and USB sticks all showing up as I'd hoped.

Once per will i will try send you new version or just create some FTP for people with BT/CHT devices.


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - artur9 - 2016-07-12

I have a movie that only plays the sound but no video. Black screen.

dmesg: http://sprunge.us/IQEX
kodi.log (movie play starts at 21:57:35 3247.654785) http://sprunge.us/HOBW

What am I doing wrong?


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - porkchop999 - 2016-07-12

Just changed over to a NUC6i3SYK, working really well.


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Tequilla9 - 2016-07-12

(2016-06-11, 21:20)fritsch Wrote:
(2016-06-11, 08:55)Tequilla9 Wrote:
(2016-06-09, 19:42)Tequilla9 Wrote: OK. Here you are:

Kodi log: http://pastebin.com/7YyuU2EN

I pressed everytime I could see the stutter the Vol+ key, hope you can see whats going on there Wink

Edit: After playing arround with the settings the only thing that solves the issue is to enable "Sync playback to display" - unfortunately there is no DTS HD passthrough anymore.

thx

@Fritsch: Have you already been able to check the log?

Discon method needs some hysteresis. DTS-HD is decoded lossless. So if you don't need the green light on your AVR - use PCM audio + Sync Playback to Display.


Is there any hope that this issue will be fixed in future? In kodi 16.1 its working perfectly. Latest build still have this issue...

@Fritsch: I don't understand what you want to say with "Discon method need some...." Can you please clarify this? I am a noob on this Wink

thx


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - axbmcuser - 2016-07-12

@Milhouse:

Just FYI:
Regarding build 0711

adsp.biquad.filters (5849a194, +7)
Looks like this info is not correct. It includes an older state of the addon (0.0.2). 5849a194 Would be 0.0.3 with fixed major crashes.
Maybe something got mixed up in the build process. Did not check the other adsp addons.


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - illiac4 - 2016-07-12

Suspend is not working anymore. I was on build 0522 and from 0523b and also on latest builds suspend is not working anymore.. Roling back to 0522 fixes the suspend.


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - john.cord - 2016-07-12

(2016-07-12, 12:51)illiac4 Wrote: Suspend is not working anymore. I was on build 0522 and from 0523b and also on latest builds suspend is not working anymore.. Roling back to 0522 fixes the suspend.

Fritsch said that Suspend is based on pure luck on linux platform atm so that is a known issue...


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Milhouse - 2016-07-12

(2016-07-12, 11:50)axbmcuser Wrote: @Milhouse:

Just FYI:
Regarding build 0711

adsp.biquad.filters (5849a194, +7)
Looks like this info is not correct. It includes an older state of the addon (0.0.2). 5849a194 Would be 0.0.3 with fixed major crashes.
Maybe something got mixed up in the build process. Did not check the other adsp addons.

These builds are using the "testbuild_AudioDSPV2" branch which needs to be updated (and the same on the other adsp.* repositories) - I'll ping AchimTuran. Thanks for the heads up.


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - QLink - 2016-07-12

(2016-07-07, 22:56)Milhouse Wrote:
(2016-07-07, 22:45)QLink Wrote: vu+ pvr service does not start automatically after restart. when i deactivate/activate the service it works and channels+epg is loading from pvr backend...

i'm on 3rd of july testbuild...
No debug log (wiki), no problem.

here is log file: https://paste.ee/p/X8cFS

best greetz

p.s. i tried 11th of july build but got same problem


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Milhouse - 2016-07-12

New LibreELEC.tv Krypton build #0712: Generic
(Supercedes previous build)

Code:
# uname -a
Linux LibreELEC 4.7.0-rc7 #1 SMP Tue Jul 12 21:42:32 BST 2016 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse) - Version: devel-20160712213432-#0712-g1cfefd3 [Build #0712]

Based on tip of LibreELEC.tv master (1cfefd35, changelog) and tip of XBMC master (5568fd34, changelog) with the following modifications: Build Highlights:
  1. New 4.7-rc7 kernel
  2. Added upgrade check to prevent users upgrading to incompatible versions (ie. dropping RPi tar into RPi2, or vice versa). See PR for details.
Build Details:
  1. XBMC:
    • PluginDirectory: dont time out while script is modal/not cancelled (PR:10093, 1 commit, 2 files changed)
    • [cmake] Sync Peripheral API (e247a0d2)
  2. pvr.mythtv:
    • 4.6.0 (PR:70, 4 commits, 10 files changed)
  3. xbmc/master (FernetMenta):
    • New commits in this build:
      • IPlayer: properly sync playspeed with application (a78b5a6f)
    • Commits no longer in build:
      • python: use kodi provided cert if available (d63eea3e)
      • VideoPlayer: update selectionstreams when stream parameters changes (725f4b81)
  4. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] PR:535: init: Add upgrade check to avoid incompatible upgrades [RFC,WIP]



RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Xtropy - 2016-07-13

Unfortunately I have no remote control support in this Testbuild. Going into Settings/Interface/Control does not show a remote for me to setup. Have a MAC Mini with built-in IR, no issues in OE 6.0.3 or Libreelec Jarvis builds with the remote

journalctl -a | pastebinit
http://sprunge.us/UBPV

dmesg | pastebinit
http://sprunge.us/eKAI

systemctl status | pastebinit
http://sprunge.us/EDHX

kodi.log
http://pastebin.com/rfcBhdS0


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Milhouse - 2016-07-13

(2016-07-13, 00:22)Xtropy Wrote: Unfortunately I have no remote control support in this Testbuild.

Could you tell me if you've ever had working IR with these builds, or are you saying it has just stopped with build #0712 (which would be odd, and a new problem).

To be honest, I have no idea if you've just dived into this thread and kicked off with build #0712, or have been along for the ride over the last few months so if you're reporting a problem and telling me that something doesn't work it's also useful to know when it last worked (if it ever worked), or if you've only just joined us (welcome) and this is the first time you've tried one of these builds.

As it is, IR not working is something we're aware of and trying to fix (this might be your problem, but I really don't know because I don't know if you had working IR yesterday, or not).

Anyway, assuming it's the ongoing IR issue, try build #0618 and see if your IR is working there. Then try build #0619, when it probably won't be. Oh, and auto-repeat might not be working for you either, once you get a working IR.


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Xtropy - 2016-07-13

(2016-07-13, 00:36)Milhouse Wrote: \
Could you tell me if you've ever had working IR with these builds, or are you saying it has just stopped with build #0712 (which would be odd, and a new problem).

*snip*

Anyway, assuming it's the ongoing IR issue, try build #0618 and see if your IR is working there. Then try build #0619, when it probably won't be. Oh, and auto-repeat might not be working for you either, once you get a working IR.

Sorry, I should have given more details here. I started trying the Libreelec 7.90.XXX series and the remote did not work starting there. I tried your build from 0503 and it did not work either. Tried the 0331 and 0406 builds but I can't get the GUI to load. I just tried the 0618 and 0619 builds and no remote there either, like I say, it doesn't even show up as a choice in Kodi. As soon as I roll back to LE 7.0.1 or 7.02 everything works just fine. This appears to be a different issue than what's being reported.

For kicks, I ran the lsusb command and you can see the Apple IR listed on the 2nd line. No idea why Kodi is not seeing it like all versions prior to Krypton. Please let me know if there is anything else I can provide?

# lsusb
Bus 002 Device 004: ID 09da:0260 A4Tech Co., Ltd. KV-300H Isolation Keyboard
Bus 002 Device 003: ID 05ac:8242 Apple, Inc. Built-in IR Receiver
Bus 002 Device 002: ID 0424:2513 Standard Microsystems Corp. 2.0 Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 005: ID 0951:1666 Kingston Technology DataTraveler G4
Bus 001 Device 004: ID 041e:4087 Creative Technology, Ltd Live! Cam Socialize HD 1080 [VF0680]
Bus 001 Device 008: ID 05ac:8281 Apple, Inc. Bluetooth Host Controller
Bus 001 Device 003: ID 0a5c:4500 Broadcom Corp. BCM2046B1 USB 2.0 Hub (part of BCM2046 Bluetooth)
Bus 001 Device 002: ID 0424:2513 Standard Microsystems Corp. 2.0 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Thanks


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Milhouse - 2016-07-13

New LibreELEC.tv Krypton build #0713: Generic
(Supercedes previous build)

Code:
# uname -a
Linux NUC 4.7.0-rc7 #1 SMP Wed Jul 13 21:46:31 BST 2016 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse) - Version: devel-20160713214428-#0713-ga99b0e6 [Build #0713]

Based on tip of LibreELEC.tv master (a99b0e68, changelog) and tip of XBMC master (dfe31edd, changelog) with the following modifications: Build Highlights:
  1. Update ffmpeg 3.1.1 commit
  2. Display progress information during database migrations
Build Details:
  1. LibreELEC.tv:
    • projects/imx6: update kodi patch (beautified for next kodi updates) (PR:536, 1 commit, 1 file changed)
  2. XBMC:
    • Fix out of memory crash in CArchive (PR:9225, 3 commits, 10 files changed)
    • IPlayer: properly sync playspeed with application (PR:10103, 4 commits, 18 files changed)
    • [OverlayRendererDX] Fix rendering overlays in TAB/SBS modes. (PR:10105, 1 commit, 1 file changed)
    • [D3D11] Hack to fix refresh rate issue in full screen exclusive mode. (PR:10083, 2 commits, 4 files changed)
    • Update usage of Crc32 after changing methods to static (PR:10107, 1 commit, 4 files changed)
  3. xbmc/master (FernetMenta):
    • New commits in this build:
      • VideoPlayer: DVDMessageQueue, round up instead to the nearest integer (3ac6580f)
      • VideoPlayer: set clock to video pts when seeking while player is paused (de69813a)
    • Commits no longer in build:
      • vdpau: advanced settings for auto deinterlacing (85712f87)
      • IPlayer: properly sync playspeed with application (a78b5a6f)
      • VideoPlayer: continue normal playback if seek fails (d2af7167)
  4. xbmc/AudioDSP/V2/usability_core_fixes (AchimTuran):
    • New commits in this build:
      • [skin.esturay] TODO: How can we use default values for vertical sliderex controls? If I use sliderexs without sliderwidth and sliderheight the control will look (de077856)
      • [guilib] Add vertical orientation to GUISettingsSliderControl (5152880f)
      • [guilib] TODO: This is currently an ugly hack. Should I create a new public method to get acces to m_Label? (6fbdaf7b)
  5. Additional commits/pull requests/changes not yet merged upstream:
    • Updated: [env] patch: ffmpeg: bump 3.1.1
    • Added: [env] PR:537: kodi: database migration splash text