Kodi Community Forum
v17 LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Linux (https://forum.kodi.tv/forumdisplay.php?fid=52)
---- Thread: v17 LibreELEC Testbuilds for x86_64 (Kodi 17.0) (/showthread.php?tid=269815)



RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - fritsch - 2016-04-22

That rather sounds like TV's over / undscran settings have changed and need adjustments for 24p mode ...


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - smiffy1989 - 2016-04-22

(2016-04-19, 23:36)peak3d Wrote:
(2016-04-19, 19:28)smiffy1989 Wrote: [
sprunge seems to be down at the minute, struggling to find an alternative that will allow a 1.6MB log!
EDIT2: heres a log from 414: https://gist.githubusercontent.com/smiffy1989/51b08bc6577d28472781bc619621d8b0/raw/6f83ac9bba52cf6462455a74812d30267d256ac4/kodi%2520log

This is also my problem: I cannot access the old log from 418 :-(
But I need it to compare. Either you could post it also in githubusercontent or I'll wait for sprunge

Hi sorry I've been busy with work. Here's a new log with build 420:
https://gist.github.com/anonymous/132586d50807d0cffa14f0ba48287ef7


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - michi_jl - 2016-04-22

(2016-04-22, 01:05)Milhouse Wrote:
(2016-04-21, 17:03)michi_jl Wrote: So why could the addon be missing here?
Code:
16:59:50 80373.945312 T:140280563066624   ERROR: CAddonInstallJob[script.openelec.devupdate]: The dependency on os.openelec.tv version 4.0 could not be satisfied.
Run the following command and paste the output:
Code:
sqlite3 /storage/.kodi/userdata/Database/Addons23.db "select * from installed where addonID like 'os.%'"

Well thats wierd..
Code:
25|os.libreelec.tv|1|2016-04-15 12:35:09||
26|os.openelec.tv|0|2016-04-15 12:35:09||

(2016-04-22, 01:08)Milhouse Wrote:
(2016-04-21, 20:23)michi_jl Wrote: I also got another problem which i haven't had bevore on any other kodi version:

On some (most) videos the borders of the screen are cut off.
In the gui everything is fine, but as soon as a video plays its cut off. What can i do to solve this?

When did this start? Did you first see this behaviour in #0420, or #0419 or earlier? What hardware (GPU) are you using - is it Intel GPU, AMD GPU or Nvidia?

It sarted when i started using your libreelec test build. I jumped directly from kodi 16.1 rc2 to your builds..
I have a asus chromebox with a haswell cpu.

(2016-04-22, 07:46)fritsch Wrote: That rather sounds like TV's over / undscran settings have changed and need adjustments for 24p mode ...

I have had problems with overscan before, but until now it was consistant and as soon as i changed the tv input to 'pc' it was fine until now.
Also i cant find any setting in my tv which are over/underescan related..


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - fritsch - 2016-04-22

Those builds change the display driver, yes. If you disable "Adjust Refreshrate" that issue will disappear, cause your TV changes its overscan / underscan when the refreshrate changes. You might need to "reselect" PC when that has happened. Also make sure there are no calibrations left in your guisettings.xml. So if you have manually calibrated the screen, go into the calibration and press "d" for delete.

Which TV model do you have? Attached via HDMI?


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - michi_jl - 2016-04-22

(2016-04-22, 10:16)fritsch Wrote: Those builds change the display driver, yes. If you disable "Adjust Refreshrate" that issue will disappear, cause your TV changes its overscan / underscan when the refreshrate changes. You might need to "reselect" PC when that has happened. Also make sure there are no calibrations left in your guisettings.xml. So if you have manually calibrated the screen, go into the calibration and press "d" for delete.

Which TV model do you have? Attached via HDMI?

Yes that makes sense, i never had this option set before.
After a lot of googeling i found how to disabe overscan for good so everything is fine now (:
Thanks a lof for your help and for telling me what need to search for (:


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Milhouse - 2016-04-22

(2016-04-22, 08:35)michi_jl Wrote: Well thats wierd..
Code:
25|os.libreelec.tv|1|2016-04-15 12:35:09||
26|os.openelec.tv|0|2016-04-15 12:35:09||

You'll need to re-enable the os.openelec.tv add-on - the only way to do this with the new addons system is from SQLite:
Code:
sqlite3 /storage/.kodi/userdata/Database/Addons23.db "update installed set enabled=1 where id=26"



RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Milhouse - 2016-04-23

New LibreELEC.tv Krypton build #0423: Generic
(Supercedes previous build)

Code:
# uname -a
Linux LibreELEC 4.6.0-rc4 #1 SMP Sat Apr 23 12:13:10 BST 2016 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse) - Version: devel-20160423121110-#0423-gf1aef79 [Build #0423]

Based on tip of LibreELEC.tv master (f1aef79f, changelog) and tip of XBMC master (23783f68, changelog) with the following modifications: Build Highlights:
  1. NOTE: DVD playback remains temporarily disabled
  2. New 4.6.0-rc4 kernel
  3. [PVR] Alternative pvr announce - this introduces an API bump to 5.2.0, not all PVR addons are updated yet, so expect some temporary breakage
  4. Fix for Pandoki certificate issue
  5. Bump connman 1.32
  6. Switch to libinput
Build Details:
  1. LibreELEC.tv:
    • ncurses: replace with netbsd-curses (PR:187, 1 commit, 10 files changed)
    • Package updates! (PR:188, 6 commits, 8 files changed)
      • mesa: update to 11.2.1
      • pango: update to 1.40.1
      • connman: update to 1.32
      • util-linux: update to 2.28
      • libinput: update to 1.2.4
      • xf86-input-libinput: update to 0.18.0
    • chromium: update to 50.0.2661.75 (PR:189, 1 commit, 4 files changed)
    • addons: update for LibreELEC 8.0 (PR:191, 1 commit, 21 files changed)
    • docker: update to 1.11.0 (PR:193, 2 commits, 4 files changed)
    • tvheadend42: update to 4.1.1928 (PR:195, 1 commit, 2 files changed)
    • kodi/imx6: remove patch for Kodi Jarvis (PR:197, 1 commit, 1 file changed)
    • RBP: Update RPi kernel and firmware (PR:198, 2 commits, 4 files changed)
    • distro-tool: treat 350 status as valid for ftp (PR:208, 1 commit, 1 file changed)
    • Update bluez (PR:203, 2 commits, 2 files changed)
    • Update libressl (PR:204, 2 commits, 2 files changed)
    • docker: fix build for 1.11.0 (PR:209, 4 commits, 5 files changed)
    • script.config.vdr: update to 1.1.1 (PR:212, 1 commit, 1 file changed)
    • settings: bump to v0.7.2 (PR:214, 1 commit, 1 file changed)
    • repo-tool: add ability to update PKG_REPO_VERSION (PR:192, 1 commit, 1 file changed)
    • rpi-tools: initial add-on (PR:201, 4 commits, 7 files changed)
    • LibreELEC-settings: update patch to work with 0.7.2 (PR:216, 1 commit, 1 file changed)
    • script.config.vdr: update to 1.1.3 (PR:219, 1 commit, 1 file changed)
    • use top from procps-ng (PR:215, 2 commits, 4 files changed)
  2. XBMC:
    • Use CodeDocs for Doxygen documentation (PR:9652, 1 commit, 2 files changed)
    • add default icon for roles node (PR:9649, 1 commit, 4 files changed)
    • Fix covery issues from Controller Input PR (PR:9346, 4 commits, 7 files changed)
    • [estuary] - skin sync (PR:9665, 1 commit, 6 files changed)
    • [ios] - fix missing song metadata in control center when music is scanned into the db (PR:9650, 1 commit, 1 file changed)
    • [PVR] Alternative pvr announce (PR:9662, 2 commits, 9 files changed)
    • [pvr] - fix deadlock in epg (PR:9667, 1 commit, 1 file changed)
  3. inputstream.smoothstream:
    • Enable fragmented LiveStreams (900e2b8c)
    • Compile issue (e30e1d1b)
    • 64 bit datatype for time calculation (4500241c)
    • Windows optimization issue fixed for annexb conversation (88329d96)
  4. pvr.vdr.vnsi:
    • adapt to PVR API 5.2.0 (PR:78, 1 commit, 2 files changed)
  5. xbmc/master (FernetMenta):
    • New commits in this build:
      • ADDON: revert announcement interface, not thread safe (ad95a289)
  6. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] PR:183: Linux update to 4.6
    • Added: [env] PR:200: switch to using libinput exclusively (x86 / Generic only)



RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Raitsa - 2016-04-23

i was not able to start Vu+ Enigma2 client on 423 on my NUC 5CPYH, downgraded to 420 and working now.


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - M4tt0 - 2016-04-23

Have several issues:
* Deactivating English keyboard layout and activate the German one has not effect.
* Copied my sources.xml and advancedsettings.xml files linking to my MySQL server, the database is imported but all covers / pictures are missing.
* Several messages that add-ons (dependencies) can not be found / met (e.g. Amazon Prime Instant Add-on).
I reckon(!) that this is simply due to the absence of the 8.0 LibreElec-Addon repo. Is there some workaround for that?


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Milhouse - 2016-04-23

(2016-04-23, 16:14)Raitsa Wrote: i was not able to start Vu+ Enigma2 client on 423 on my NUC 5CPYH, downgraded to 420 and working now.

A number of PVR add-ons will likely be broken until you see them update to API 5.2.0. You might want to avoid updating until you see your PVR addon updated. Hopefully tomorrow, or whenever I'm able to upload normally.


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Milhouse - 2016-04-23

(2016-04-23, 16:42)M4tt0 Wrote: Have several issues:
* Deactivating English keyboard layout and activate the German one has not effect.
* Copied my sources.xml and advancedsettings.xml files linking to my MySQL server, the database is imported but all covers / pictures are missing.
* Several messages that add-ons (dependencies) can not be found / met (e.g. Amazon Prime Instant Add-on).
I reckon(!) that this is simply due to the absence of the 8.0 LibreElec-Addon repo. Is there some workaround for that?

Some context would help, is this an upgrade or fresh install? If upgrade, from what?

Covers/pictures missing - no idea without a debug log. Check your artwork metadata, texturecache.py is included in these builds.

Dependencies - probably disabled add-ons. Welcome to Kodi 17.


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - _Spook_ - 2016-04-23

New kernel seems OK on Sky Lake NUC Smile Had problems with 4.5 kernel so that is good! Smile


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - fritsch - 2016-04-23

The audio bug was fixed, thanks to your bugreport on freedesktop :-)


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - _Spook_ - 2016-04-23

Glad I can help on something Smile


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Nafi - 2016-04-23

Don't really know if
Quote:Switch to libinput
or the new kernel is the reason, but in #0423 release around half of my remote control Buttons are incorrect/differently mapped than before.

Now, some buttons of my Logitech Harmony's MCE-Remote Profile, which were definitly unique buttons before, are recognised as the same button.