Kodi Community Forum
v17 LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Linux (https://forum.kodi.tv/forumdisplay.php?fid=52)
---- Thread: v17 LibreELEC Testbuilds for x86_64 (Kodi 17.0) (/showthread.php?tid=269815)



RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - mhoogenbosch - 2016-07-21

(2016-07-21, 20:23)QLink Wrote:
(2016-07-20, 22:01)Milhouse Wrote:
(2016-07-20, 21:41)QLink Wrote: anything new about this problem. tried the latest testbuild, but still error msg "pvr addon could not be loaded" when i deactivate/reactivate it in addon menu it works ...

You might also want to enable "Wait for network" in the LE Settings addon as it appears you don't have a network when Kodi starts.

That did the trick !
Now pvr addon starts without error msg ...

strange that i didn't need that setting with kodi 16.1 ...

Thanks anyway for your help milhouse Smile
@Milhouse, is it an idea to turn this setting on by default? Or are there any downsides? Because I read lots of people run into problems without this setting turned on (myself included).


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - john.cord - 2016-07-21

Latest Build bumps Video Database Version from 106 to 107


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Milhouse - 2016-07-21

(2016-07-21, 23:00)mhoogenbosch Wrote: @Milhouse, is it an idea to turn this setting on by default? Or are there any downsides? Because I read lots of people run into problems without this setting turned on (myself included).

It can't be enabled by default because there are users that use LE without a network connection - they'd be left waiting forever with no way to disable the setting.

One solution might be to add it to the first run Wizard, or enable by default but only when there's a configured network.

For now though it's easier to live with the downsides of having it disabled by default than the potential chaos that might result from enabling by default.


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Vidman - 2016-07-21

(2016-07-21, 23:43)Milhouse Wrote:
(2016-07-21, 23:00)mhoogenbosch Wrote: @Milhouse, is it an idea to turn this setting on by default? Or are there any downsides? Because I read lots of people run into problems without this setting turned on (myself included).

It can't be enabled by default because there are users that use LE without a network connection - they'd be left waiting forever with no way to disable the setting.

One solution might be to add it to the first run Wizard, or enable by default but only when there's a configured network.

For now though it's easier to live with the downsides of having it disabled by default than the potential chaos that might result from enabling by default.
Isn't there also a timeout?


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Milhouse - 2016-07-21

(2016-07-21, 23:19)john.cord Wrote: Latest Build bumps Video Database Version from 106 to 107

Thanks, missed that in PR10000 - build highlights updated. Hopefully the database migration message worked as intended... Smile


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - john.cord - 2016-07-21

Yes it worked.


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Milhouse - 2016-07-21

(2016-07-21, 23:45)Vidman Wrote: Isn't there also a timeout?

Yes, and it's configurable (default is 10 seconds). I'll have a word with the LE developers see what they think about changing it.


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Milhouse - 2016-07-21

(2016-07-21, 23:56)john.cord Wrote: Yes it worked.

Hurrah! Smile


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Milhouse - 2016-07-22

New LibreELEC.tv Krypton build #0721: Generic
(Supercedes previous build)

Code:
# uname -a
Linux NUC 4.7.0-rc7 #1 SMP Thu Jul 21 22:23:06 BST 2016 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse) - Version: devel-20160721222041-#0721-g7da6912 [Build #0721]

Based on tip of LibreELEC.tv master (7da69129, changelog) and tip of XBMC master (77a8ce9a, changelog) with the following modifications:
  • Includes FernetMenta "VideoPlayer" patches
  • Includes latest kodi-platform master (c8188d82)
  • Includes latest libcec master (6d68d212)
  • Includes latest libnfs master (fac3a954, ahead +34)
  • Includes latest p8-platform master (041a8c6c, ahead +1)
  • Includes latest addons: inputstream.mpd (be57d7cf, +21), inputstream.rtmp (7bf2298e), inputstream.smoothstream (99e77711, +4), peripheral.joystick (6090a90e, +1), pvr.argustv (e536f32e), pvr.demo (01c68c88), pvr.dvblink (20e1ccb4, +2), pvr.dvbviewer (7a7ead36, +1), pvr.filmon (efd379b8), pvr.hdhomerun (a71e816d), pvr.hts (66dcb89f, +2), pvr.iptvsimple (21e91a5f, +1), pvr.mediaportal.tvserver (72452b9d, +2), pvr.mythtv (a9ea5816, +6), pvr.nextpvr (32b3c2ff, +2), pvr.njoy (b5d65655), pvr.pctv (12d8baf1), pvr.stalker (b6cb9b87, +9), pvr.vbox (f38f82f0, +2), pvr.vdr.vnsi (8515b4bf, +6), pvr.vuplus (4f2ad621, +2), pvr.wmc (979c37db, +2)
  • Includes commits from xbmc/master, ahead +2 (FernetMenta)
  • Include [env] e7cbe9cb: xf86-video-intel: Explicitely disable TearFree and TripleBuffer
  • Include [env] ed774729: Intel: Implement Passthrough-Range
  • Include [env] 98c65e6a: Kodi: Use Limited Range by default
  • Include [env] patch: Add kodi binary addons (pvr, adsp, other)
  • Include [env] patch: Don't build ADSP addons
  • Include [env] patch: Bump included addon versions to prevent online updates
  • Include [env] patch: Install libbrcmEGL/libbrcmGLESv2 shared libraries, with sym links for backward compatability
  • Include [env] patch: HACK: Disable multiple PVR addons during migration. Always enable inputstream.*, os.* and peripheral.*
  • Include [env] patch: Add experimental splash video for RPi
  • Include [env] patch: ffmpeg: bump 3.1.1
  • Include [env] PR:481: linux: Update to 4.7 (WIP)
  • Include [env] PR:526: Cpu temperature readings for devices with aml_thermal interface
  • Include [env] PR:535: init: Add upgrade check to avoid incompatible upgrades [RFC,WIP]
  • Include [env] PR:548: connman: bump to 1.33
  • Include [env] PR:555: Package updates
  • Revert [env] 46b9b7b3: rtmpdump (Reason: use newclock5 bump)
  • Include [pkg] 441217d8: logging: Add microsecond timer to log messages (kodi)
  • Include [pkg] patch: drm/i915: Extend Fake HDMI live status to Valley View (linux)
  • Include [pkg] patch: [skin.estuary] Hide watched items on home (kodi-theme-Estuary)
  • Include [pkg] PR:8645: [video] Add season/TV show artwork to episodes/seasons even if they have their own fanart.
  • Include [pkg] PR:8824: videodb: fix smart playlists not honoring "Show empty TV shows" setting.
  • Include [pkg] PR:8922: [guiinfo] extend ranges for listitem properties
  • Include [pkg] PR:9803: [PeripheralCecAdapter] fix playback stopping on screensaver deactivated
  • Include [pkg] PR:10141: set tvshow thumb on *all seasons node
  • Include [pkg] PR:10150: GLX: fix vsync for glXSwapIntervalMESA after f0c02bd1adb8be38d8a5ae56…
  • Revert [pkg] PR:10130: [cmake] Change the way how shared libraries are built (Reason: conflict with newclock5)
Build Highlights:
  1. Clean build. Bump mysql, busybox, bluez and many many more (see PR:555)
  2. Revert PR10130 for now (newclock5 needs a rebase)
  3. inputstream.mpd and inputstream.smoothstream updates
  4. PR:10150: GLX: fix vsync for glXSwapIntervalMESA after f0c02bd1adb8be38d8a5ae56… - @pyrodex this should fix skipping with AMD GPU
Build Details:
  1. LibreELEC.tv:
    • lcdproc: LCD_DRIVER glcd should depend on freetype (PR:551, 1 commit, 1 file changed)
    • systemd: Do not unmount /storage and /flash at shutdown as this always fails (PR:546, 1 commit, 1 file changed)
    • hyperion: update to 85fcec3 (PR:553, 2 commits, 4 files changed)
    • sundtek-mediatv: update driver to latest version on first install (PR:559, 1 commit, 7 files changed)
  2. XBMC:
    • [cmake] Change the way how shared libraries are built (PR:10130, 9 commits, 117 files changed)
    • [lang][skin.estuary] updated language files from Transifex (7a79f43d)
    • [lang][skin.estouchy] updated language files from Transifex (77a8ce9a)
  3. inputstream.mpd:
  4. inputstream.smoothstream:
    • Implemented interface changes (ssd:3) (99e77711)
  5. pvr.dvblink:
    • [lang] updated language files from Transifex (20e1ccb4)
  6. pvr.dvbviewer:
    • [lang] updated language files from Transifex (7a7ead36)
  7. pvr.hts:
    • [lang] updated language files from Transifex (66dcb89f)
  8. pvr.iptvsimple:
    • [lang] updated language files from Transifex (21e91a5f)
  9. pvr.mediaportal.tvserver:
    • [lang] updated language files from Transifex (72452b9d)
  10. pvr.mythtv:
    • [lang] updated language files from Transifex (a9ea5816)
  11. pvr.nextpvr:
    • [lang] updated language files from Transifex (32b3c2ff)
  12. pvr.stalker:
    • channel and guide managers (PR:70, 3 commits, 11 files changed)
    • [lang] updated language files from Transifex (b6cb9b87)
  13. pvr.vbox:
    • [lang] updated language files from Transifex (f38f82f0)
  14. pvr.vdr.vnsi:
    • [lang] updated language files from Transifex (8515b4bf)
  15. pvr.vuplus:
    • [lang] updated language files from Transifex (4f2ad621)
  16. pvr.wmc:
    • [lang] updated language files from Transifex (979c37db)
  17. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] PR:555: Package updates
    • Added: [pkg] PR:10150: GLX: fix vsync for glXSwapIntervalMESA after f0c02bd1adb8be38d8a5ae56…
    • Reverted: [pkg] PR:10130: [cmake] Change the way how shared libraries are built (Reason: conflict with newclock5)



LibreELEC Testbuilds for x86 (Kodi 17.0) - pyrodex - 2016-07-22

@Milhouse #721 works perfectly!


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Milhouse - 2016-07-22

(2016-07-22, 00:55)pyrodex Wrote: @Milhouse #721 works perfectly!

Nice. Thanks for the feedback, and thanks @FernetMenta. Smile


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - xxxnelly - 2016-07-22

Hey Milhouse,

I have 3 small form boxes other my TVs in my house. All running Libreelec - so thanks for the builds.

The Zotac Zbox D80 has an issue that first appears in 523b and works in 522. The issue is that standby no longer works, the light remains on and I have to hard reset the box.

#0523b, 24-May-2016: Generic -- Release post (NOTE: DVD playback remains temporarily disabled; bumped xf86-video-nvidia to 361.42; #0523b: Updated xf86-video-nvidia with modesetting fix; #0523b: patch: drm/i915/ilk: Wait one vblank before enabling audio)
#0522, 22-May-2016: Generic -- Release post (NOTE: DVD playback remains temporarily disabled; systemd: update to 230; PR:9862: PluginDirectory - avoid BusyDialog if not called by main thread)

Let me know what logs you need or more info on the box.
This took me a while to go through the previous versions to get to where if first happened, so sorry for the delay.

I have tested #0721 and the issue still exists, I have tried most versions between #0523 and #0721 as I upgrade a few times a week on all boxes.

Let me know your thoughts and I can provide the log you need.

Thanks.


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Milhouse - 2016-07-22

What GPU does the D80 use - I did a quick Google for "zotac zbox d80" but came up empty, are you sure that's the model number? Please provide a full debug log and dmesg.


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - bazzz3 - 2016-07-22

(2016-07-22, 12:50)Milhouse Wrote: What GPU does the D80 use - I did a quick Google for "zotac zbox d80" but came up empty, are you sure that's the model number? Please provide a full debug log and dmesg.

I'm wondering is it this Zotac he's talking about,with a
NVIDIA GeForce GT520M Zotac ID80 ?


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Milhouse - 2016-07-22

(2016-07-22, 16:35)bazzz3 Wrote:
(2016-07-22, 12:50)Milhouse Wrote: What GPU does the D80 use - I did a quick Google for "zotac zbox d80" but came up empty, are you sure that's the model number? Please provide a full debug log and dmesg.

I'm wondering is it this Zotac he's talking about,with a
NVIDIA GeForce GT520M Zotac ID80 ?
Could be, in which case the updated nvidia driver would be the obvious candidate for breaking standby (in which case there's probably not much we can do).

@xxxnelly if your Zotac box is using an nvidia GPU, try build #0709x - this is the same as #0709 but uses the older 340.96 driver in place of 367.27. This should help confirm the standby issue is being caused by the latest nvidia drivers.