Kodi Community Forum
v17 LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Linux (https://forum.kodi.tv/forumdisplay.php?fid=52)
---- Thread: v17 LibreELEC Testbuilds for x86_64 (Kodi 17.0) (/showthread.php?tid=269815)



RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Milhouse - 2016-08-03

(2016-08-03, 22:58)Martijn Wrote: Huh? The settings should be stored by setting id regardless of where the setting is.

OK I'll dig into it, something weird is happening.


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Milhouse - 2016-08-03

Meh. In LibreELEC we enable the webserver by default in appliance.xml which clearly needs tweaking in light of the settings changes, as we're no longer enabling the webserver by default.


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Milhouse - 2016-08-03

New LibreELEC.tv Krypton build #0803: Generic
(Supercedes previous build)

Code:
# uname -a
Linux NUC 4.7.0 #1 SMP Wed Aug 3 22:21:35 BST 2016 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse) - Version: devel-20160803221747-#0803-g32f35d3 [Build #0803]

Based on tip of LibreELEC.tv master (32f35d3d, changelog) and tip of XBMC master (b04140e5, changelog) with the following modifications: Build Highlights:
  1. PR:10216 player: make playspeed floating point and add tempo controls
  2. PR:10222 VideoPlayer: write state of clocksync to ProcessInfo, make FinishPipeline dependent on this
Build Details:
  1. LibreELEC.tv:
    • kodi: Fix green screen on Generic (PR:598, 1 commit, 1 file changed)
    • projects/imx6/linux: disable kernel NTFS support (PR:601, 1 commit, 1 file changed)
    • dispmanx_vnc: build with linux 4.7 rpi libraries (PR:602, 1 commit, 3 files changed)
    • Fix build of AML-based projects after updating to Krypton Alpha3 (PR:603, 3 commits, 20 files changed)
    • spotify-connect-web: initial addon (PR:580, 1 commit, 8 files changed)
  2. XBMC:
    • [Socket] fix port assignments (PR:10220, 1 commit, 1 file changed)
    • [droid] show correct labels of plugged USB drives (PR:10209, 1 commit, 13 files changed)
    • [linux] fix datadir (KODI_HOME) detection (PR:10217, 1 commit, 1 file changed)
    • listproviders: fix segfault introduced by 2702a31f6dc1e9b6d9aaab56bc5… (PR:10223, 1 commit, 2 files changed)
    • [droid] remove google-breakpad (PR:10226, 1 commit, 3 files changed)
  3. pvr.vdr.vnsi:
    • drop -1 from list of priorities (PR:86, 1 commit, 1 file changed)
  4. Additional commits/pull requests/changes not yet merged upstream:



RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Milhouse - 2016-08-04

The webserver being disabled by default will be corrected in #0804.


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Ichabod Fletchman - 2016-08-04

(2016-08-03, 13:54)LateAdopter Wrote: The Sony TV data linked in the earlier post says it can only do the off standard YCC 420 at 60Hz, but Intel linux drivers don't do YCC.

By YCC 420 are you talking about (YCbCr4:2:0 8bit) that is listed on the Sony TV details?
I have done a bit of research and testing, and from what I can tell, LibreELEC will only output at RGB.
I tried changing a few things in xrandr to try using 'Limited' colours, but still can't get 3840x2160 at either 30hz or 60hz.

Sorry, I really don't know anything about monitor/colourspace configurations; I might be trying pointless stuff here.
Because it is working in Windows at 60hz, should I send through some detailed output from Windows?


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - LateAdopter - 2016-08-04

Yes: (YCbCr4:2:0 8bit) only needs half of the bit rate of RGB 444 and will work over HDMI 1.4 hardware. The Intel linux HDMI driver only does RGB, so it can't connect to your TV. The Windows driver has different capabilities.


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Ichabod Fletchman - 2016-08-04

(2016-08-04, 09:53)LateAdopter Wrote: Yes: (YCbCr4:2:0 8bit) only needs half of the bit rate of RGB 444 and will work over HDMI 1.4 hardware. The Intel linux HDMI driver only does RGB, so it can't connect to your TV. The Windows driver has different capabilities.

Well that's a bummer. I appreciate the info though.
Do you or anybody know of a workaround, patch or anything that would allow this to work?


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - _Spook_ - 2016-08-04

Works with my LG OLED, but that does do RGB. So that may be why it works for me.


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Ichabod Fletchman - 2016-08-04

(2016-08-04, 10:21)Ichabod Fletchman Wrote:
(2016-08-04, 09:53)LateAdopter Wrote: Yes: (YCbCr4:2:0 8bit) only needs half of the bit rate of RGB 444 and will work over HDMI 1.4 hardware. The Intel linux HDMI driver only does RGB, so it can't connect to your TV. The Windows driver has different capabilities.

Well that's a bummer. I appreciate the info though.
Do you or anybody know of a workaround, patch or anything that would allow this to work?

I have done a bit more researching and found this thread for the Raspberry Pi: http://forum.kodi.tv/showthread.php?tid=237892
There is a post from Milhouse with a link to hdmi_pixel_encoding for the RPi. It appears that you can set different modes:
• hdmi_pixel_encoding=0 default (limited for CEA, full for DMT)
• hdmi_pixel_encoding=1 RGB limited (16-235)
• hdmi_pixel_encoding=2 RGB full ( 0-255)
• hdmi_pixel_encoding=3 YCbCr limited (16-235)
• hdmi_pixel_encoding=4 YCbCr full ( 0-255)

I am wondering if something already exists for this in LibreELEC or if it could be incorporated?


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Milhouse - 2016-08-04

(2016-08-04, 16:16)Ichabod Fletchman Wrote: I have done a bit more researching and found this thread for the Raspberry Pi: http://forum.kodi.tv/showthread.php?tid=237892
There is a post from Milhouse with a link to hdmi_pixel_encoding for the RPi. It appears that you can set different modes:
• hdmi_pixel_encoding=0 default (limited for CEA, full for DMT)
• hdmi_pixel_encoding=1 RGB limited (16-235)
• hdmi_pixel_encoding=2 RGB full ( 0-255)
• hdmi_pixel_encoding=3 YCbCr limited (16-235)
• hdmi_pixel_encoding=4 YCbCr full ( 0-255)

I am wondering if something already exists for this in LibreELEC or if it could be incorporated?

Those settings are nothing to do with LibreELEC, they're specific to the Raspberry Pi platform (ie. hardware) and I don't think there's anything similar for x86_64.


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Milhouse - 2016-08-05

New LibreELEC.tv Krypton build #0804: Generic
(Supercedes previous build)

Code:
# uname -a
Linux NUC 4.7.0 #1 SMP Thu Aug 4 22:45:58 BST 2016 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse) - Version: devel-20160804224402-#0804-g33aafb5 [Build #0804]

Based on tip of LibreELEC.tv master (33aafb5c, changelog) and tip of XBMC master (49ea0980, changelog) with the following modifications: Build Highlights:
  1. curl: bump 7.50.1 (same as kodi)
  2. Fix appliance.xml - webserver enabled by default
  3. VAAPI: Use VAAPI's BOB implementation by default (PR:10170)
Build Details:
  1. LibreELEC.tv:
    • spotify-connect-web: add icon (PR:604, 1 commit, 1 file changed)
  2. XBMC:
    • VAAPI: Use VAAPI's BOB implementation by default (PR:10170, 4 commits, 2 files changed)
    • player: make playspeed floating point and add tempo controls (PR:10216, 4 commits, 17 files changed)
    • inputstream: bump version (PR:10212, 1 commit, 1 file changed)
    • [PVR][guiinfo] Recordings: Add more VIDEOPLAYER info labels (e.g. VIDEOPLAYER_EPISODENAME). (PR:10221, 2 commits, 2 files changed)
    • BuildSetup: don't copy the contents of \system in \BUILD_WIN32\applic… (PR:10214, 1 commit, 1 file changed)
    • inputstream: add API version check (PR:10228, 1 commit, 4 files changed)
    • [cmake] Don't repeat optional dependencies (PR:10210, 2 commits, 6 files changed)
    • [droid] fix build and cleanup after Breakpad removal (PR:10230, 1 commit, 8 files changed)
    • Curl: Support version 7.5.0 and upwards (PR:10160, 1 commit, 1 file changed)
    • CompileWarnings: Fix some signed / unsigned vs unused variables (PR:9502, 1 commit, 3 files changed)
    • VideoPlayer: write state of clocksync to ProcessInfo, make FinishPipeline dependent on this (PR:10222, 3 commits, 9 files changed)
    • [depends] curl 7.50.1 (PR:10219, 1 commit, 1 file changed)
    • BuildSetup: don't copy the contents of \system in \BUILD_WIN32\application (cb767692)
  3. Additional commits/pull requests/changes not yet merged upstream:



RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - C-Quel - 2016-08-05

Just a quick question before I report this as a bug. I own a Zotac BI323 and just recently have noticed that when using shutdown either idle shutdown / yatse remote or power menu it SOMETIMES does not complete the shutdown process and hangs. Forcing me or the wife to power the unit off physically and back on. Seen a few recent attempts at fixes for similar issues, is this still an ongoing issue for some users?

Thank you.


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Milhouse - 2016-08-05

There's a segfault caused by nfs:// which might be part of the problem. It's hard to say though without a journalctl of the failed shutdown, and to see this you'll need to add "debugging" to your kernel parameters, then having experienced a failed shutdown restart the box and look at the previous bootlog ("journalctl -b1", I think) which may then include details of what went wrong.


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - C-Quel - 2016-08-05

ok ill switch to smb for a few days to rule out nfs:// connections... if successful then i will report back! you may be right as i hold a shared db on my nas which is accessed via nfs:// maybe its not closing this correctly on shutdown


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - C-Quel - 2016-08-05

hmmm actually come to think of it... i bet its the mounted folder for the nas for recorded tv that is the issue!... i will check that first...