Kodi Community Forum
Support for H.264 on NV GT218 (ion) with Jarvis? - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Video Support (https://forum.kodi.tv/forumdisplay.php?fid=264)
--- Thread: Support for H.264 on NV GT218 (ion) with Jarvis? (/showthread.php?tid=276779)



Support for H.264 on NV GT218 (ion) with Jarvis? - ocgltd - 2016-05-26

I have an atom+ion2 (GT218) nvidia card, running Ubuntu 16.04 with NVidia 304.131 drivers.

When I try to play back H.264 video the video is choppy (audio is fine). Is there something I'm missing / need to do to accelerate H264 encoded video?


RE: Support for H.264 on NV GT218 (ion) with Jarvis? - nickr - 2016-05-26

debug log (wiki)


RE: Support for H.264 on NV GT218 (ion) with Jarvis? - ocgltd - 2016-05-27

I created a log after watching ~5 seconds of video from the Myth back-end. The log is here: kodi.log: http://xbmclogs.com/p7kygdakd

These errors seem to be related:
ERROR: CDVDAudio::AddPacketsRenderer - timeout adding data to renderer
ERROR: (VDPAU) Error: An invalid pointer was provided.(4) at VDPAU.cpp:1064
ERROR: Decode - avcodec_decode_video returned failure

Can anyone suggest a next step to diagnose?


RE: Support for H.264 on NV GT218 (ion) with Jarvis? - ocgltd - 2016-05-27

I found a workaround (i wouldn't call it a solution). If I disable de-interlacing for a single video (using ENTER then B key), then playback is smooth.

Until I figure out the root cause, is there a way to set DEFAULT deinterlacing of TV to OFF ? (So I don't have to turn it off every channel/recording)?


RE: Support for H.264 on NV GT218 (ion) with Jarvis? - FernetMenta - 2016-05-27

What de-interlacing methods did you try? ion2 is too weak for doing high quality de-interlacing (temporal spatial) for 1080i. Set to temporal.


This forum uses Lukasz Tkacz MyBB addons.