Kodi Community Forum
Disabling onboard RPi3 wifi running LibreELEC - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Raspberry Pi (https://forum.kodi.tv/forumdisplay.php?fid=166)
---- Thread: Disabling onboard RPi3 wifi running LibreELEC (/showthread.php?tid=281325)



Disabling onboard RPi3 wifi running LibreELEC - nickrob84 - 2016-07-02

I'm running numerous RPi3's all running LibreELEC 7.0.2 and Edimax EW-7811UTC 5G dongles via wlan1 on a 5ghz wifi network. Problem is that the onboard wifi on wlan0 randomly tries to override the dongle and find its own (non existent) connection and dropping wlan1 out. Is there anyway I can disable the onboard wifi baring in mind I am solely running LibreELEC? Thank you.


RE: Disabling onboard RPi3 wifi running LibreELEC - Milhouse - 2016-07-02

Try creating a blacklist.

Create the file /etc/modprobe.d/raspi3-blacklist.conf by adding the following entries:
Code:
#wifi
blacklist brcmfmac
blacklist brcmutil
#bt
blacklist btbcm
blacklist hci_uart

If you want Bluetooth, don't include the last 3 lines.


RE: Disabling onboard RPi3 wifi running LibreELEC - nickrob84 - 2016-07-02

Thanks Millhouse. Can I input all that at once via SSH? Or separate lines?


RE: Disabling onboard RPi3 wifi running LibreELEC - Milhouse - 2016-07-03

(2016-07-02, 16:33)nickrob84 Wrote: Thanks Millhouse. Can I input all that at once via SSH? Or separate lines?

Not sure what you mean, use "nano" or "vi" to edit "/etc/modprobe.d/raspi3-blacklist.conf" then enter the lines you need. Save the file. Reboot, and your onboard WiFi (and/or BT) should be disabled.


RE: Disabling onboard RPi3 wifi running LibreELEC - nickrob84 - 2016-07-03

I know what you mean now, sorry am still fairly new to all this. Appreciate your help once again.


RE: Disabling onboard RPi3 wifi running LibreELEC - nickrob84 - 2016-07-03

Image

Apologies Millhouse - I know your dealing with an idiot here but from the point in the picture I want to (^O) write out then reboot?


RE: Disabling onboard RPi3 wifi running LibreELEC - Milhouse - 2016-07-03

Or: ctrl-x, y, return


RE: Disabling onboard RPi3 wifi running LibreELEC - nickrob84 - 2016-07-03

Thank you.


This forum uses Lukasz Tkacz MyBB addons.