Kodi Community Forum
MovieMeter.nl (Dutch Movies) Scraper development... - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Add-on Support (https://forum.kodi.tv/forumdisplay.php?fid=27)
+---- Forum: Metadata scrapers (https://forum.kodi.tv/forumdisplay.php?fid=147)
---- Thread: MovieMeter.nl (Dutch Movies) Scraper development... (/showthread.php?tid=28297)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30


- Vertigo - 2011-01-30

It works for me for most movies.
However, a few recent one's dont work because they have special characters in the name. Like

Wall Street: Money Never Sleeps (2010)

The colon messes it up. If I leave it out, its not recognised, and my filesystem doesnt like colons.

Same with:

O Brother, Where Art Thou? (2000)

Here it is the question mark. One would think it would find it without the question mark, but halas. Both movies work fine with IMDB scraped.

Any suggestions?


- Vertigo - 2011-01-30

The_Ghost16 Wrote:I have fixed some issues (I think), but i can't test them right now.

The things I fixed:
-When a movie title isn't found it will be stored and that day it will not request the same title again.
- Made a fix to movie titles that contain illegal filename characters. Like: \ / ' : ? and some more.

I will hope there will be no problems and i will check this tomorrow.

I just bumped into both those issues. I had a few movies with a colon or question mark in them, and neither where found. If it helps:
O Brother, Where Art Thou? (2000) and
Wall Street: Money Never Sleeps (2010)

Looking forward to seeing this fixed, and THANK YOU for your work.

BTW, I use both IMDB and Moviemeter scraper (on different folders) because I have a fair amount of movies not listed in moviemeter. A small problem that arises from that is that the categories are messed up, containing both english and dutch categories. Also my skin is unaware of the dutch categories, which gives me rather ugly question mark icons. Is there anyway I can fix that? Even by mapping them by hand or something. I dont care too much if it ends up in english or dutch but its annoying having some movies under 'Family" and others under "Familie".


- The_Ghost16 - 2011-01-31

Today I made some fixes to the website to make it even more better.
To let it all work properly I had to delete the information i collected so far.

So every movie has to be found on moviemeter again. So I think sometimes the scraper won't find anything because of the 5000 requests per day limitation.

Fixes I made:
- Alternative title is saved now. And will also be searched when a movie title is entered.

A good example for this is the movie Step Up 2. Because thats the alternative title and Step Up 2: The Streets is the original title. And many people will use the first notation.
So this had to be searched over and over again at MovieMeter. Which isn't very handy.

I hope the issues with the limitations will not be very annoying. And that most of the problems with the scraper are now fixed so i can expand the functionality of it.


- Vertigo - 2011-01-31

The_Ghost16 Wrote:Today I made some fixes to the website to make it even more better.
Awesome. Tried it on a few known problematic cases and it seems to work for me Smile Ill test on my entire collection later.

Just one minor nitpick; In my xbmc movie library the movie names also show up without the special characters. Eg, "O, Brother where art thou?" there is no question mark at the end. With MovieDB scraper they show up correctly. But thats hardly a big deal. Thanks a lot!


- The_Ghost16 - 2011-01-31

Thats nice to hear that it works better now.

That little thingy is indeed correct. Maybe i will change that today else i will make a fix for that tomorrow.

Thnx for the information.

EDIT: I have implemented and original title feature. So in XBMC it should show the original title instead of the filename title.


- Vertigo - 2011-02-02

Yep that looks fixed too Smile

Im trying to move my entire library to moviemeter now, and the first one Im stumbling on is "Moon". This one:
http://www.moviemeter.nl/film/50933

No matter how I call the folder, adding the year, it turns in to "alabama moon" or whatever, but not the correct one. Ill post further issues as I find them.

edit: looks like the problem is with single worded movie names. I have the same problem with 'doubt":
http://www.moviemeter.nl/film/49418

Thanks again!


- The_Ghost16 - 2011-02-02

Vertigo thnx for your input.

I tested the movie Doubt. But it will find it correctly. Maybe because another movie that was found already had that as alternative title. To solve this adding the year was good enough. So when the name was 'Doubt (2008)' it would find the correct one.

And for the movie Moon i couldn't test it because the movie was already found.


- The_Ghost16 - 2011-02-03

A new update on the scraper has been made.

It will now better support nfo files.

The next thing that will be implemented is trailers for the movie.
And after that i will try to look at different filename structures.


- Xenomes - 2011-02-03

The_Ghost16 Wrote:A new update on the scraper has been made.

It will now better support nfo files.

The next thing that will be implemented is trailers for the movie.
And after that i will try to look at different filename structures.

Good job! I will update tonight to the new version. Laugh


- lowfi - 2011-02-04

Thanks for adding nfo support Smile

From my 211 movies now 9 are not scraped. Is there any quick way of checking which ones?

All my movie folders have a nfo file with imdb url.


- The_Ghost16 - 2011-02-04

lowfi Wrote:Thanks for adding nfo support Smile

From my 211 movies now 9 are not scraped. Is there any quick way of checking which ones?

All my movie folders have a nfo file with imdb url.
Your welcome.

I don't know how you can check the unscraped movies. If you can find out which ones they are, I can check why they aren't scraped.


- lowfi - 2011-02-06

Missing movies are also scraped now Smile Not sure what went wrong...

Is it also possible to add the studio?


- The_Ghost16 - 2011-02-07

Studio should already be in it.

But i can't check it right now. So when i have to the time, i will check it out. And if it's missing i will try to fix it as soon as possible.

Are there any other features that are missing?


- redje - 2011-02-07

The_Ghost16 Wrote:Studio should already be in it.

But i can't check it right now. So when i have to the time, i will check it out. And if it's missing i will try to fix it as soon as possible.

Are there any other features that are missing?

i think rating like mpaa is missing, not much of an issue, but i'm using cinema experience and mpaa rating would be a nice addition Smile


Dutch movie name instead of English? - brulsmurf - 2011-02-10

I tried to scrape my children's collection of animated movies, and I found that the scraper returns the English title of the movie (e.g. "Aladdin and the King of Thieves" instead of "Aladdin en de Dievenkoning"). I think this is because MovieMeter itself uses the English titles. But it also adds the Dutch titles as Älternative" titles. Would it be possible to (have a configuration option to) use the alternative titles instead of the "main" titles?