Kodi Community Forum
MovieMeter.nl (Dutch Movies) Scraper development... - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Add-on Support (https://forum.kodi.tv/forumdisplay.php?fid=27)
+---- Forum: Metadata scrapers (https://forum.kodi.tv/forumdisplay.php?fid=147)
---- Thread: MovieMeter.nl (Dutch Movies) Scraper development... (/showthread.php?tid=28297)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30


- BertusG - 2011-06-17

Xenomes Wrote:I found in your logfile, that the name and directory is "Age of Heroes (2010)" but the movie on moviemeter is from 2011, change it and try again!

Unfortunately, after changing the year the effect is still the same. According to the log file I don't think that it is searching for fanart at MovieDB anyway?


- Xenomes - 2011-06-17

I have created the file in my xbmc, after updating all info and Cover are shown. But the Fanart not there.


- BertusG - 2011-06-17

Xenomes Wrote:I have created the file in my xbmc, after updating all info and Cover are shown. But the Fanart not there.

Does your logfile give any clues why it is not downloading the fanart? Other recent examples of movies with no fanart (however available on MovieDB) are "Last Night (2010)", "Little Fockers (2010)".


- JackSparrow - 2011-07-04

I have the situation that despite I have activated the option to fetch the rating from the IMDB the moviemeter scraper does not.

It did work several weeks ago. Now when I refresh a movie that has a rating the rating is not fetched and it says -. All movies XBMC fetched had an IMDB rating it just does not fetch it anymore.

Any ideas how to fix the situation?


- donmark82 - 2011-07-13

The scraper doesn't find the following movies;
S.W.A.T. (2003)
The Pirates Of Caribbean: At World's End (2007)

I tried serveral things, but nothing works.
Can anybody (The_Ghost16) fix this?


- The_Ghost16 - 2011-07-14

I tested S.W.A.T. (2003) and this movie is normally found.
And The Pirates Of Caribbean: At World's End (2007) cannot be found because you have to remove 'The' because that doesn't belong to the title.

You could also check on the moviemeter site what the name needs to be. And when you use the same name as moviemeter and it still doesn't work there is something else.


- Xenomes - 2011-07-14

*Deleted*


- donmark82 - 2011-07-14

I have 400 movies and have only problems with S.W.A.T. and Pirates Of The Caribbean: At World's End and i use for all my movies the same title as in MovieMeter.

The hit I have with S.W.A.T. is the movie Satta if i remove the dots. Even manually i can't find S.W.A.T, but i find SWAT: Warhead One, but thats another movie.

The word "The" was a typing mistake in my previous post.
I have no hit at all with Pirates Of The Caribbean: At World's End. The other 2 movies of Pirates Of The Caribbean i have no problems.


- The_Ghost16 - 2011-07-14

I only tested it online on the website the scraper is calling to find the movies and that was working correctly.

If i find some time today i will create 2 files on my machine with the names and start scraping them. As soon as i have done that i will let you know what the results are.

EDIT:
I tested with the following filenames:
Pirates of the Caribbean At World's End (2007).mkv
S.W.A.T. (2003).mkv

And both movies are found.

Could you provide more information about the filenames and the folder structure you are using. So i can help you further with that (or could you try scraping them again).


- Xenomes - 2011-07-14

I tested the files as well.
Pirates of the Caribbean At World's End (2007).mkv
S.W.A.T. (2003).mkv

Both files are found.


- donmark82 - 2011-07-14

Rootfolder: Films

Subfolder --> Pirates Of The Caribbean; At World's End (2007)
File --> Pirates Of The Caribbean; At World's End.m4v
File --> Folder.jpg

Subfolder --> S.W.A.T. (2003)
File --> S.W.A.T.m4v
File --> Folder.jpg

Thanks for the quick responses. I appreciate it.


- Robotica - 2011-07-14

donmark82 Wrote:Rootfolder: Films

Subfolder --> Pirates Of The Caribbean; At World's End (2007)
File --> Pirates Of The Caribbean; At World's End.m4v
File --> Folder.jpg

Subfolder --> S.W.A.T. (2003)
File --> S.W.A.T.m4v
File --> Folder.jpg

Thanks for the quick responses. I appreciate it.

Code:
Pirates of the Caribbean; At World's End
should be

Code:
Pirates of the Caribbean: At World's End

I think the scraper shouldn't make a difference for ; and : (nor just a space in between)

This is also how search at moviemeter works.


- The_Ghost16 - 2011-07-14

donmark82 Wrote:Rootfolder: Films

Subfolder --> Pirates Of The Caribbean; At World's End (2007)
File --> Pirates Of The Caribbean; At World's End.m4v
File --> Folder.jpg

Subfolder --> S.W.A.T. (2003)
File --> S.W.A.T.m4v
File --> Folder.jpg

Thanks for the quick responses. I appreciate it.

That Pirates Of The Caribbean; At World's End (2007) is due to the ';' instead of the ':'. MovieMeter doesn't know that movie name.
Or i should make a change that every ';' is converted to a ':' or you should update your filename.

And for S.W.A.T. do you use filenames to search for or folder names?


- Robotica - 2011-07-14

The_Ghost16 Wrote:That Pirates Of The Caribbean; At World's End (2007) is due to the ';' instead of the ':'. MovieMeter doesn't know that movie name.
Or i should make a change that every ';' is converted to a ':' or you should update your filename.

And for S.W.A.T. do you use filenames to search for or folder names?

I think changing it like Moviemeter works is the way to go since this is a very common scenario.


- The_Ghost16 - 2011-07-14

Robotica Wrote:I think changing it like Moviemeter works is the way to go since this is a very common scenario.
I also think this is the best solution. I hope i can fix this today.

When it's finished i will post it here. So you all know that it should be solved.

For the SWAT issue i need some more information.