Kodi Community Forum
v18 LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Linux (https://forum.kodi.tv/forumdisplay.php?fid=52)
---- Thread: v18 LibreELEC Testbuilds for x86_64 (Kodi 18.0) (/showthread.php?tid=298462)



RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - pacoma2610 - 2017-09-11

@Milhouse

# 910 and 910z cause problems with forward and rewind, the image is immediately there, the sound is delayed by 2 - 3 times until it sounds again. Also, the sound is generally quieter, so I must raise the TV volume by 25 - 30% to reach the same volume, as usual.

With Build # 909 everything is fine


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Boulder - 2017-09-11

(2017-09-10, 19:23)Milhouse Wrote:
(2017-09-10, 16:27)Boulder Wrote: The bluetooth adapter in my Asus Chromebox (M004U) doesn't seem to work with the test build. Is this a known issue and if not, can I help in any way to get it working? I was interested in trying Leia to build a retro gaming platform along the normal Kodi usage.
Upload the latest logfile zip archive from the Logfiles samba share.

Here's the logfile archive right after installing #910.

https://drive.google.com/open?id=0BzeF_1syecQwLVhKWlVfU3YtN2s

Just let me know if you need anything else.


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Living Legend - 2017-09-11

I never thorughly tested the 908z, but could confirm that the GUI was working better.

But after attempting to actually use today, I'm getting constant crashes and reboots.

Here's the log file:

http://sprunge.us/hACU

This could be related to the VM. I certainly could allocate more resources if the logfile is showing that my hardware is not adequate. But 4MB RAM and 4 cores should be sufficient....


LibreELEC Testbuilds for x86_64 (Kodi 18.0) - lrusak - 2017-09-11

(2017-09-11, 17:29)Living Legend Wrote: This could be related to the VM. I certainly could allocate more resources if the logfile is showing that my hardware is not adequate. But 4MB RAM and 4 cores should be sufficient....


I hope that's a typo!


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Living Legend - 2017-09-11

(2017-09-11, 17:52)lrusak Wrote:
(2017-09-11, 17:29)Living Legend Wrote: This could be related to the VM. I certainly could allocate more resources if the logfile is showing that my hardware is not adequate. But 4MB RAM and 4 cores should be sufficient....


I hope that's a typo!

Ahhh, 4 GB RAM haha.


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Milhouse - 2017-09-11

(2017-09-11, 17:29)Living Legend Wrote: But after attempting to actually use today, I'm getting constant crashes and reboots.

Do you not have a crashlog? And LE is rebooting, for what reason?


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Milhouse - 2017-09-11

New LibreELEC.tv Leia build #0911: Generic
(Supercedes previous build)

Code:
# uname -a
Linux NUC 4.13.0 #1 SMP Mon Sep 11 21:05:52 BST 2017 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse): devel-20170911210345-#0911-g57014df [Build #0911]

# Kodi version
(18.0-ALPHA1 Git:bc12cb0). Platform: Linux x86 64-bit

Based on tip of LibreELEC.tv master (57014df, changelog) and tip of XBMC master (bc12cb0, changelog) with the following modifications:
  • Includes latest kodi-platform master (36fb493)
  • Includes latest libcec master (8adc786, ahead +26)
  • Includes latest libnfs master (3ba2a2c, ahead +101)
  • Includes latest p8-platform master (a822e19)
  • Includes latest addons: inputstream.adaptive (d417964, +5), inputstream.rtmp (e094fa3), peripheral.joystick (cc14287), pvr.argustv (23cc0e8), pvr.demo (122dedd), pvr.dvblink (816f90c), pvr.dvbviewer (8741c8b), pvr.filmon (34dca04), pvr.hdhomerun (ace19fa), pvr.hts (53118d8), pvr.iptvsimple (ac4f4bd), pvr.mediaportal.tvserver (c86ab35), pvr.mythtv (b46e5be), pvr.nextpvr (a855663), pvr.njoy (99874de), pvr.octonet (a77cf11), pvr.pctv (549f690), pvr.stalker (e15edca), pvr.vbox (b5da811), pvr.vdr.vnsi (f3f80d5, +1), pvr.vuplus (9bfd868), pvr.wmc (d820bf8), pvr.zattoo (a24879b)
  • Include [env] 22775c5: include crazycat dvb drivers addon in image
  • Include [env] patch: RPi/RPi2: enable Broadcom WiFi debugging (see details)
  • Include [env] patch: libcec: don't link non-existant libtinfo
  • Include [env] patch: rev hack for kodi
  • Include [env] patch: Add experimental splash video for RPi
  • Include [env] patch: Bump included addon versions to prevent online updates
  • Include [env] patch: HACK: Disable multiple PVR addons during migration. Always enable inputstream.* and os.*
  • Include [env] patch: Add kodi binary addons (pvr, adsp, inputstream, vfs, other)
  • Include [env] patch: pvr addons: disable broken addons
  • Include [env] PR:1773: init: make break after behaviour really break after
  • Include [env] PR:1776: Don't cause system to hang on halt/reboot when net-booting
  • Include [env] PR:1791: nss/nspr: include in main image [rfc]
  • Include [env] PR:1835: add support for optional kernel modules in image and from addons
  • Include [env] PR:1919: samba: don't restart smbd in samba-autoshare
  • Include [env] PR:1958: samba: validate samba user config and don't use if legacy or incompatible
  • Include [pkg] patch: skin.estuary: reduce system info font size (kodi)
  • Include [pkg] PR:234: implement intensity compensation for VC-1 decoding for Ivybridge and better (intel-vaapi-driver)
  • Include [pkg] PR:260: Fix Seeking with VC1 after 6702b01ee3598017f05374bfc7956493f790361c (intel-vaapi-driver)
  • Include [pkg] PR:12767: Partial revert of imdb crashfix due to a introduced bug
Build Highlights:
  1. Minors
Build Details:
  1. LibreELEC.tv:
    • wireless-regdb: update to wireless-regdb-2017.03.07 (PR:1956, 1 commit, 1 file changed)
    • sundtek-mediatv: localize ir_disabled parameter (PR:1957, 1 commit, 4 files changed)
    • build some more packages with fPIC (PR:1950, 2 commits, 2 files changed)
    • package updates (PR:1947, 3 commits, 3 files changed)
      • llvm: update to 5.0.0
      • pulseaudio: update to 11.0
      • mesa: remove depreciated options
    • linux: enable ftrace (PR:1917, 2 commits, 4 files changed)
    • updated getedid script because of an issue (PR:1961, 1 commit, 1 file changed)
  2. XBMC:
    • [PVR] CPVRClient(s)::OpenStream: Remove unused parameter bIsSwitchingChannels (PR:12788, 1 commit, 5 files changed)



RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Milhouse - 2017-09-12

(2017-09-11, 17:24)Boulder Wrote: Here's the logfile archive right after installing #910.

It looks like the Chromebook needs the ar3k firmware.
Code:
[    3.672332] usb 1-4: Direct firmware load for ar3k/AthrBT_0x11020000.dfu failed with error -2
[    3.672338] Bluetooth: Patch file not found ar3k/AthrBT_0x11020000.dfu
[    3.672339] Bluetooth: Loading patch file failed
[    3.672349] ath3k: probe of 1-4:1.0 failed with error -2
[    3.672392] usbcore: registered new interface driver ath3k
[    3.675236] usbcore: registered new interface driver btusb
I'll include this in tomorrows #0912 build, please confirm if that resolves the issue tomorrow.


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - pacoma2610 - 2017-09-12

@Milhouse

# 910, 910z and @911cause problems with forward and rewind, the image is immediately there, the sound is delayed by 2 - 3 times until it sounds again. Also, the sound is generally quieter, so I must raise the TV volume by 25 - 30% to reach the same volume, as usual.

With Build # 909 everything is fine


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Milhouse - 2017-09-12

@pacoma2610 yes I saw your previous post. It doesn't include a debug log - you know the drill, no debug log, no problem.

Also it doesn't sound like it's a common issue (nobody else has complained, so far) - have you tried a "clean" setup to make sure it's not a duff setting?

There were two audio changes in #0910 so maybe @fritsch can suggest something (if he has time), but without a debug log there's nothing to go on here.


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - pacoma2610 - 2017-09-12

@Milhouse

Debug Log https://www.dropbox.com/s/a2tjoetu9zbjyo1/kodi.log?dl=0


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Milhouse - 2017-09-12

(2017-09-12, 07:25)Milhouse Wrote: have you tried a "clean" setup to make sure it's not a duff setting?

^^ @pacoma2610


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - pacoma2610 - 2017-09-12

@Milhouse

Nop, do this today


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - pacoma2610 - 2017-09-12

@Milhouse

Also after Cleaninstall same Problem


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - UrushibaraRuka - 2017-09-12

(2017-09-11, 16:12)pacoma2610 Wrote: @Milhouse

# 910 and 910z cause problems with forward and rewind, the image is immediately there, the sound is delayed by 2 - 3 times until it sounds again. Also, the sound is generally quieter, so I must raise the TV volume by 25 - 30% to reach the same volume, as usual.

With Build # 909 everything is fine

Pretty much the same here with the exception off the quieter sound.

It also happens when I resume a movie or video that I stopped earlier. Image is immediately on my screen but audio take 2-3 seconds.

The forward/rewind stuff started with #0831 if I remember it correctly, the stop/resume with #0904.

I'll try to post a log when I get back home, and to be fair, my system was an OpenELEC 3 or 4, updated to LibreELEC 6, then to LE7 followed by LE8 and now your alpha builds.
I wouldn't be surprised if there's old stuff bugging out.