Kodi Community Forum
v18 LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Linux (https://forum.kodi.tv/forumdisplay.php?fid=52)
---- Thread: v18 LibreELEC Testbuilds for x86_64 (Kodi 18.0) (/showthread.php?tid=298462)



RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Nekromantik - 2018-03-06

hi

just installed build 0304 and got a bug. after finishing watching an item and pressing stop kodi seems to crash. it goes to a black screen with mouse pointer and after 2-3 mins it restarts Kodi.
pressing upload crash log files from LE settings dont work so had to use samba to transfer to laptop and upload.
crash log: https://paste.ubuntu.com/p/ZFTYWMMn9K/

edit: also happens on 0303

thanks


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Milhouse - 2018-03-06

(2018-03-06, 00:39)Nekromantik Wrote: hi

just installed build 0304 and got a bug. after finishing watching an item and pressing stop kodi seems to crash. it goes to a black screen with mouse pointer and after 2-3 mins it restarts Kodi.
pressing upload crash log files from LE settings dont work so had to use samba to transfer to laptop and upload.
crash log: https://paste.ubuntu.com/p/ZFTYWMMn9K/

edit: also happens on 0303

thanks

Yes, it's been reported by others. And in RPi builds. Apparently #0228 is the last build without this issue. Haven't been able to reproduce it myself.


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Nekromantik - 2018-03-06

Ah ok.
If it cant be re produced then will it mean fix is unlikely?


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Milhouse - 2018-03-06

(2018-03-06, 01:22)Nekromantik Wrote: Ah ok.
If it cant be re produced then will it mean fix is unlikely?

Certainly less likely, rather than unlikely.

Knowing what causes it, and how it can be caused (precise circumstances) will help enormously. Since I'm not seeing it, but you (and two or three others) are, this may require a specific setting or configuration in order for the issue to be triggered.

Do you use Trakt, or movie/music ratings?

Since this issue started with #0301, the only possible candidate would appear to be PR13533 which touches the application message handling and may now be causing unwanted side effects at the end of videos.

I'll upload a debug-enabled test build without PR13533 in a short while.


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Milhouse - 2018-03-06

I've uploaded a debug-enabled build of #0305 with PR13533 reverted:

#0305y: Generic

Can those experiencing crashes at the end of playback test with #0305y and confirm if the crashes continue - if so, please upload the new crashlog. Thanks


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - basco - 2018-03-06

(2018-03-05, 22:15)kowalmisiek Wrote: Hello Milhouse

I installed on trial New LibreELEC.tv Leia build # 0304: Generic. As for Live TV, this is a tragedy. The sound is not synchronized with the image. Often the difference is about 5 seconds.

1. As the "Adjust display refresh rate" option is switched off, the sound is poorly synchronized.
2. As the "Adjust display refresh rate" option is enabled, the sound is poorly synchronized + from time to time there are jerks on the screen.

This is my log

https://pastebin.com/h561wxGt
same behavior here. same errors (if relevant) in my log

cat 4061867cc46e/.kodi/temp/kodi.log | grep error

22:25:12.804 T:140444113544960   DEBUG: AddOnLog: Tvheadend HTSP Client: pvr.hts - recording id:2089880377, stateConfusedcheduled, title:Keuringsdienst van waarde, desc:, error:none
22:25:30.003 T:140444557379328   DEBUG: ActiveAE::SyncStream - average error of -659.832480, start adjusting
22:25:30.155 T:140444557379328   DEBUG: ActiveAE::SyncStream - average error -2.957890 below threshold of 30.000000
22:25:33.556 T:140443027162880   ERROR: ffmpeg[7FBB70BEC700]: [h264] error while decoding MB 0 48, bytestream 117841
22:25:34.650 T:140442947548928   ERROR: ffmpeg[7FBB6BFFF700]: [h264] error while decoding MB 70 46, bytestream 41145
22:25:41.403 T:140444557379328 WARNING: ActiveAE - large audio sync error: -89410.192246
22:25:41.403 T:140444557379328 WARNING: ActiveAE - large audio sync error: -89410.378144
22:25:42.172 T:140443027162880   ERROR: ffmpeg[7FBB70BEC700]: [h264] error while decoding MB 0 64, bytestream 22153
22:25:57.914 T:140442930763520   ERROR: ffmpeg[7FBB6AFFD700]: [h264] error while decoding MB 101 60, bytestream 1833
22:26:03.354 T:140443027162880   ERROR: ffmpeg[7FBB70BEC700]: [h264] error while decoding MB 76 54, bytestream 8811
22:26:04.516 T:140442930763520   ERROR: ffmpeg[7FBB6AFFD700]: [h264] error while decoding MB 0 56, bytestream 16652

cat 4061867cc46e/.kodi/temp/kodi.log | grep ERROR

22:25:05.239 T:140444574001344   ERROR: DBus error: org.freedesktop.DBus.Error.ServiceUnknown - The name org.freedesktop.UPower was not provided by any .service files
22:25:05.623 T:140444574001344   ERROR: failed to initialize egl display
22:25:05.767 T:140444574001344   ERROR: Window Translator: Can't find window MyMusicLibrary
22:25:05.776 T:140444574001344   ERROR: Window Translator: Can't find window MyMusicLibrary
22:25:13.680 T:140443128170240   ERROR: CPVRTimerInfoTag: no epg tag given for epg based timer type (4)!
22:25:13.684 T:140443128170240   ERROR: CPVRTimerInfoTag: no epg tag given for epg based timer type (4)!
22:25:15.416 T:140443128170240   ERROR: CPVRTimerInfoTag: no epg tag given for epg based timer type (4)!
22:25:15.703 T:140443128170240   ERROR: CPVRTimerInfoTag: no epg tag given for epg based timer type (4)!
22:25:19.377 T:140444147115776   ERROR: ## LibreELEC Addon ## oe::load_config ## ERROR: (ExpatError('no element found: line 2, column 0',))
22:25:19.377 T:140444147115776   ERROR: Traceback (most recent call last):
22:25:19.377 T:140444147115776   ERROR: ## LibreELEC Addon ## oe::read_setting ## ERROR: (AttributeError("'NoneType' object has no attribute 'getElementsByTagName'",))
22:25:19.377 T:140444147115776   ERROR: Traceback (most recent call last):
22:25:29.153 T:140443035555584   ERROR: ffmpeg[7FBB713ED700]: [h264] mmco: unref short failure
22:25:29.178 T:140443035555584   ERROR: ffmpeg[7FBB713ED700]: [h264] mmco: unref short failure
22:25:29.433 T:140444548986624   ERROR: Previous line repeats 1 times.
22:25:33.556 T:140443027162880   ERROR: ffmpeg[7FBB70BEC700]: [h264] left block unavailable for requested intra mode
22:25:33.556 T:140443027162880   ERROR: ffmpeg[7FBB70BEC700]: [h264] error while decoding MB 0 48, bytestream 117841
22:25:34.650 T:140442947548928   ERROR: ffmpeg[7FBB6BFFF700]: [h264] Reference 2 >= 2
22:25:34.650 T:140442947548928   ERROR: ffmpeg[7FBB6BFFF700]: [h264] error while decoding MB 70 46, bytestream 41145
22:25:42.172 T:140443027162880   ERROR: ffmpeg[7FBB70BEC700]: [h264] left block unavailable for requested intra mode
22:25:42.172 T:140443027162880   ERROR: ffmpeg[7FBB70BEC700]: [h264] error while decoding MB 0 64, bytestream 22153
22:25:56.662 T:140442947548928   ERROR: ffmpeg[7FBB6BFFF700]: [h264] reference picture missing during reorder
22:25:56.662 T:140442947548928   ERROR: ffmpeg[7FBB6BFFF700]: [h264] Missing reference picture, default is 66582
22:25:56.700 T:140443035555584   ERROR: ffmpeg[7FBB713ED700]: [h264] mmco: unref short failure
22:25:57.019 T:140443035555584   ERROR: ffmpeg[7FBB713ED700]: [h264] mmco: unref short failure
22:25:57.914 T:140442930763520   ERROR: ffmpeg[7FBB6AFFD700]: [h264] Reference 2 >= 2
22:25:57.914 T:140442930763520   ERROR: ffmpeg[7FBB6AFFD700]: [h264] error while decoding MB 101 60, bytestream 1833
22:25:59.221 T:140443035555584   ERROR: ffmpeg[7FBB713ED700]: [h264] mmco: unref short failure
22:26:03.061 T:140442947548928   ERROR: ffmpeg[7FBB6BFFF700]: [h264] reference picture missing during reorder
22:26:03.061 T:140442947548928   ERROR: ffmpeg[7FBB6BFFF700]: [h264] Missing reference picture, default is 66904
22:26:03.103 T:140443035555584   ERROR: ffmpeg[7FBB713ED700]: [h264] mmco: unref short failure
22:26:03.354 T:140443027162880   ERROR: ffmpeg[7FBB70BEC700]: [h264] Reference 5 >= 2
22:26:03.354 T:140443027162880   ERROR: ffmpeg[7FBB70BEC700]: [h264] error while decoding MB 76 54, bytestream 8811
22:26:03.381 T:140442930763520   ERROR: ffmpeg[7FBB6AFFD700]: [h264] reference picture missing during reorder
22:26:03.381 T:140442930763520   ERROR: ffmpeg[7FBB6AFFD700]: [h264] Missing reference picture, default is 66920
22:26:03.460 T:140443035555584   ERROR: ffmpeg[7FBB713ED700]: [h264] mmco: unref short failure
22:26:04.516 T:140442930763520   ERROR: ffmpeg[7FBB6AFFD700]: [h264] left block unavailable for requested intra4x4 mode -1
22:26:04.516 T:140442930763520   ERROR: ffmpeg[7FBB6AFFD700]: [h264] error while decoding MB 0 56, bytestream 16652
22:26:09.081 T:140442947548928   ERROR: ffmpeg[7FBB6BFFF700]: [h264] reference picture missing during reorder
22:26:09.081 T:140442947548928   ERROR: ffmpeg[7FBB6BFFF700]: [h264] Missing reference picture, default is 67196
22:26:09.121 T:140443035555584   ERROR: ffmpeg[7FBB713ED700]: [h264] mmco: unref short failure
22:26:09.361 T:140443035555584   ERROR: ffmpeg[7FBB713ED700]: [h264] mmco: unref short failure
22:26:12.961 T:140442930763520   ERROR: ffmpeg[7FBB6AFFD700]: [h264] reference picture missing during reorder
22:26:12.961 T:140442930763520   ERROR: ffmpeg[7FBB6AFFD700]: [h264] Missing reference picture, default is 67390
22:26:13.001 T:140443035555584   ERROR: ffmpeg[7FBB713ED700]: [h264] mmco: unref short failure
22:26:13.361 T:140443035555584   ERROR: ffmpeg[7FBB713ED700]: [h264] mmco: unref short failure
22:26:15.244 T:140443027162880   ERROR: ffmpeg[7FBB70BEC700]: [h264] reference picture missing during reorder
22:26:15.244 T:140443027162880   ERROR: ffmpeg[7FBB70BEC700]: [h264] Missing reference picture, default is 67502
22:26:15.281 T:140443035555584   ERROR: ffmpeg[7FBB713ED700]: [h264] mmco: unref short failure
22:26:15.600 T:140442947548928   ERROR: ffmpeg[7FBB6BFFF700]: [h264] reference picture missing during reorder
22:26:15.600 T:140442947548928   ERROR: ffmpeg[7FBB6BFFF700]: [h264] Missing reference picture, default is 67520
22:26:15.640 T:140443035555584   ERROR: ffmpeg[7FBB713ED700]: [h264] mmco: unref short failure
22:27:49.921 T:140442930763520   ERROR: ffmpeg[7FBB6AFFD700]: [h264] reference picture missing during reorder
22:27:49.921 T:140442930763520   ERROR: Previous line repeats 1 times.
22:27:49.921 T:140442930763520   ERROR: ffmpeg[7FBB6AFFD700]: [h264] Missing reference picture, default is 72238
22:27:49.961 T:140443035555584   ERROR: Previous line repeats 1 times.
22:27:49.961 T:140443035555584   ERROR: ffmpeg[7FBB713ED700]: [h264] mmco: unref short failure
22:27:50.320 T:140443035555584   ERROR: ffmpeg[7FBB713ED700]: [h264] mmco: unref short failure
22:28:21.801 T:140443027162880   ERROR: ffmpeg[7FBB70BEC700]: [h264] reference picture missing during reorder
22:28:21.801 T:140443027162880   ERROR: Previous line repeats 1 times.
22:28:21.801 T:140443027162880   ERROR: ffmpeg[7FBB70BEC700]: [h264] Missing reference picture, default is 73832
22:28:21.841 T:140443035555584   ERROR: Previous line repeats 1 times.
22:28:21.841 T:140443035555584   ERROR: ffmpeg[7FBB713ED700]: [h264] mmco: unref short failure
22:28:22.121 T:140442947548928   ERROR: ffmpeg[7FBB6BFFF700]: [h264] reference picture missing during reorder
22:28:22.121 T:140442947548928   ERROR: ffmpeg[7FBB6BFFF700]: [h264] Missing reference picture, default is 73848
22:28:22.199 T:140443035555584   ERROR: ffmpeg[7FBB713ED700]: [h264] mmco: unref short failure
22:28:46.440 T:140443035555584   ERROR: ffmpeg[7FBB713ED700]: [h264] mmco: unref short failure
22:28:53.720 T:140443035555584   ERROR: ffmpeg[7FBB713ED700]: [h264] mmco: unref short failure
22:28:53.720 T:140443035555584   ERROR: ffmpeg[7FBB713ED700]: [h264] number of reference frames (0+5) exceeds max (4; probably corrupt input), discarding one
22:28:53.800 T:140443027162880   ERROR: ffmpeg[7FBB70BEC700]: [h264] reference picture missing during reorder
22:28:53.800 T:140443027162880   ERROR: ffmpeg[7FBB70BEC700]: [h264] Missing reference picture, default is 75432
22:28:53.840 T:140443035555584   ERROR: ffmpeg[7FBB713ED700]: [h264] mmco: unref short failure
22:28:54.248 T:140444113544960   ERROR: Previous line repeats 1 times.
22:33:36.438 T:140443035555584   ERROR: ffmpeg[7FBB713ED700]: [h264] mmco: unref short failure
22:33:36.796 T:140443035555584   ERROR: ffmpeg[7FBB713ED700]: [h264] mmco: unref short failure
22:40:33.984 T:140442939156224   ERROR: Got MSGQ_ABORT or MSGO_IS_ERROR return true
22:40:34.006 T:140443043948288   ERROR: Got MSGQ_ABORT or MSGO_IS_ERROR return true (-1)



RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - _Spook_ - 2018-03-06

"VideoPlayer: OpenGL - fix HDR metadata MaxCLL" is 4K HDR now supported in these builds? I switched to ATV4K a while back so have been a bit off. But now the ATV is starting to piss me off a bit...hehe


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - TimoJ - 2018-03-06

(2018-03-06, 02:51)Milhouse Wrote: I've uploaded a debug-enabled build of #0305 with PR13533 reverted:

#0305y: Generic

Can those experiencing crashes at the end of playback test with #0305y and confirm if the crashes continue - if so, please upload the new crashlog. Thanks
 I tested with #0305y and had no crashes. Regular #0305 still crashed.


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - c--mas - 2018-03-06

(2018-01-30, 21:51)c--mas Wrote:
(2018-01-28, 22:07)Milhouse Wrote:
(2018-01-28, 17:40)c--mas Wrote: @Milhouse: No further support from your side regarding my problem?

I had intended to ping my colleague, but real life intervened (and I forgot). Have pinged him now.   
Hi :-) Just for your information. I´m also active on libreelec.tv forum to test the other Libreelec Build 8.x with dvb drivers and i found before 2 days another thread regarding dvb devices. So i wrote some posts about my device and make 2 pictures:
Hauppauge WinTV-Nova Picture 1Hauppauge WinTV-Nova Picture 2 
One of the user has also contact with the developer of the Haupauge drivers and he goes in contact with him. The device is unknown for him and he will try to fix it. I´ve just give them the hint, that i assumed my issue is already placed at him. So i think it´s the same developer. Sorry for that. I hope it´s okay and i think all of you are informed to avoid more work on it than needed :-) 
Hi, to come back to my issue after weeks. This here is the only information which i´ve received: https://github.com/b-rad-NDi/Ubuntu-media-tree-kernel-builder/issues/34#issuecomment-361656376
Are you able to integrate such a driver for this tuner?


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Nekromantik - 2018-03-06

(2018-03-06, 02:51)Milhouse Wrote: I've uploaded a debug-enabled build of #0305 with PR13533 reverted:

#0305y: Generic

Can those experiencing crashes at the end of playback test with #0305y and confirm if the crashes continue - if so, please upload the new crashlog. Thanks
 Hi
Yes I do use trakt.
I will test this tonight.
Thanks


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - AndreaSpooky - 2018-03-06

(2018-03-05, 01:38)AndreaSpooky Wrote:
(2018-03-04, 22:37)Milhouse Wrote:
(2018-03-04, 22:13)AndreaSpooky Wrote: I'm using a quite recent 8.2 build on x86
...
Have someone else this kind of problem?
Not been reported so far with these LE9.0 test builds so you may want to try it.

Testing with the latest LE 8.2.3 might also be worth a try as your "quite recent 8.2 build" covers both Kodi 17.5 and Kodi 17.6.

I was indeed on a December milhouse, and now I passed on the latest 9.0 build: issue still remains. Weird thing is UI recognise I have the subtitles file in the path, and even when I disable/re-enable/load it still doesn't render. The only way stays download it again o_O

OK, I kept trying, and this issue seems to be related to the way Kodi recognizes/catalogs the episodes or movies, and then opens the subs file in accordance to the filename (or DB name).
Example: I open an episode from the TV Shows listing, no subtitles shown, then I try opening the very same episode from the files section, the subs appears.


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Milhouse - 2018-03-06

(2018-03-06, 20:47)AndreaSpooky Wrote: OK, I kept trying, and this issue seems to be related to the way Kodi recognizes/catalogs the episodes or movies, and then opens the subs file in accordance to the filename (or DB name).
Example: I open an episode from the TV Shows listing, no subtitles shown, then I try opening the very same episode from the files section, the subs appears.

I would suggest you open a ticket on trac.kodi.tv, and provide a sample subtitle file so that this can be reproduced - just the subtitle file should be sufficient, as I'm assuming it can be used with any video file. Include details of the exact file naming conventions you are using (for both the video and subtitle files). A debug log (wiki) should also be provided.


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Nekromantik - 2018-03-06

(2018-03-06, 02:51)Milhouse Wrote: I've uploaded a debug-enabled build of #0305 with PR13533 reverted:

#0305y: Generic

Can those experiencing crashes at the end of playback test with #0305y and confirm if the crashes continue - if so, please upload the new crashlog. Thanks
 Just tested this and yes it fixed the crash!
Will this need to be raised with Kodi devs to fix?


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Milhouse - 2018-03-06

New LibreELEC.tv Leia build #0306: Generic
(Supercedes previous build)

SHA256 Checksum: a2cf479533ff4717908add9e654958b8bfd7d701974888f785d889bf5cb03183 (Generic)

# uname -a
Linux NUC 4.14.24 #1 SMP Tue Mar 6 21:19:48 GMT 2018 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse): devel-20180306211737-#0306-g6f7037f [Build #0306]

# Kodi version
(18.0-ALPHA1 Git:89a53e4). Platform: Linux x86 64-bit

Based on tip of LibreELEC.tv master (6f7037f, changelog) and tip of XBMC master (480fab5, changelog) with the following modifications: Build Highlights:
  1. VideoPlayer: VPV - drop obsolete code for ff
Build Details:
  1. LibreELEC.tv:
    • projects/Amlogic: SBC updates (PR:2507, 12 commits, 45 files changed)
    • linux: update to linux-4.14.24 (ish) (PR:2520, 14 commits, 11 files changed)
  2. XBMC:
    • VideoPlayer: VPV - drop obsolete code for ff (PR:13620, 1 commit, 1 file changed)
  3. Additional commits/pull requests/changes not yet merged upstream:
    • Rebased: [env] patch: buildsystem: add BUILD_FLAG support



RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Milhouse - 2018-03-07

(2018-03-06, 22:43)Nekromantik Wrote: Just tested this and yes it fixed the crash!
Will this need to be raised with Kodi devs to fix?
I've left a comment on PR13533, if more information/testing is required I'll let you know!