Kodi Community Forum
v18 LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Linux (https://forum.kodi.tv/forumdisplay.php?fid=52)
---- Thread: v18 LibreELEC Testbuilds for x86_64 (Kodi 18.0) (/showthread.php?tid=298462)



RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Milhouse - 2018-06-19

@Pienoet & @Nekromantik:

Can you test the following builds and let me know which, if any, make a difference (please test them all!)

#0618b: Generic - revert Intel eDP patch
#0618c: Generic - revert GLK quirk patch
#0618d: Generic - revert xf86-video-intel bump
#0618e: Generic - include PR14078


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - billbillw - 2018-06-19

OK, I thought I'd try again now that these builds are using newer kernels. I just tried the 0618 version uploaded a couple hours ago. I am still having the same issue with my NUC7i3BNH not being able to pass DTS-HD Master or TrueHD. It doesn't matter if I have it at 60p or 24p.
To refresh NUC7i3BNH (Kaby Lake) >HDMI cable >Yamaha A3010 receiver > Epson Projector. 

This receiver projector combo has worked fine for me to stream DTS HD Ma/TrueHD for many years using previous Kodi builds (Chromebox, PC, Dell/Wyse Thin Clients, etc). 

I updated the NUC HDMI firmware to 1.66 some time ago and this NUC box works fine with Windows 10 and official Windows 32 bit Kodi. It passes HD audio and does so with refresh rate switching down to 24p. 

I finally figured out how to enable logging. I played back a 1080p movie rip with both DTS-HD Master (5.1) and DTS 5.1. I switched from DTSHDMA to regular DTS after a short period with no audio playback (receiver shows Analog). This was set at fixed 60p for this log. When I switched to bitstreaming regular DTS, it started playing the audio immediately. I switched back to DTS HD Master and the audio dropped again immediately.

Here is the latest Log. 
http://ix.io/1dQ7


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - skydancer - 2018-06-19

(2018-06-19, 00:54)Milhouse Wrote:
(2018-06-18, 14:20)pyrodex Wrote: @Milhouse 

Just tried #617 and still unable to play UHD full Blu-Ray folders. 

DEBUG: https://www.dropbox.com/s/td3t01nrmy33ptq/kodi.log?dl=0
(2018-06-18, 18:14)skydancer Wrote: +1 for that, UHD folders / iso playes fine on kodi 18 windows but not on Libreelec.

Has UHD ISO playback ever worked in any of these builds, or is it just a problem since #0616/#0617 as this is the first build with Radeon APU support? My hunch is that this is the former. 
Hi, never worked in these builds


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - riccardo - 2018-06-19

(2018-06-19, 03:30)billbillw Wrote: ... I am still having the same issue with my NUC7i3BNH not being able to pass DTS-HD Master or TrueHD. It doesn't matter if I have it at 60p or 24p.
To refresh NUC7i3BNH (Kaby Lake) >HDMI cable >Yamaha A3010 receiver > Epson Projector. 
This receiver projector combo has worked fine for me to stream DTS HD Ma/TrueHD for many years using previous Kodi builds (Chromebox, PC, Dell/Wyse Thin Clients, etc). 
I updated the NUC HDMI firmware to 1.66 some time ago and this NUC box works fine with Windows 10 and official Windows 32 bit Kodi. It passes HD audio and does so with refresh rate switching down to 24p. 
...
 I have similair issues as billbillw on NUC6CAYH+Onkyo TX-SR608. Audio Passthrough works very strange. On LibreElec 8.2.x audio pass works only for non-HD audio formats, eg DD a DTS while formats like DD-EX, DTS-EX, DTS-HD MA5.1/7.1 and Dolby THD 7.1 don't work at all. On these new builds 9.x audio is passed correctly in most cases, but video is not smooth with refresh rate set to 60 Hz (or 59.97). Refresh rates 29.97 and lower give no audio at all for any audio format. I wonder if it's a prolem with NUC6CAYH generally and I need to get myself a newer NUC, but since not so many people complain about this I have a strange feeling that the problem might be somewhere else. I've upgraded HDMI firmware recently to 1.72 without any effect; also read somewhere that a new kernel 4.13+  will fix this. Some progress has been made but it's far from being usable. I still need to transer audio over optical cable and therefore downgrade all the HD audio formats.


LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Nekromantik - 2018-06-19

Wil try those tonight.
Thanks


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - pyrodex - 2018-06-19

(2018-06-19, 00:54)Milhouse Wrote:
(2018-06-18, 14:20)pyrodex Wrote: @Milhouse 

Just tried #617 and still unable to play UHD full Blu-Ray folders. 

DEBUG: https://www.dropbox.com/s/td3t01nrmy33ptq/kodi.log?dl=0
(2018-06-18, 18:14)skydancer Wrote: +1 for that, UHD folders / iso playes fine on kodi 18 windows but not on Libreelec.

Has UHD ISO playback ever worked in any of these builds, or is it just a problem since #0616/#0617 as this is the first build with Radeon APU support? My hunch is that this is the former. 
@Milhouse 

Seems a few have confirmed it may have never worked. Anything I can do to help test it out to get a fix? I can't backrev since I have a newer system to find the bad build.


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - billbillw - 2018-06-19

(2018-06-19, 11:39)riccardo Wrote:
(2018-06-19, 03:30)billbillw Wrote: ... I am still having the same issue with my NUC7i3BNH not being able to pass DTS-HD Master or TrueHD. It doesn't matter if I have it at 60p or 24p.
To refresh NUC7i3BNH (Kaby Lake) >HDMI cable >Yamaha A3010 receiver > Epson Projector. 
This receiver projector combo has worked fine for me to stream DTS HD Ma/TrueHD for many years using previous Kodi builds (Chromebox, PC, Dell/Wyse Thin Clients, etc). 
I updated the NUC HDMI firmware to 1.66 some time ago and this NUC box works fine with Windows 10 and official Windows 32 bit Kodi. It passes HD audio and does so with refresh rate switching down to 24p. 
...
 I have similair issues as billbillw on NUC6CAYH+Onkyo TX-SR608. Audio Passthrough works very strange. On LibreElec 8.2.x audio pass works only for non-HD audio formats, eg DD a DTS while formats like DD-EX, DTS-EX, DTS-HD MA5.1/7.1 and Dolby THD 7.1 don't work at all. On these new builds 9.x audio is passed correctly in most cases, but video is not smooth with refresh rate set to 60 Hz (or 59.97). Refresh rates 29.97 and lower give no audio at all for any audio format. I wonder if it's a prolem with NUC6CAYH generally and I need to get myself a newer NUC, but since not so many people complain about this I have a strange feeling that the problem might be somewhere else. I've upgraded HDMI firmware recently to 1.72 without any effect; also read somewhere that a new kernel 4.13+  will fix this. Some progress has been made but it's far from being usable. I still need to transer audio over optical cable and therefore downgrade all the HD audio formats. 
 Have you tried disabling the passthrough option and letting Kodi convert it? I think that going all the way down to optical audio is an extreme measure.

If you turn off passthrough, Kodi will convert the high resolution DTSHD/TrueHD down to PCM multichannel with little or no discernible difference. You may loose some bass management features, but the audio quality should be largely the same. At the very least, it will be superior to the lossy Dolby Digital/DTS.


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Pienoet - 2018-06-19

(2018-06-19, 02:05)Milhouse Wrote: @Pienoet & @Nekromantik:

Can you test the following builds and let me know which, if any, make a difference (please test them all!)

#0618b: Generic - revert Intel eDP patch
#0618c: Generic - revert GLK quirk patch
#0618d: Generic - revert xf86-video-intel bump
#0618e: Generic - include PR14078

I’ll try them later tonight


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Nekromantik - 2018-06-19

(2018-06-19, 02:05)Milhouse Wrote: @Pienoet & @Nekromantik:

Can you test the following builds and let me know which, if any, make a difference (please test them all!)

#0618b: Generic - revert Intel eDP patch
#0618c: Generic - revert GLK quirk patch
#0618d: Generic - revert xf86-video-intel bump
#0618e: Generic - include PR14078
 None of those work.
Here is the logs zip file from the box after upgrade https://drive.google.com/file/d/1-FURWt802Ll7PU8a0DOgGCHAgmv35lbR/view?usp=sharing

Reverted to 615


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Milhouse - 2018-06-19

(2018-06-19, 16:28)pyrodex Wrote: Seems a few have confirmed it may have never worked. Anything I can do to help test it out to get a fix? I can't backrev since I have a newer system to find the bad build.

I'm not sure what the problem is right now but if anyone wants to PR a fix that would be appreciated.


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Milhouse - 2018-06-19

(2018-06-19, 19:58)Nekromantik Wrote:  None of those work.
Here is the logs zip file from the box after upgrade https://drive.google.com/file/d/1-FURWt802Ll7PU8a0DOgGCHAgmv35lbR/view?usp=sharing

Reverted to 615

Thanks.

Could upload the zip file for #0615, and also the zipfile when booting #0618d?


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Pienoet - 2018-06-19

(2018-06-19, 02:05)Milhouse Wrote: @Pienoet & @Nekromantik:

Can you test the following builds and let me know which, if any, make a difference (please test them all!)

#0618b: Generic - revert Intel eDP patch
#0618c: Generic - revert GLK quirk patch
#0618d: Generic - revert xf86-video-intel bump
#0618e: Generic - include PR14078
 @Milhouse i tested all builds and #618c and #618e both builds crashed 1 time.
builds #618b and #618d no crashes so far but al builds where some quick tests.

crash_log #618e
crash_log #618c


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Nekromantik - 2018-06-19

(2018-06-19, 20:19)Milhouse Wrote:
(2018-06-19, 19:58)Nekromantik Wrote:  None of those work.
Here is the logs zip file from the box after upgrade https://drive.google.com/file/d/1-FURWt802Ll7PU8a0DOgGCHAgmv35lbR/view?usp=sharing

Reverted to 615

Thanks.

Could upload the zip file for #0615, and also the zipfile when booting #0618d? 
 615 logs https://drive.google.com/file/d/1TXa9YmfLQtijI_lp_e4W9jlgGxLKTd6D/view?usp=sharing
618d logs https://drive.google.com/file/d/1p70_XwU1CxgnZOlkr8FfJpw3XBfGLUMU/view?usp=sharing


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - mglae - 2018-06-19

(2018-06-19, 20:09)Milhouse Wrote:
(2018-06-19, 16:28)pyrodex Wrote: Seems a few have confirmed it may have never worked. Anything I can do to help test it out to get a fix? I can't backrev since I have a newer system to find the bad build.

I'm not sure what the problem is right now but if anyone wants to PR a fix that would be appreciated.  
Do you already include #2417?


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Milhouse - 2018-06-19

(2018-06-19, 22:27)mglae Wrote:
(2018-06-19, 20:09)Milhouse Wrote:
(2018-06-19, 16:28)pyrodex Wrote: Seems a few have confirmed it may have never worked. Anything I can do to help test it out to get a fix? I can't backrev since I have a newer system to find the bad build.

I'm not sure what the problem is right now but if anyone wants to PR a fix that would be appreciated.  
Do you already include #2417?

No not yet - we haven't be able to merge it due to stability issues on RPi, but it's on the list to get done before Kodi 18 is released. I'll see if I can push a one-off test build with it for those with UHD, and take it from there.