Kodi Community Forum
v18 LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Linux (https://forum.kodi.tv/forumdisplay.php?fid=52)
---- Thread: v18 LibreELEC Testbuilds for x86_64 (Kodi 18.0) (/showthread.php?tid=298462)



RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - fritsch - 2018-06-30

Quote:Frequency requested 733
  min hard:200, soft:200; max soft:756, hard:756
  idle:200, efficient:400, boost:756
Xorg [441]: 0 boosts
kodi.bin [489]: 4 boosts
VideoPlayer [687]: 35 boosts
Kernel (anonymous) boosts: 3840

RPS Autotuning (current "high power" window):
  Avg. up: 42% [above threshold? 90%]
  Avg. down: 0% [below threshold? 70%]

So we see here, that VP boosts the GPU, but it sadly only upclocks when it uses > 90% and downclocks right away when using < 70%.

Try to echo 400 into that file and see if it already helps. If not try with 756. i915_min_freq


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - lwrcase - 2018-06-30

(2018-06-30, 19:46)fritsch Wrote:
Quote:Frequency requested 733
  min hard:200, soft:200; max soft:756, hard:756
  idle:200, efficient:400, boost:756
Xorg [441]: 0 boosts
kodi.bin [489]: 4 boosts
VideoPlayer [687]: 35 boosts
Kernel (anonymous) boosts: 3840

RPS Autotuning (current "high power" window):
  Avg. up: 42% [above threshold? 90%]
  Avg. down: 0% [below threshold? 70%]

So we see here, that VP boosts the GPU, but it sadly only upclocks when it uses > 90% and downclocks right away when using < 70%.

Try to echo 400 into that file and see if it already helps. If not try with 756. i915_min_freq 
 kodi:~ # echo 400 > /sys/kernel/debug/dri/i915_min_freq
-sh: can't create /sys/kernel/debug/dri/i915_min_freq: Permission denied


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Aenima99x - 2018-06-30

(2018-06-30, 19:52)lwrcase Wrote:
(2018-06-30, 19:46)fritsch Wrote:
Quote:Frequency requested 733
  min hard:200, soft:200; max soft:756, hard:756
  idle:200, efficient:400, boost:756
Xorg [441]: 0 boosts
kodi.bin [489]: 4 boosts
VideoPlayer [687]: 35 boosts
Kernel (anonymous) boosts: 3840

RPS Autotuning (current "high power" window):
  Avg. up: 42% [above threshold? 90%]
  Avg. down: 0% [below threshold? 70%]

So we see here, that VP boosts the GPU, but it sadly only upclocks when it uses > 90% and downclocks right away when using < 70%.

Try to echo 400 into that file and see if it already helps. If not try with 756. i915_min_freq  
 kodi:~ # echo 400 > /sys/kernel/debug/dri/i915_min_freq
-sh: can't create /sys/kernel/debug/dri/i915_min_freq: Permission denied 
 You missed a directory in the path......
echo 400 > /sys/kernel/debug/dri/0/i915_min_freq


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - lwrcase - 2018-06-30

ah. my mistake.
setting it to 400 works! no more stutter/slowness.
will this stick after reboot?


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Aenima99x - 2018-06-30

(2018-06-30, 19:58)lwrcase Wrote: ah. my mistake.
setting it to 400 works! no more stutter/slowness.
will this stick after reboot?
 You'll need to use an autostart.sh file -  https://wiki.libreelec.tv/autostart.sh


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - fritsch - 2018-06-30

A version with a newer kernel should fix that. There are some LE testbuilds here with 4.16 or later. Could you verify that?


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - lwrcase - 2018-06-30

i'm using #0629 which should have 4.17.3, issue still exists.


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - phunkyfish - 2018-07-01

Just wanted to say that the min freq fix also worked for my Cubi N 8 GL.

Slightly out of sync on the audio but I’m sure that will get fixed in time.


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Bromor - 2018-07-01

Hello,

I am facing 2 issues on my NUC7PJYH:

1) No audio on TV
NUC7PJYH is connected to Philips 47PFL3007H/12 (somewhat old device) via HDMI. No issues with video at all, but no audio on TV through HDMI. It seems like the HDMI audio device is identified since there is a entry "PHL PHILIPS FTV on HDMI #0" in the audio output device section.
The NUC provides video + audio over the same HDMI cable when connected to a newer generation TV (Samsung). TV plays video + audio when connected to my old HTPC, so TV is not defect.
I assume this issue may be related to wrong codec or data format for audio negotiated between NUC and TV. Is there a way to force audio to a basic/native format?

2) IR remote control stops working after some inputs
I configured my Harmony 300 as MCE remote and first key press works out of the box. But after a few key presses (4-6) remote control via IR stops working. Seems like CIR in the NUC is disconnected but I do not find anything related in the logs.

Any ideas?

I am on latest BIOS and build #0629 on the NUC.
Logs: http://ix.io/1fAi


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Devil-Strike - 2018-07-01

(2018-07-01, 00:54)phunkyfish Wrote: Just wanted to say that the min freq fix also worked for my Cubi N 8 GL.

Slightly out of sync on the audio but I’m sure that will get fixed in time.
This also works on Apollo lake soc, lest few builds have some problems running hevc rips and gave some stutter, changed the gpu min freq to the max(700-Mhz) and no problems, even high bitrate uhd bluray like pacific rim2 with 108Mbit/s avg. works now flawless.


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Milhouse - 2018-07-01

(2018-06-30, 03:41)phunkyfish Wrote:  @Milhouse should I be getting a J5005 unit or would a J4005 be sufficient?

I can't in good conscience recommend buying anything from Intel right now as all recent hardware generations have potentially major problems of one kind or another (it just seems to be pot luck if you're affected or not), may not do 4K (older but more reliable generations), or won't ever do HDR (including the latest generations, even once the software side of things is fixed).

I can't recommend Nvidia either, given the uncertainty over long term Kodi support.

This leaves only AMD, either a discrete GPU or Ryzen+Vega APU, which as far as I'm aware seems to be working quite well, with few if any problems, without all the workarounds, kludges and fixes that Intel needs.

So if you're dead set on investing a significant sum of money on x86 hardware, I'd be looking at AMD.


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Milhouse - 2018-07-01

New LibreELEC.tv Leia build #0630: Generic
(Supercedes previous build)

SHA256 Checksum: ed1ce612a0783915093e7f838112e8513c68c745372580dfb5a76bca695e0f8d (Generic)

# uname -a
Linux NUC 4.17.3 #1 SMP Sat Jun 30 21:04:41 BST 2018 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse): devel-20180630210315-#0630-g3e3cc3d [Build #0630]

# Kodi version
(18.0-ALPHA3 Git:95de5f5). Platform: Linux x86 64-bit

Based on tip of LibreELEC.tv master (3e3cc3d, changelog) and tip of XBMC master (8063088, changelog) with the following modifications: Build Highlights:
  1. AESinkPULSE: Fix enumeration callback
  2. Fix ocassional playback in background
  3. VideoPlayer: fixes for discarding streams
Build Details:
  1. XBMC:
    • AESinkPULSE: Fix enumeration callback (PR:14133, 1 commit, 1 file changed)
    • Fix ocassional playback in background (PR:14130, 1 commit, 1 file changed)
    • VideoPlayer: fixes for discarding streams (PR:14127, 1 commit, 2 files changed)



RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Jezze - 2018-07-01

Is anything new about that subtitle problem?


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - HiassofT - 2018-07-01

(2018-07-01, 08:29)Bromor Wrote: 2) IR remote control stops working after some inputs
I configured my Harmony 300 as MCE remote and first key press works out of the box. But after a few key presses (4-6) remote control via IR stops working. Seems like CIR in the NUC is disconnected but I do not find anything related in the logs.
You are not alone, this seems to be a general problem with the newer NUCs. 2734278 (post)

Not exactly sure what causes this issue or if/when it will be fixed.

It's probably easiest to just buy an MCEUSB IR receiver (the HP branded ones you can find on ebay for about 10 USD work fine) and use that instead of the built-in IR receiver.

Quote:Any ideas?
Stay away from current-gen NUCs :-)

so long,

Hias


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Jezze - 2018-07-01

I just fresh installed latest build. I cant install any addon from official repo and not even install new language. My internet connection works fine. Here is logfile: https://pastebin.com/E9zn0JpZ