Kodi Community Forum
v18 LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Linux (https://forum.kodi.tv/forumdisplay.php?fid=52)
---- Thread: v18 LibreELEC Testbuilds for x86_64 (Kodi 18.0) (/showthread.php?tid=298462)



RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Milhouse - 2018-07-03

(2018-06-30, 18:19)lwrcase Wrote:
(2018-06-30, 16:45)Aenima99x Wrote:
(2018-06-30, 08:53)lwrcase Wrote: the stuttering/slowness also goes away when there are subtitles actively being displayed on the screen. if there is no dialogue (no subtitle) and just movement or music, the stuttering persists.

it seems like UI elements being displayed indeed cures the stuttering/slowness issue. can anyone else confirm?
This is exactly the same thing I experience on my NUC7CJYH. Turning on any sort of info overlay on the screen stops the "stutter". It doesn't happen all the time, but I'm going to try and grab a debug log today when it does.
Looks like there was someone else with the same issue that solved it with some config changes to DRI/Mesa - https://forum.kodi.tv/showthread.php?tid=299115&page=7
it looks like /etc/drirc is read-only on libreelec and i wasn't able to add the lines to the configuration. anyone know how to try this fix on /etc/drirc?

Can you test with build #0702b: Generic and confirm it the stutter is any better/worse/no different? Don't force i915_min_freq when testing this build.

#0702b includes a commit that reverts a change added in 4.17-rc1 which aims to avoid boosting the GPU unnecessarily but which seems to have the effect of never allowing the GPU to boost at all when being used by Kodi (tested on Skylake).


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Milhouse - 2018-07-03

New LibreELEC.tv Leia build #0702: Generic
(Supercedes previous build)

SHA256 Checksum: 6a64a41e80a38633b8464c8105df1c5ff00cc7a46dfdde1598fa95479c3cbd67 (Generic)

# uname -a
Linux NUC 4.17.3 #1 SMP Mon Jul 2 23:37:23 BST 2018 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse): devel-20180702233607-#0702-g6bd47f0 [Build #0702]

# Kodi version
(18.0-ALPHA3 Git:95de5f5). Platform: Linux x86 64-bit

Based on tip of LibreELEC.tv master (6bd47f0, changelog) and tip of XBMC master (a44e6e2, changelog) with the following modifications: Build Highlights:
  1. Fix segfault on shutdown caused by busy python addons
  2. Loadsa lang updates
Build Details:
  1. LibreELEC.tv:
    • config/functions: store package caches in build dir (PR:2809, 1 commit, 1 file changed)
    • Revert "dash: add package, configure as CONFIG_SHELL" (PR:2808, 1 commit, 4 files changed)
    • mesa: only build va tracker if using a gallium driver that uses it (PR:2801, 1 commit, 1 file changed)
    • valgrind: add patch to enable armv8 (PR:2802, 1 commit, 1 file changed)
  2. XBMC:
    • Fix segfault on shutdown caused by busy python addons (PR:14138, 1 commit, 3 files changed)
    • RetroPlayer: Fix segfault on subsequent failure (PR:14101, 1 commit, 1 file changed)
    • [lang][kodi.core] automatic syntax corrections for the en_GB language file (2656577)
    • [lang][skin.estuary] automatic syntax corrections for the en_GB language file (39f9bd5)
    • [lang][skin.estuary] updated language files from Transifex (e66ca5d)
  3. pvr.dvblink:
    • [lang] updated language files from Transifex (c66203b)
  4. pvr.dvbviewer:
    • [lang] automatic syntax corrections for the en_GB language file (4c60fc2)
    • [lang] updated language files from Transifex (89344b4)
  5. pvr.filmon:
    • [lang] updated language files from Transifex (93ae10d)
  6. pvr.hdhomerun:
    • [lang] updated language files from Transifex (ced70bd)
  7. pvr.hts:
    • [lang] automatic syntax corrections for the en_GB language file (7500796)
    • [lang] updated language files from Transifex (83451d3)
  8. pvr.iptvsimple:
    • [lang] updated language files from Transifex (c721c03)
  9. pvr.mediaportal.tvserver:
    • [lang] updated language files from Transifex (6439be6)
  10. pvr.mythtv:
    • [lang] updated language files from Transifex (3a04d2c)
    • [lang] updated language files from Transifex (c9a14a7)
    • [lang] updated language files from Transifex (6a0f2a2)
    • [lang] updated language files from Transifex (f0f7e6d)
    • bump version 5.8.1 (c4d8899)
  11. pvr.nextpvr:
    • [lang] updated language files from Transifex (6f0515b)
  12. pvr.pctv:
    • [lang] updated language files from Transifex (32d4b66)
  13. pvr.stalker:
    • [lang] updated language files from Transifex (6026419)
  14. pvr.vbox:
    • [lang] updated language files from Transifex (325774b)
  15. pvr.vuplus:
    • [lang] updated language files from Transifex (75179a3)
  16. pvr.wmc:
    • [lang] updated language files from Transifex (ec652db)
  17. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [pkg] PR:14137 (perma): addondb: avoid constraint violation



RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Milhouse - 2018-07-03

(2018-07-02, 20:54)Nekromantik Wrote: Here you go: https://paste.ubuntu.com/p/QgrCQZ7zh2/
This time pressing stop after black screen does not fix the issue I had to reboot to bring display back.

Are you absolutely certain this issue (whatever it is, as it's not clear to me from your kodi log) started with #0628?

Can you try testing with a "clean" .kodi folder (or just temporarily rename guisettings.xml) in case your settings have become corrupted somehow?


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - lwrcase - 2018-07-03

(2018-07-03, 08:03)Milhouse Wrote:
(2018-06-30, 18:19)lwrcase Wrote:
(2018-06-30, 16:45)Aenima99x Wrote: This is exactly the same thing I experience on my NUC7CJYH. Turning on any sort of info overlay on the screen stops the "stutter". It doesn't happen all the time, but I'm going to try and grab a debug log today when it does.
Looks like there was someone else with the same issue that solved it with some config changes to DRI/Mesa - https://forum.kodi.tv/showthread.php?tid=299115&page=7
it looks like /etc/drirc is read-only on libreelec and i wasn't able to add the lines to the configuration. anyone know how to try this fix on /etc/drirc? 

Can you test with build #0702b: Generic and confirm it the stutter is any better/worse/no different? Don't force i915_min_freq when testing this build.

#0702b includes a commit that reverts a change added in 4.17-rc1 which aims to avoid boosting the GPU unnecessarily but which seems to have the effect of never allowing the GPU to boost at all when being used by Kodi (tested on Skylake). 
hi milhouse. i just tested this build on one of my units and so far the stuttering/slowness seems to be virtually gone.


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Aenima99x - 2018-07-03

(2018-07-03, 18:04)lwrcase Wrote:
(2018-07-03, 08:03)Milhouse Wrote:
(2018-06-30, 18:19)lwrcase Wrote: it looks like /etc/drirc is read-only on libreelec and i wasn't able to add the lines to the configuration. anyone know how to try this fix on /etc/drirc? 

Can you test with build #0702b: Generic and confirm it the stutter is any better/worse/no different? Don't force i915_min_freq when testing this build.

#0702b includes a commit that reverts a change added in 4.17-rc1 which aims to avoid boosting the GPU unnecessarily but which seems to have the effect of never allowing the GPU to boost at all when being used by Kodi (tested on Skylake).  
hi milhouse. i just tested this build on one of my units and so far the stuttering/slowness seems to be virtually gone. 
I'll also test this build once I get home later today.


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - kalle2000 - 2018-07-03

Dear all,

not sure if this has been addressed already: my mediabox (Zotac) has a Kaby Lake GPU (HD Graphics 620 Kaby Lake GT2).
Whenever i switched on VAAPI hardware decoding, livetv is not running smoothly anymore (input dvb-c with tvheadend backend). UHD are playing fine.
When VAAPI hardware decoding is deactivated, live tv is fine, UHD playback is stuttering. I also tried to only activate certain codecs underneath VAAPI hw decoding (i.e. HEVC only) - same result.

Player process info for live tv: h264 codec

Any ideas what I can try out?


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - fritsch - 2018-07-03

(2018-07-03, 21:17)kalle2000 Wrote: Dear all,

not sure if this has been addressed already: my mediabox (Zotac) has a Kaby Lake GPU (HD Graphics 620 Kaby Lake GT2).
Whenever i switched on VAAPI hardware decoding, livetv is not running smoothly anymore (input dvb-c with tvheadend backend). UHD are playing fine.
When VAAPI hardware decoding is deactivated, live tv is fine, UHD playback is stuttering. I also tried to only activate certain codecs underneath VAAPI hw decoding (i.e. HEVC only) - same result.

Player process info for live tv: h264 codec

Any ideas what I can try out?
 Post your Debug Log. This is exactly my setup where everything is fine. Besides tvheadend - recordings work?


LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Milhouse - 2018-07-03

@kalle2000 try #0702b (see my previous post).


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - kalle2000 - 2018-07-03

@Milhouse 
@fritsch 

Thanks for your kind support.
I installed 0702b as outlined previously.
Only HEVC hardware decoding is activated
I did run "echo 300 > /sys/kernel/debug/dri/0/i915_min_freq" in the current session (no reboot)

pastebinit
LiveTV is not running smoothly. Every few seconds some very, very short "breaks"/"cuts"

Hopefully this is somehow included in the debug log.

Do you need another kodi log without HEVC activated?


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - fritsch - 2018-07-03

Are recordings working?


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - kalle2000 - 2018-07-03

(2018-07-03, 21:59)fritsch Wrote: Are recordings working?
 I  dont record TV via kodi. If this is important to resolve this issue, i have to set it up first.


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - fritsch - 2018-07-03

And please disable plex entirely. It spams the whole log with connect requests every few seconds.


LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Milhouse - 2018-07-03

Something is wrong with Plex.


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Jezze - 2018-07-03

14136 (PR)

Is that gonna fix earlier subtitle problem?


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - fritsch - 2018-07-03

(2018-07-03, 22:24)Jezze Wrote: 14136 (PR)

Is that gonna fix earlier subtitle problem?
 it's not even marginally related ...