Kodi Community Forum
v18 LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Linux (https://forum.kodi.tv/forumdisplay.php?fid=52)
---- Thread: v18 LibreELEC Testbuilds for x86_64 (Kodi 18.0) (/showthread.php?tid=298462)



RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - lwrcase - 2018-08-22

just updated to #0821 and it has video stuttering issues again. i tried to apply the i915_min_freq fix but it gave me a permission denied error.


Livingroom:~ # echo 756 > /sys/kernel/debug/dri/0/i915_min_freq
-sh: can't create /sys/kernel/debug/dri/0/i915_min_freq: Permission denied



RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Nekromantik - 2018-08-22

Just updated to #0820 and it tried to upgrade the SQL database and failed.
Log is here https://paste.ubuntu.com/p/NT2qcPT2rK/


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Milhouse - 2018-08-22

(2018-08-22, 19:55)Nekromantik Wrote: Just updated to #0820 and it tried to upgrade the SQL database and failed.
Log is here https://paste.ubuntu.com/p/NT2qcPT2rK/

Too late - we need to see the migration.

Enable debug logging, drop MyVideos112 and reboot - then upload your debug log.


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Milhouse - 2018-08-22

(2018-08-22, 19:55)Nekromantik Wrote: Just updated to #0820 and it tried to upgrade the SQL database and failed.
Log is here https://paste.ubuntu.com/p/NT2qcPT2rK/

From what version? Can you identify when the stuttering starts? This was fixed a while ago.


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Nekromantik - 2018-08-22

(2018-08-22, 21:50)Milhouse Wrote:
(2018-08-22, 19:55)Nekromantik Wrote: Just updated to #0820 and it tried to upgrade the SQL database and failed.
Log is here https://paste.ubuntu.com/p/NT2qcPT2rK/

Too late - we need to see the migration.

Enable debug logging, drop MyVideos112 and reboot - then upload your debug log. 
Debug log after dropping table and rebooting
https://paste.ubuntu.com/p/2yPY9tTXvP/


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Milhouse - 2018-08-22

(2018-08-22, 23:05)Nekromantik Wrote:
(2018-08-22, 21:50)Milhouse Wrote:
(2018-08-22, 19:55)Nekromantik Wrote: Just updated to #0820 and it tried to upgrade the SQL database and failed.
Log is here https://paste.ubuntu.com/p/NT2qcPT2rK/

Too late - we need to see the migration.

Enable debug logging, drop MyVideos112 and reboot - then upload your debug log. 
Debug log after dropping table and rebooting
https://paste.ubuntu.com/p/2yPY9tTXvP/


22:01:21.313 T:140274495907584 INFO: CreateAnalytics - creating triggers
22:01:21.313 T:140274495907584 DEBUG: Mysql execute: CREATE TRIGGER delete_movie AFTER DELETE ON movie FOR EACH ROW BEGIN DELETE FROM genre_link WHERE media_id=old.idMovie AND media_type='movie'; DELETE FROM actor_link WHERE media_id=old.idMovie AND media_type='movie'; DELETE FROM director_link WHERE media_id=old.idMovie AND media_type='movie'; DELETE FROM studio_link WHERE media_id=old.idMovie AND media_type='movie'; DELETE FROM country_link WHERE media_id=old.idMovie AND media_type='movie'; DELETE FROM writer_link WHERE media_id=old.idMovie AND media_type='movie'; DELETE FROM movielinktvshow WHERE idMovie=old.idMovie; DELETE FROM art WHERE media_id=old.idMovie AND media_type='movie'; DELETE FROM tag_link WHERE media_id=old.idMovie AND media_type='movie'; DELETE FROM rating WHERE media_id=old.idMovie AND media_type='movie'; DELETE FROM uniqueid WHERE media_id=old.idMovie AND media_type='movie'; END
22:01:21.319 T:140274495907584 ERROR: SQL: [MyVideos112] Undefined MySQL error: Code (1419)
Query: CREATE TRIGGER delete_movie AFTER DELETE ON movie FOR EACH ROW BEGIN DELETE FROM genre_link WHERE media_id=old.idMovie AND media_type='movie'; DELETE FROM actor_link WHERE media_id=old.idMovie AND media_type='movie'; DELETE FROM director_link WHERE media_id=old.idMovie AND media_type='movie'; DELETE FROM studio_link WHERE media_id=old.idMovie AND media_type='movie'; DELETE FROM country_link WHERE media_id=old.idMovie AND media_type='movie'; DELETE FROM writer_link WHERE media_id=old.idMovie AND media_type='movie'; DELETE FROM movielinktvshow WHERE idMovie=old.idMovie; DELETE FROM art WHERE media_id=old.idMovie AND media_type='movie'; DELETE FROM tag_link WHERE media_id=old.idMovie AND media_type='movie'; DELETE FROM rating WHERE media_id=old.idMovie AND media_type='movie'; DELETE FROM uniqueid WHERE media_id=old.idMovie AND media_type='movie'; END
22:01:21.336 T:140274495907584 ERROR: Exception updating database MyVideos112 from version 110 to 112
22:01:21.336 T:140274495907584 ERROR: Error updating database MyVideos112 from version 110 to 112
22:01:21.340 T:140274495907584 DEBUG: Mysql rollback transaction

Error 1419 seems to be a permission problem in the database.

I would suggest leaving debugging enabled, then booting into #0819 as this will try to migrate your MyVideos110 database to MyVideos111 - if that also has the problem then we can rule out the change in #0820 and most likely this is a general issue with your database configuration (inability to create triggers) which you'll need to fix.


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - lwrcase - 2018-08-22

(2018-08-22, 21:51)Milhouse Wrote:
(2018-08-22, 19:55)Nekromantik Wrote: Just updated to #0820 and it tried to upgrade the SQL database and failed.
Log is here https://paste.ubuntu.com/p/NT2qcPT2rK/

From what version? Can you identify when the stuttering starts? This was fixed a while ago.

i upgraded from #0816.


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Milhouse - 2018-08-22

(2018-08-22, 23:19)lwrcase Wrote:
(2018-08-22, 21:51)Milhouse Wrote:
(2018-08-22, 19:55)Nekromantik Wrote: Just updated to #0820 and it tried to upgrade the SQL database and failed.
Log is here https://paste.ubuntu.com/p/NT2qcPT2rK/

From what version? Can you identify when the stuttering starts? This was fixed a while ago.

i upgraded from #0816.

Can you confirm the build when the stuttering starts - is it #0817, #0818, #0819 etc.?

The fix for the GUI stutter that was added in 4.17.y is still present in these 4.18.y builds:

https://github.com/LibreELEC/LibreELEC.tv/blob/master/packages/linux/patches/default/linux-999-drm_i915-interactive-rps-mode.patch


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Nekromantik - 2018-08-22

(2018-08-22, 23:16)Milhouse Wrote:
(2018-08-22, 23:05)Nekromantik Wrote:
(2018-08-22, 21:50)Milhouse Wrote: Too late - we need to see the migration.

Enable debug logging, drop MyVideos112 and reboot - then upload your debug log. 
Debug log after dropping table and rebooting
https://paste.ubuntu.com/p/2yPY9tTXvP/  

22:01:21.313 T:140274495907584 INFO: CreateAnalytics - creating triggers
22:01:21.313 T:140274495907584 DEBUG: Mysql execute: CREATE TRIGGER delete_movie AFTER DELETE ON movie FOR EACH ROW BEGIN DELETE FROM genre_link WHERE media_id=old.idMovie AND media_type='movie'; DELETE FROM actor_link WHERE media_id=old.idMovie AND media_type='movie'; DELETE FROM director_link WHERE media_id=old.idMovie AND media_type='movie'; DELETE FROM studio_link WHERE media_id=old.idMovie AND media_type='movie'; DELETE FROM country_link WHERE media_id=old.idMovie AND media_type='movie'; DELETE FROM writer_link WHERE media_id=old.idMovie AND media_type='movie'; DELETE FROM movielinktvshow WHERE idMovie=old.idMovie; DELETE FROM art WHERE media_id=old.idMovie AND media_type='movie'; DELETE FROM tag_link WHERE media_id=old.idMovie AND media_type='movie'; DELETE FROM rating WHERE media_id=old.idMovie AND media_type='movie'; DELETE FROM uniqueid WHERE media_id=old.idMovie AND media_type='movie'; END
22:01:21.319 T:140274495907584 ERROR: SQL: [MyVideos112] Undefined MySQL error: Code (1419)
Query: CREATE TRIGGER delete_movie AFTER DELETE ON movie FOR EACH ROW BEGIN DELETE FROM genre_link WHERE media_id=old.idMovie AND media_type='movie'; DELETE FROM actor_link WHERE media_id=old.idMovie AND media_type='movie'; DELETE FROM director_link WHERE media_id=old.idMovie AND media_type='movie'; DELETE FROM studio_link WHERE media_id=old.idMovie AND media_type='movie'; DELETE FROM country_link WHERE media_id=old.idMovie AND media_type='movie'; DELETE FROM writer_link WHERE media_id=old.idMovie AND media_type='movie'; DELETE FROM movielinktvshow WHERE idMovie=old.idMovie; DELETE FROM art WHERE media_id=old.idMovie AND media_type='movie'; DELETE FROM tag_link WHERE media_id=old.idMovie AND media_type='movie'; DELETE FROM rating WHERE media_id=old.idMovie AND media_type='movie'; DELETE FROM uniqueid WHERE media_id=old.idMovie AND media_type='movie'; END
22:01:21.336 T:140274495907584 ERROR: Exception updating database MyVideos112 from version 110 to 112
22:01:21.336 T:140274495907584 ERROR: Error updating database MyVideos112 from version 110 to 112
22:01:21.340 T:140274495907584 DEBUG: Mysql rollback transaction

Error 1419 seems to be a permission problem in the database.

I would suggest leaving debugging enabled, then booting into #0819 as this will try to migrate your MyVideos110 database to MyVideos111 - if that also has the problem then we can rule out the change in #0820 and most likely this is a general issue with your database configuration (inability to create triggers) which you'll need to fix.  
That was it.
Had to grant user Super permissions which is annoying.
Thanks


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - lwrcase - 2018-08-23

(2018-08-22, 23:31)Milhouse Wrote:
(2018-08-22, 23:19)lwrcase Wrote:
(2018-08-22, 21:51)Milhouse Wrote: From what version? Can you identify when the stuttering starts? This was fixed a while ago.

i upgraded from #0816. 

Can you confirm the build when the stuttering starts - is it #0817, #0818, #0819 etc.?

The fix for the GUI stutter that was added in 4.17.y is still present in these 4.18.y builds:

https://github.com/LibreELEC/LibreELEC.tv/blob/master/packages/linux/patches/default/linux-999-drm_i915-interactive-rps-mode.patch 
getting some weird results here. clean installed 0817, 0818, 0819, 0820 and all have the stutter issue. clean installed 0816 and it has the stutter issue (before was sequential upgrades from an already installed version).

i'm working on clean installing 0815 and back but this will take some time. odd how it just popped up out of nowhere considering 4.17.y being present all the way back to the middle of July. will post results again once i'm done testing back.


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Milhouse - 2018-08-23

New LibreELEC.tv Leia build #0822: Generic
(Supercedes previous build)

SHA256 Checksum: 41bdd2b5d97f12aba71dec3c2371329833199974e93141bc372ea09a97a7d99b (Generic)

# uname -a
Linux NUC 4.18.4 #1 SMP Wed Aug 22 22:57:12 BST 2018 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse): devel-20180822225356-#0822-gb56a1af [Build #0822]

# Kodi version
(18.0-BETA1 Git:1cbdec1a78a35985d8959a3f43dbb3c5b0db6f7f). Platform: Linux x86 64-bit

Based on tip of LibreELEC.tv master (b56a1af, changelog) and tip of XBMC master (1cbdec1, changelog) with the following modifications: Build Highlights:
  1. New 4.18.4 kernel
  2. bump libfmt to 5.1.0
Build Details:
  1. LibreELEC.tv:
    • Rockchip: update linux and some packages (PR:2646, 9 commits, 56 files changed)
    • LibreELEC-settings: update to LibreELEC-settings-5a4bde7 (PR:2910, 1 commit, 1 file changed)
  2. XBMC:
    • [depends] Fix standalone build of flatbuffers with GCC 8.1 (PR:14334, 1 commit, 1 file changed)
    • Include cleanup (PR:14336, 4 commits, 4 files changed)
    • [depends] bump libfmt to 5.1.0 (PR:14328, 1 commit, 1 file changed)
    • kodi-send: restore -a support broken by #13804 (PR:14335, 1 commit, 1 file changed)
  3. vfs.libarchive:
    • [depends] update lz4 & xz (PR:23, 3 commits, 7 files changed)
    • fixed: do not incorporate the file name in the regular expression (430a8e0)
  4. vfs.sftp:
    • [depends] libssh: fix iOS/OSX compile error (PR:16, 2 commits, 3 files changed)
    • [depends] openssl: build static (PR:17, 1 commit, 1 file changed)
  5. Additional commits/pull requests/changes not yet merged upstream:
    • Updated: [env] patch: Add experimental splash video for RPi
    • Updated: [env] PR:2872 (perma): update dvb addons
    • Updated: [env] PR:2908 (perma): linux (Generic): update to linux-4.18.4
    • Added: [env] PR:2907 (perma): config/functions: clean up recursion test
    • Added: [env] PR:2909 (perma): kodi: next (Sept || kodi bump)
    • Added: [env] PR:2913 (perma): linux (RPi): update to linux-4.18.4



RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - lwrcase - 2018-08-23

(2018-08-22, 23:31)Milhouse Wrote:
(2018-08-22, 23:19)lwrcase Wrote:
(2018-08-22, 21:51)Milhouse Wrote: From what version? Can you identify when the stuttering starts? This was fixed a while ago.

i upgraded from #0816. 

Can you confirm the build when the stuttering starts - is it #0817, #0818, #0819 etc.?

The fix for the GUI stutter that was added in 4.17.y is still present in these 4.18.y builds:

https://github.com/LibreELEC/LibreELEC.tv/blob/master/packages/linux/patches/default/linux-999-drm_i915-interactive-rps-mode.patch 
i've tested clean installs of #0815 back to #0711 and the stutter/jitter issue exists in every version i've tested to some degree. the earlier versions are a little less severe than the latter. i've also retested #0708b and found that the issue still exists intermittently. not sure if this has anything to do with BIOS update 066 which i did perform recently.


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Milhouse - 2018-08-23

(2018-08-23, 04:27)lwrcase Wrote:
(2018-08-22, 23:31)Milhouse Wrote:
(2018-08-22, 23:19)lwrcase Wrote: i upgraded from #0816. 

Can you confirm the build when the stuttering starts - is it #0817, #0818, #0819 etc.?

The fix for the GUI stutter that was added in 4.17.y is still present in these 4.18.y builds:

https://github.com/LibreELEC/LibreELEC.tv/blob/master/packages/linux/patches/default/linux-999-drm_i915-interactive-rps-mode.patch 
i've tested clean installs of #0815 back to #0711 and the stutter/jitter issue exists in every version i've tested to some degree. the earlier versions are a little less severe than the latter. i've also retested #0708b and found that the issue still exists intermittently. not sure if this has anything to do with BIOS update 066 which i did perform recently.
Hard to say. We tested the original stutter issues and everyone seemed happy that the problem had been solved - it would add more weight if those same users now said the problem had returned. If it's only your system that has a stutter problem, and you recently changed the BIOS, then it may be more than a coincidence - can you revert back to your old BIOS, and/or clear the CMOS and reconfigure?


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - lwrcase - 2018-08-23

(2018-08-23, 04:38)Milhouse Wrote:
(2018-08-23, 04:27)lwrcase Wrote:
(2018-08-22, 23:31)Milhouse Wrote: Can you confirm the build when the stuttering starts - is it #0817, #0818, #0819 etc.?

The fix for the GUI stutter that was added in 4.17.y is still present in these 4.18.y builds:

https://github.com/LibreELEC/LibreELEC.tv/blob/master/packages/linux/patches/default/linux-999-drm_i915-interactive-rps-mode.patch 
i've tested clean installs of #0815 back to #0711 and the stutter/jitter issue exists in every version i've tested to some degree. the earlier versions are a little less severe than the latter. i've also retested #0708b and found that the issue still exists intermittently. not sure if this has anything to do with BIOS update 066 which i did perform recently. 
Hard to say. We tested the original stutter issues and everyone seemed happy that the problem had been solved - it would add more weight if those same users now said the problem had returned. If it's only your system that has a stutter problem, and you recently changed the BIOS, then it may be more than a coincidence - can you revert back to your old BIOS, and/or clear the CMOS and reconfigure? 
just tried it. still has an issue with both #0821, #0711 and #0708b.

log: http://ix.io/1kZF

also ran the output of cat /sys/kernel/debug/dri/0/* :
http://ix.io/1kZH


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - porkchop999 - 2018-08-23

Out of interest do you have sync playback to display on?