Kodi Community Forum
v18 LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Linux (https://forum.kodi.tv/forumdisplay.php?fid=52)
---- Thread: v18 LibreELEC Testbuilds for x86_64 (Kodi 18.0) (/showthread.php?tid=298462)



RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Milhouse - 2018-10-28

(2018-10-28, 12:19)fritsch Wrote: Yes - we could just exit gracefully to desktop.
Not sure how that might work in LibreELEC (as we restart Kodi if it fails to start). Could probably implement something, assuming Kodi doesn't crash on exit (which it typically does these days, even on shutdown/restart ie. "graceful" exit).


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Milhouse - 2018-10-28

(2018-10-28, 10:09)winux Wrote: All builds #1021 to present end up having a black screen but are updating fine.

Can you boot into #1026 then run:


echo KODI_GL_INTERFACE=GLX >>/run/libreelec/kodi.conf
systemctl restart kodi
and confirm if Kodi is now starting with visible GUI? Please upload your kodi.log after restarting kodi. Also run journalctl -a | pastebinit and post the link.

If you reboot the GLX setting will be lost, so you'll need to add it to /storage/.config/autostart.sh


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - winux - 2018-10-28

(2018-10-28, 16:43)Milhouse Wrote:
(2018-10-28, 10:09)winux Wrote: All builds #1021 to present end up having a black screen but are updating fine.

Can you boot into #1026 then run:


echo KODI_GL_INTERFACE=GLX >/run/libreelec/debug/kodi.conf
systemctl restart kodi
and confirm if Kodi is now starting with visible GUI? Please upload your kodi.log after restarting kodi. Also run journalctl -a | pastebinit and post the link.

If you reboot the GLX setting will be lost, so you'll need to add it to /storage/.config/autostart.sh 

will test/do that as soon as i'm back home. but it will take a couple of hours. thx for your help guys!
 
Quote:@fritsch 
We don't support

01:33:48.301 T:140039425247360 NOTICE: GL_RENDERER = Mesa DRI Intel® 945G
01:33:48.301 T:140039425247360 NOTICE: GL_VERSION = 1.4 Mesa 18.2.3
01:33:48.301 T:140039425247360 NOTICE: GL_SHADING_LANGUAGE_VERSION = 1.20
You are on your own. 2.1 is our suggested bare minimum and 4.x is suggested!
i know that, but my oldish hardware still works fine. it's like a déjà vu bug that happens every october, just in a different disguise Big Grin
we went through all this ova here: 2747682 (post)
at the end it still worked with GL_VERSION = 1.4 till last week. it can't do 4k and such but it's still fine to watch 720p youtube streams + it ran kodi/xbmc for more than a decade if i remember right =)


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - HeresJohnny - 2018-10-28

Keeping old hardware is no shame. But it then begs the question why you don't keep the old software that matches the old hardware.


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - fritsch - 2018-10-28

OpenGL lower than 2.0 was not supported anymore more than a year ago, it worked by chance.

If you want the GL 1.4 path working and supported to match your free choice, namely to keep 14 year old hardware, contribute and FIX that path and maintain it. Btw. the change from last week misses a fallback ... but this does not mean at all that we support GL 1.4 even when it starts working again after that.

Also see kodi's wiki for that.


ERROR: Failed to open savestate file - SuperSheep81 - 2018-10-28

Hello,

When having the Milhouse build running, Kodi hangs when a game is started. In the logfile there is a error about a savestate file that isn't there. Couldn't find info on the forum though. So,

Here is the log file: owusahojuc.kodi (paste)

Hope someone can give some support on this.


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - whocarez1 - 2018-10-28

(2018-10-27, 22:20)Milhouse Wrote:
(2018-10-27, 21:22)whocarez1 Wrote: I experience a lot of slowness when browsing and starting playback from SMB-shares, from release #1023 and onwards. Just opening a share can take up to a minute and videos just buffer for 90 seconds or so and are unplayable. I think this release was the first one with kernel 4.19? I think this kernel has som major changes for CIFS, but I am really unsure if that is the problem. I have tested playback from both Samba 4.5.12 on Debian 9.3 and from Windows 7 shares, with the same results. Anoyone having similar issues?
smb:// or OS mounted shares?

debug log (wiki)?  

Just tried #1027 with the same results. Here is a debug log: https://www.dropbox.com/s/nlm8d7ggk0ltt4h/01_KODI_1027.log?dl=0 Oh yeah, those are smb:// shares. Tried to remove all of them just in case, and added back again.


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - winux - 2018-10-29

(2018-10-28, 16:43)Milhouse Wrote:
(2018-10-28, 10:09)winux Wrote: All builds #1021 to present end up having a black screen but are updating fine.

Can you boot into #1026 then run:


echo KODI_GL_INTERFACE=GLX >>/run/libreelec/kodi.conf
systemctl restart kodi
and confirm if Kodi is now starting with visible GUI? Please upload your kodi.log after restarting kodi. Also run journalctl -a | pastebinit and post the link.

If you reboot the GLX setting will be lost, so you'll need to add it to /storage/.config/autostart.sh 
 ok i just tried it. no success though. kodi still starts with a black screen, so no ui visible.
funny thing is everytime i trigger "systemctl restart kodi" the entry KODI_GL_INTERFACE=GLX gets removed from /run/libreelec/kodi.conf dunno if thats supposed to be like that.
here is the kodi.log:
https://del.dog/kodi281018_log
and the pastebin:
http://ix.io/1qki

p.s. i also tried adding it to /storage/.config/autostart.sh  (the file didn't exist so i created it, made no difference though.

@HeresJohnny  fair question. well i'm doing that. my xbox1 is still running xbmc and it's fine.  but nowadays it's more like a xbox music center, since it can't play modern content anymore.
same goes with krypton. i totally would stay on krypton but i cannot even watch youtube on it anymore. since youtube needs dash and inputstream.adaptive for most vids.
also modern stream services like netflix also don't work on the older versions anymore. but i can stay on #1019 for now. works fine..

@fritsch hehe, thx for you help man. i like your humor and i totally understand that it makes no sense to keep my ancient hardware compatible. i promise i will buy new hardware soon but i can't afford it at the moment. i will wait for hdmi 2.1 devices, whats your opinion on these https://androidtvbox.eu/functional-comparison-of-amlogic-s905x-s905y2-and-s905x2/ 
S905X2 devices?  is < 2ghz enough for a supersmooth ui?


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Milhouse - 2018-10-29

(2018-10-28, 23:41)whocarez1 Wrote: Just tried #1027 with the same results. Here is a debug log: https://www.dropbox.com/s/nlm8d7ggk0ltt4h/01_KODI_1027.log?dl=0 Oh yeah, those are smb:// shares. Tried to remove all of them just in case, and added back again.

smb:// uses the Samba library so shouldn't be significantly affected by the kernel, and certainly not any kernel CIFS changes.

You can try bisecting the 4.19-rc releases: https://github.com/LibreELEC/LibreELEC.tv/pull/2937

There were eight 4.19-rc releases, so try 4.19-rc1 and see if that has the same smb:// issue - if not, continue with 4.19-rc2 etc. The only difference between the rc releases and the matching 4.18.y build is the kernel (plus some updated Realtek drivers). If none of the rc releases have the smb:// performance issue then we can probably rule out the kernel, although I don't see anything else in #1023 which might be responsible for smb:// performance issues.

Are you using wired or wifi? If it's Wifi, are you sure it's not a new neighbour etc. knackering your Wifi performance? Measure your Wifi performance. Are you using a Realtek driver, if so maybe the changes for 4.19 need some tweaking.

I use these builds on i5 Skylake NUC with 5GHz wifi and Revo 3700 with wired 1GBps Ethernet, and I've tested smb:// to Windows 7 (SMB3) and I'm not seeing any performance degradation since #1023.


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Milhouse - 2018-10-29

(2018-10-29, 00:05)winux Wrote: funny thing is everytime i trigger "systemctl restart kodi" the entry KODI_GL_INTERFACE=GLX gets removed from /run/libreelec/kodi.conf dunno if thats supposed to be like that.

Crap! Sorry, my bad.

The instructions should have been:
echo KODI_GL_INTERFACE=GLX >/run/libreelec/debug/kodi.conf
systemctl restart kodi

I gave you the wrong file name - it should have been the debug/kodi.conf file. Can you quickly try that again?


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Milhouse - 2018-10-29

New LibreELEC.tv Leia build #1028: Generic
(Supercedes previous build)

SHA256 Checksum: e844fc74b90015b70d8e8588544be134b6e6c9b6e9b7b08bbb57ad5f06bcb56d (Generic)

# uname -a
Linux NUC 4.19.0 #1 SMP Sun Oct 28 21:04:28 GMT 2018 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse): devel-20181028210242-#1028-g01f20a4 [Build #1028]

# Kodi version
(18.0-BETA5 Git:f237c7e). Platform: Linux x86 64-bit

Based on tip of LibreELEC.tv master (01f20a4, changelog) and tip of XBMC master (f237c7e, changelog) with the following modifications: Build Highlights:
  1. Resolution: Use v17 behaviour if whitelist is not present
  2. [PVR][Estuary] Add GUI for Radio Data System (RDS).
  3. kodi: fix egl fallback after PR14612 (kodi)
Build Details:
  1. LibreELEC.tv:
    • Update libdrm, xf86-video-amdgpu and xf86-video-ati (PR:3050, 3 commits, 5 files changed)
    • xf86-video-nvidia: update to xf86-video-nvidia-410.73 (PR:3060, 1 commit, 1 file changed)
    • xorg-server: update to xorg-server-1.20.3 (PR:3061, 1 commit, 1 file changed)
    • kodi: more easily support user configuration (PR:3066, 1 commit, 1 file changed)
  2. XBMC:
    • changed: modernize mime type map initialization (PR:14685, 2 commits, 2 files changed)
    • Allow number (PR:14621, 1 commit, 1 file changed)
    • [Subtitles] Avoid using res and overscan (use rectview instead) (PR:14371, 1 commit, 5 files changed)
    • [osx/windowing] - removed "true fullscreen" mode as it is not supported on macOS. (PR:14729, 1 commit, 1 file changed)
    • [Settings] Update videoscreen.screen setting when toggling fullscreen (PR:14727, 1 commit, 1 file changed)
    • [video library] Use one of the original item url to get url options (PR:14124, 1 commit, 1 file changed)
    • Update Cpack Deb packaging names. (PR:14483, 3 commits, 3 files changed)
    • [Docs] Cleanup removed methods and style fixes (PR:14724, 1 commit, 6 files changed)
    • Resolution: Use v17 behaviour if whitelist is not present (PR:14701, 2 commits, 3 files changed)
    • Addons: Don't consider broken add-ons installable (PR:14702, 2 commits, 7 files changed)
    • [PVR][Estuary] Add GUI for Radio Data System (RDS). (PR:14731, 1 commit, 11 files changed)
  3. inputstream.adaptive:
    • [DASH] sync segments with range_end on full update (ad00d56)
    • Version bump 2.3.4 (365bec1)
  4. pvr.mediaportal.tvserver:
    • Update addon to v3.5.10 to fix Android build (0e0c137)
  5. Additional commits/pull requests/changes not yet merged upstream:
    • Updated: [env] PR:2954 (perma): linux (Generic/RPi): update to linux-4.19
    • Added: [pkg] patch: kodi: fix egl fallback after PR14612 (kodi)



RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Milhouse - 2018-10-29

(2018-10-29, 00:05)winux Wrote: funny thing is everytime i trigger "systemctl restart kodi" the entry KODI_GL_INTERFACE=GLX gets removed from /run/libreelec/kodi.conf dunno if thats supposed to be like that.

Also, once you've confirmed that the KODI_GL_INTERFACE=GLX workaround is working with #1026 (or #1027, I'm losing track of time...), you can try #1028 which implements the egl fallback (dropped in #1021) which should make the KODI_GL_INTERFACE=GLX workaround unnecessary (so undo any changes you've made).

Can you test #1028 without KODI_GL_INTERFACE=GLX and confirm if that is now working, thanks! Assuming the outcome is positive the change will be pushed to Kodi, however your 14-year old GPU is a dead man walking and is unlikely to continue working with Kodi 19... maybe time for an upgrade to a Raspberry Pi? Smile


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - winux - 2018-10-29

(2018-10-29, 00:13)Milhouse Wrote:
(2018-10-29, 00:05)winux Wrote: funny thing is everytime i trigger "systemctl restart kodi" the entry KODI_GL_INTERFACE=GLX gets removed from /run/libreelec/kodi.conf dunno if thats supposed to be like that.

Crap! Sorry, my bad.

The instructions should have been:
echo KODI_GL_INTERFACE=GLX >/run/libreelec/debug/kodi.conf
systemctl restart kodi

I gave you the wrong file name - it should have been the debug/kodi.conf file. Can you quickly try that again?   
 
No worries. You are the man! i got picture =) Is it christmas yet? I totally wanna give you a cookie Big Grin

Image

Image

kodi.log:
https://del.dog/kodi291018_log
pastebin:
http://ix.io/1qkB

autostart.sh also works now =)


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Milhouse - 2018-10-29

(2018-10-29, 00:47)winux Wrote: autostart.sh also works now =)

Great! Now remove the KODI_GL_INTERFACE=GLX workaround and boot #1028 - it should work right out of the box.


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - winux - 2018-10-29

(2018-10-29, 00:50)Milhouse Wrote:
(2018-10-29, 00:47)winux Wrote: autostart.sh also works now =)

Great! Now remove the KODI_GL_INTERFACE=GLX workaround and boot #1028 - it should work right out of the box. 
 
Quote:Can you test #1028 without
KODI_GL_INTERFACE=GLX
and confirm if that is now working, thanks! Assuming the outcome is positive the change will be pushed to Kodi, however your 14-year old GPU is a dead man walking and is unlikely to continue working with Kodi 19... maybe time for an upgrade to a Raspberry Pi?

I removed the autostart.sh and updated to #1028. i saw the libreelec boot screen and after that as soon as it booted into the ui it went black again. so no it's not working out of the box with #1028.
I added the autostart.sh again, rebooted, got picture and it's working fine.

Last time i tried kodi on a pi was more than a year ago and i didn't like the video quality on it. maybe things changed but the 720p video quality on that 14 year old machine still looked way better than the same video on the pi. I also think that at least 2,4ghz is needed to get a buttersmooth ui in kodi. it was really slow and laggy on the pi back then when i tried.  maybe things changed but i guess i will wait for hdmi 2.1 devices.
what do you guys think about these new s905x2 socs, the specs look nice except the clock speed < 2ghz.?