Kodi Community Forum
v18 LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Linux (https://forum.kodi.tv/forumdisplay.php?fid=52)
---- Thread: v18 LibreELEC Testbuilds for x86_64 (Kodi 18.0) (/showthread.php?tid=298462)



RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Milhouse - 2018-11-20

(2018-11-20, 00:57)whocarez1 Wrote: Interesting. On my system editing /flash/syslinux.cfg had no effect Smile But then again, I have not reinstalled Libreelec completely for many months, I just use the update function for the time being.

Right - because you have both /flash/EFI/BOOT/syslinux.cfg and /flash/syslinux.cfg. SYSLINUX will use the former by default, but is happy to use the latter when the former does not exist.

Since having two SYSLINUX boot configs is confusing, new installs (since 8.90.003/May 2018) will only install /flash/syslinux.cfg - I had thought we had applied this change for existing installs but obviously not.

To conform with the new "single config" approach, what you can do is move your /flash/EFI/BOOT/syslinux.cfg to /flash/syslinux.cfg (or just delete /flash/EFI/BOOT/syslinux.cfg if it's not been modified).


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Milhouse - 2018-11-20

New LibreELEC.tv Leia build #1119: Generic
(Supercedes previous build)

SHA256 Checksum: 4347878ecd5a8537fbb99a7f5cb6d2ec15f4f0202b23778d368348adc9842c6f (Generic)

# uname -a
Linux NUC 4.19.2 #1 SMP Mon Nov 19 21:04:46 GMT 2018 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse): devel-20181119210238-#1119-gd35701a [Build #1119]

# Kodi version
(18.0-RC1 Git:0509481). Platform: Linux x86 64-bit

Based on tip of LibreELEC.tv master (d35701a, changelog) and tip of XBMC master (0509481, changelog) with the following modifications: Build Highlights:
  1. [Estuary] Movie listing and overview fixes for sets
  2. [music]Fix album source constraint violations during library update
  3. X11 - fix segfauls
  4. VAAPI: add error and info callbacks
Build Details:
  1. XBMC:
    • X11 - fix segfauls (PR:14900, 2 commits, 1 file changed)
    • [games] Show installed game clients first (PR:14902, 1 commit, 1 file changed)
    • [addons] remove never set value on CAddonInfo (PR:14895, 1 commit, 1 file changed)
    • [Estuary] Movie listing and overview fixes for sets (PR:14909, 1 commit, 2 files changed)
    • [music]Fix album source constraint violations during library update (PR:14906, 1 commit, 2 files changed)
    • VAAPI: add error and info callbacks (PR:14831, 1 commit, 2 files changed)
  2. inputstream.adaptive:
    • Implement NXFrameRate UUID atom (7a66f1e)
  3. peripheral.joystick:
  4. pvr.mythtv:
    • fix display for video flags (672dee6)
    • sync upstream cppmyth (2.11.2) (67854e9)
    • announce as frontend (e2aad6c)
    • this is a hack to work around the PVR startup flow issue (a1e5399)
    • bump version 5.9.1 (aa5241b)



RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Milhouse - 2018-11-21

New LibreELEC.tv Leia build #1120: Generic
(Supercedes previous build)

SHA256 Checksum: bcbd4fa74821f3be8f67a2feebd54fe2028234da231f0e13bba2a66ae04bf7e1 (Generic)

# uname -a
Linux NUC 4.19.2 #1 SMP Tue Nov 20 21:04:03 GMT 2018 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse): devel-20181120210239-#1120-g39219f8 [Build #1120]

# Kodi version
(18.0-RC1 Git:bacbbc3). Platform: Linux x86 64-bit

Based on tip of LibreELEC.tv master (39219f8, changelog) and tip of XBMC master (bacbbc3, changelog) with the following modifications: Build Highlights:
  1. alsa: update lib/utils/plugins to 1.1.7
  2. OpenGL(ES) debugging improvements
Build Details:
  1. LibreELEC.tv:
    • busybox: enable dmesg and less in init (PR:3113, 1 commit, 1 file changed)
  2. XBMC:
    • OpenGL(ES) debugging improvements (PR:14772, 6 commits, 8 files changed)
  3. inputstream.adaptive:
    • [VP9] copy VpcC atom data into codec extra data (e016f6b)
    • Version bump 2.3.11 (eb5224f)
  4. pvr.mythtv:
    • set state 'CONNECTING' when init the launcher (4b8f89a)
    • sync upstream cppmyth (2.12.0) (85630fb)
    • bump version 5.9.2 (bb02eaf)
  5. pvr.teleboy:
    • Extract APi key from html (420a28d)
  6. Additional commits/pull requests/changes not yet merged upstream:
    • Updated: [env] PR:3084 (perma): linux (RPi/Generic): update to linux-4.19.2
    • Added: [env] PR:3114 (perma): alsa: update lib/utils/plugins to 1.1.7



RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Simaryp - 2018-11-21

Hey Milhouse, I am not doing frequent updates of your builds so I don't know from which build this started but with the recent builds I have an annoying bug again that I had beforehand only on a different custom build.
I am running a HTPC with an Asrock J4105-ITX. I have randomly a mouse cursor in the center of my display. I think I saw it in the past sometimes on bootup before Kodi launched. The occurrence flipflops randomly when the display switches between video playback. For example: After boot; no cursor. During video 1; no cursor. Back in Kodi; cursor. During next video; cursor. And so on. There is no systematic in it. Switching TV-channels might also cause this. Only thing I can say is that switching the displaymode might trigger a flip.
It seems also to be different from the Kodi mouse. I activated it, while I had the cursor in the center. But this caused a second bigger cursor to appear in the upper left corner. I have no mouse attached to the system only a FLIRC-USB, which is usually detected as an Keyboard.

I asked already in the libreelec forum but got no response so far.


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Milhouse - 2018-11-21

(2018-11-21, 08:33)Simaryp Wrote: Hey Milhouse, I am not doing frequent updates of your builds so I don't know from which build this started but with the recent builds I have an annoying bug again that I had beforehand only on a different custom build.
I am running a HTPC with an Asrock J4105-ITX. I have randomly a mouse cursor in the center of my display. I think I saw it in the past sometimes on bootup before Kodi launched. The occurrence flipflops randomly when the display switches between video playback. For example: After boot; no cursor. During video 1; no cursor. Back in Kodi; cursor. During next video; cursor. And so on. There is no systematic in it. Switching TV-channels might also cause this. Only thing I can say is that switching the displaymode might trigger a flip.
It seems also to be different from the Kodi mouse. I activated it, while I had the cursor in the center. But this caused a second bigger cursor to appear in the upper left corner. I have no mouse attached to the system only a FLIRC-USB, which is usually detected as an Keyboard.

I asked already in the libreelec forum but got no response so far.

Can you take a photograph? Have you tried disabling mouse input? It would help if you could identify the first build with this issue.


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Simaryp - 2018-11-21

Hi I made a photograph.
If you were talking about Kodi mouse support, it's deactivated as you can see on the photograph. As mentioned activating it, causes the appearance of a second cursor in upper left corner.

Finding the point when it didn't work anymore might take some time. Is it possible to install freely back and forth? Then I can try to narrow it down by halving the interval again and again.

Image


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Milhouse - 2018-11-22

(2018-11-21, 20:36)Simaryp Wrote: Is it possible to install freely back and forth? Then I can try to narrow it down by halving the interval again and again.

Yes, you should be able to. If you go back far enough (about 9 months or so) you might lose your settings because of the settings system change, so take a backup of guisettings.xml before you start in case you need to restore it - you should know when you've lost your settings as your clock will change to show AM/PM and not 24-hour (at least it does for me).


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Milhouse - 2018-11-22

New LibreELEC.tv Leia build #1121: Generic
(Supercedes previous build)

SHA256 Checksum: 1064ca5cad5095df462da96f3dcff425a5a510cdfde3a83340595aba19a65c18 (Generic)

# uname -a
Linux NUC 4.19.3 #1 SMP Wed Nov 21 22:18:04 GMT 2018 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse): devel-20181121221258-#1121-g4ad81f9 [Build #1121]

# Kodi version
(18.0-RC2 Git:5478a4c). Platform: Linux x86 64-bit

Based on tip of LibreELEC.tv master (4ad81f9, changelog) and tip of XBMC master (5478a4c, changelog) with the following modifications: Build Highlights:
  1. New 4.19.3 kernel
  2. bump to v18.0 RC2
Build Details:
  1. LibreELEC.tv:
    • scripts/mkimage: show message when temp folder is full (PR:3115, 1 commit, 1 file changed)
  2. XBMC:
    • [Docs] Improve the documentation for boolean conditions and infolabels. (PR:14910, 1 commit, 5 files changed)
    • bump to v18.0 RC2 (PR:14787, 1 commit, 1 file changed)
  3. pvr.teleboy:
    • Fix check for plus and comfort member (50689bd)
  4. pvr.vuplus:
    • Unique channels and radio groups (PR:132, 12 commits, 37 files changed)
  5. pvr.zattoo:
  6. Additional commits/pull requests/changes not yet merged upstream:
    • Updated: [env] PR:3084 (perma): linux (RPi/Generic): update to linux-4.19.3
    • Added: [env] PR:3109 (perma): buildsystem: printf conversion to function
    • Added: [env] PR:3117 (perma): kodi (RPi, Generic): update to 18.0rc1



RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - x-rated - 2018-11-22

(2018-10-06, 11:31)Milhouse Wrote:
(2018-10-06, 10:16)x-rated Wrote: Hi, first post.
I too have the artifacts top and bottom.
I also have another problem: settings->system-> blank screen and can't get out. I ssh and restart kodi service

version #1005
here's my kodi.log file http://ix.io/1osX
Did the Settings problem start with #1005, or is it there too in #1004?    
In regards to the problem: settings->system-> blank screen and can't get out. I ssh and restart kodi service
I did a clean install and the problem still there. 
version #1111 debug log: http://ix.io/1u90


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - x-rated - 2018-11-22

I can also confirm artifacts problem gone on #1111


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Simaryp - 2018-11-22

I will try to narrow it down.

Since I registered and I am already here, I think I have two other bugs that I can report.

1. It seems that setting continues Playback has no effekt. I went to Player and highlighted it for series and epsisodes in ordner that for tv series the next file is started automatically. But Playback still stops after every file. Maybe it's because I created my library with EmbyforKODI?

2. I am running a TVHeadend server and client on the system. Again I don't know when it started, but recently I have the problem that starting tvbroadcast the frequency of the display is always set to 25Hz which is wrong. The system detects it and set the display to 50Hz after a second. That holds also for switching a channel.Thats abut annoying because it doubles switching time.


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - fritsch - 2018-11-22

(2018-11-22, 07:27)Simaryp Wrote: I will try to narrow it down.

Since I registered and I am already here, I think I have two other bugs that I can report.

1. It seems that setting continues Playback has no effekt. I went to Player and highlighted it for series and epsisodes in ordner that for tv series the next file is started automatically. But Playback still stops after every file. Maybe it's because I created my library with EmbyforKODI?

2. I am running a TVHeadend server and client on the system. Again I don't know when it started, but recently I have the problem that starting tvbroadcast the frequency of the display is always set to 25Hz which is wrong. The system detects it and set the display to 50Hz after a second. That holds also for switching a channel.Thats abut annoying because it doubles switching time.
 2. is an issue if backend sends semi-parsed / broken-parsed data at beginning and it cannot be detected reliably if it is interlaced or not. Workaround: Remove the 25 hz combination out of the Resolution Whitelist.


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Milhouse - 2018-11-22

(2018-11-22, 06:04)x-rated Wrote: In regards to the problem: settings->system-> blank screen and can't get out. I ssh and restart kodi service
I did a clean install and the problem still there. 
version #1111 debug log: http://ix.io/1u90

Unfortunately there's not much to go on in your log, so we still need to know when this "blank screen" issue started with these builds as we have no other clue.


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Simaryp - 2018-11-22

Thanks for the information. It's not super urgent, so I would prefer to create a bug report or whatsoever than live with a workaround. So from your comment I assume it's a problem with the TVHeadend server, right?


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - epias - 2018-11-22

I'm still seeing a lot of bugs for a RC2:

1. Aspect Ratio is not correctly displayed in Zoom information;
2. Spline36 and Lanczos3 Video Scaling does not work properly (Pixelation/Interpolation), cycling through Zoom Modes fixes it;
3. IPTV (PVR IPTV Simple Client) blank screen and log errors: 'Unsupported stream 0. Stream disabled'. Seems that this is caused by 'Adjust display refresh rate = On'.

Tested with a NUC6CAYH and the latest build #1121 (freshly formatted flash drive).

edit: The Lanczos3 Video Scaling problem started with build #0210. See the difference between #0209 and #0210. Both are Lanczos3 - Optimised.
edit2: The IPTV blank screen issue seems to be fixed in #1123.