Kodi Community Forum
v18 LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Linux (https://forum.kodi.tv/forumdisplay.php?fid=52)
---- Thread: v18 LibreELEC Testbuilds for x86_64 (Kodi 18.0) (/showthread.php?tid=298462)



RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Guilouz - 2017-06-21

(2017-06-21, 03:59)Milhouse Wrote:
(2017-06-21, 01:48)Guilouz Wrote: I do not have the exact version since it happened because I had not added new content, but it seems to be related to changes with addons.

I've just gone back to #0401 and this add-on produces the same results - poster and fanart only - so it doesn't appear to be a change in Kodi. This is more likely to be a change to the upstream website (ie. the add-on needs an update/bug fix).

Try enabling debug in the addon (on the Advanced tab) - you'll most likely see something similar to this:
Code:
02:55:32.034 T:140037309950016   DEBUG: ------ Window Init (DialogNotification.xml) ------
02:55:32.086 T:140034592741120   DEBUG: Artwork Downloader: ########################################################
02:55:32.086 T:140034592741120   DEBUG: Artwork Downloader: Processing media:  Blade Runner - The Final Cut
02:55:32.086 T:140034592741120   DEBUG: Artwork Downloader: Provider ID:       tt0083658
02:55:32.086 T:140034592741120   DEBUG: Artwork Downloader: Media path:        [u'nfs://192.168.0.3/mnt/share/media/Video-Private/MoviesHD/Blade Runner']
02:55:32.086 T:140034592741120   DEBUG: Artwork Downloader: - Still missing some files
02:55:32.086 T:140034592741120   DEBUG: Artwork Downloader: False
02:55:32.086 T:140034592741120   DEBUG: Artwork Downloader: API: http://api.themoviedb.org/3/configuration?api_key=4be68d7eab1fbd1b6fd8a3b80a65a95e
02:55:32.532 T:140034592741120   DEBUG: Artwork Downloader: API: http://api.themoviedb.org/3/movie/tt0083658/images?api_key=4be68d7eab1fbd1b6fd8a3b80a65a95e
02:55:32.552 T:140034592741120   DEBUG: Artwork Downloader: API: http://webservice.fanart.tv/v3/movies/tt0083658?api_key=586118be1ac673f74963cc284d46bd8e
02:55:32.568 T:140034592741120   DEBUG: Artwork Downloader: Cache expired. Retrieving new data
02:55:40.286 T:140037309950016   DEBUG: ------ Window Deinit (DialogNotification.xml) ------
02:55:43.654 T:140034592741120   DEBUG: Artwork Downloader: Error getting data from fanart.tv - Movie API (Timed out): skipping
02:55:43.654 T:140034592741120   DEBUG: Artwork Downloader: - Using GUI mode
02:55:43.665 T:140037309950016   DEBUG: ------ Window Init (DialogSelect.xml) ------

It looks like the fanart.tv "Movie API" is not working - you'll need to contact the addon maintainer for an update/fix/support.

See:

https://forum.fanart.tv/viewtopic.php?f=4&t=6602
https://forum.fanart.tv/viewtopic.php?f=8&t=6639
https://forum.fanart.tv/viewtopic.php?f=10&t=6601

Yes, same error in log. Thanks.


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Soulplayer - 2017-06-21

(2017-06-20, 04:51)Milhouse Wrote:
(2017-06-20, 04:42)MicTie Wrote: @Milhouse: my installation using Git 20170620 still shows the same issue
Thanks!

Thanks, but if that's an official nightly then it won't include PR12311 as the PR hasn't merged yet. This needs @Soulplayer to test using one of these test builds that already include PR12311, or you can test PR12311 after it merges and is included in a nightly.

Hello, sorry for the delay

#0616:
Works perfectly. Plays video files & downloads the subtitles right next to the video file.

#0620:
Works perfectly. Plays video files & downloads the subtitles right next to the video file.

Thanks for the great work!


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Milhouse - 2017-06-22

New LibreELEC.tv Leia build #0621: Generic
(Supercedes previous build)

Code:
# uname -a
Linux NUC 4.11.6 #1 SMP Wed Jun 21 22:10:58 BST 2017 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse) - Version: devel-20170621220859-#0621-g89d6978 [Build #0621]

# Kodi version
(18.0-ALPHA1 Git:423072a). Platform: Linux x86 64-bit

Based on tip of LibreELEC.tv master (89d69787, changelog) and tip of XBMC master (132e6e89, changelog) with the following modifications: Build Highlights:
  1. Temporary bug fix for wget issue after busybox 1.26.2 (bug 9981)
Build Details:
  1. LibreELEC.tv:
    • minor package bumps (PR:1693, 6 commits, 6 files changed)
    • busybox: update to 1.26.2 (PR:1694, 1 commit, 5 files changed)
  2. XBMC:
    • [bluray] jvm check is available since libbluray 1.0.1 (PR:12310, 2 commits, 7 files changed)
    • FIXUP: [droid] addon packaging (PR:12331, 1 commit, 1 file changed)
    • [lang][kodi.core] automatic syntax corrections for the en_GB language file (93448bdf)
    • [lang][skin.estuary] updated language files from Transifex (4d6f179b)
    • [lang][skin.estouchy] updated language files from Transifex (132e6e89)
  3. pvr.dvbviewer:
    • fix channel parsing if there's no favourites group (b51154ae)
    • bump version to 3.0.6 (1231567c)
    • In case of empty favourites bail out early (a5db9ddb)
  4. pvr.mythtv:
    • notice addon creation and destruction (fbb7e561)
  5. Additional commits/pull requests/changes not yet merged upstream:
    • Reverted: [pkg] de3da6bf: wget/ssl_helper: update to wolfssl-3.9.8 (reason: breaks chunked download) (busybox)



RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - MicTie - 2017-06-22

(2017-06-20, 04:51)Milhouse Wrote:
(2017-06-20, 04:42)MicTie Wrote: @Milhouse: my installation using Git 20170620 still shows the same issue
Thanks!

Thanks, but if that's an official nightly then it won't include PR12311 as the PR hasn't merged yet. This needs @Soulplayer to test using one of these test builds that already include PR12311, or you can test PR12311 after it merges and is included in a nightly.

Looking at the changelog for 2:18.0+git20170622.0200-132e6e8-0xenial, I find '
Quote: [Chris "Koying" Browet]
* FIXUP: [droid] addon packaging'
so it seems fix #12331 was merged (https://github.com/xbmc/xbmc/pull/12331/commits/42f225aa4ec4f0e7f969fbe3259db9c919eb33aa)

Too bad, my subtitles are still missing ...


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Milhouse - 2017-06-22

@MicTie: PR12311 is the fix, not yet merged.


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - MicTie - 2017-06-22

@Milhouse: oh, sorry mixed up the numbers ...


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - E92M3 - 2017-06-22

(2017-06-21, 10:16)Milhouse Wrote:
(2017-06-21, 08:08)E92M3 Wrote: On any of the latest builds I'm getting a hang on boot.

"any of the latest builds" how far back are you referring to? Do you have some known point in time when this started? Did it ever work, if so until when?

And if you try a build from, say, 2 months ago does that boot normally? Or does it fail in the same way as the latest build?

I'd expect an older build to fail just like the latest build, as I don't think there's anything wrong with these builds - I've never seen a problem like this before, except where the SYSTEM image is corrupted.

Presumably you've tried updating again to the latest build which would overwrite any potentially corrupted SYSTEM file with a new image.

I'm not sure what else would cause this issue. If all else fails I'd suggest a re-image using the latest LibreELEC 8.0.2 disk image.

(2017-06-21, 08:08)E92M3 Wrote: Edit2:
Connecting to remote SMB shares is still not working for me, I disabled zeroconf and can now access shares if I manually type in the full smb:///XXX.XXX.XXX.XXX/Share path, but the browse function does not work at all and will not list any shares.

Try LE 8.0.2, does that allow you to browse? Are you trying to access shares on an LE samba server or some other server? Which server on your network is your master browser and does it support NT1? Is your default network workgroup "WORKGROUP" or something else? Have you tried forcing SMB1 in the Kodi Settings > Samba?

I re-imaged with 8.0.2 and I am able to browse my SMB shares on a W7 box. I'll load a clean install that doesn't have my passwords saved and then try the latest update file to test and report back. Also, the boot hang apparently has something to do with the W10 bootloader I was using. I was using W10 bootmenu to dual boot off this second drive. If I select the drive from bios with Libreelec and boot directly from it I don't get the hang. I'll have to do some more troubleshooting on that one as I didn't have a problem with that before.

As always, thanks for replying back.


Edit: I loaded a clean 8.0.2 and then installed the latest test build from tonight #621, I get a blue spinning wheel when I try to browse for SMB shares. If I hit escape out of the spinning wheel the OS hangs and I have to power reset the NUC. I'll step back to earlier builds and see if I can get lucky.


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Milhouse - 2017-06-22

(2017-06-22, 06:23)E92M3 Wrote: Edit: I loaded a clean 8.0.2 and then installed the latest test build from tonight #621, I get a blue spinning wheel when I try to browse for SMB shares. If I hit escape out of the spinning wheel the OS hangs and I have to power reset the NUC. I'll step back to earlier builds and see if I can get lucky.

Do you see the blue spinning wheel every boot? I see it maybe 1 in 10 (restarting Kodi is enough, if you're able to do that from ssh). It seems to be a race condition/deadlock of some kind at startup that is triggered by Samba 4.

Oh and anonymous access (to shares with "Everyone" or "Guest" access and no passwords) is not currently supported but I don't think this should affect browsing.


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - kalebroc - 2017-06-22

Hi @Milhouse,

Sorry for coming across as a complete idiot for asking this question, but I've been reading and reading and I think I'm after confusing myself. I currently have an Amlogic S912 device running Libreelec and it's fine, it works really well in fairness to it, so that does most of my needs at the moment. Now on to my issue, my recent purchase has been a new Denon A/V receiver and Panasonic 4K UHD 65" TV and I would love to be using my HTPC rather than the aforementioned S912 device just for speed etc. So my HTPC is an Intel Core i3 7100, 8GB RAM, 250GB SSD & a Nvidia GTX 1050Ti 4GB Video Card and while I can get it setup on Windows 10 to play back 4k HDR 10bit files I would much rather be using Libreelec, I just find it faster and easier for the wife to use, so finally on to my question for you - are your builds capable of doing 4k HDR 10bit file playback on my setup or are they mainly aimed at Intel graphics and if so do you or anybody else reading this have any idea of a build that might suit my setup or if there is even a rough timescale to when Libreelec will be able to do 4k HDR playback?
Sorry for the long winded message, thank you in advance and also for the amazing work you do on this forum.

Regards,
@kalebroc


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Milhouse - 2017-06-22

(2017-06-22, 22:37)kalebroc Wrote: are your builds capable of doing 4k HDR 10bit file playback on my setup

No, there is no support for 4K HDR 10bit.

First of all, Kodi doesn't support HDR (yet).

Secondly, VDPAU (the hardware acceleration used by Nvidia GPUs) doesn't support 10bit HEVC (I assume you mean HEVC and not H264 as there is no hardware acceleration at all for H264 10bit).

4K 10bit HEVC support is possible with these builds, but currently only on Intel Apollo Lake/Kaby Lake hardware.

Also, the wiki has recently been updated: http://kodi.wiki/view/Supported_hardware#Desktop

(2017-06-22, 22:37)kalebroc Wrote: or are they mainly aimed at Intel graphics

These builds are not explicitly aimed at Intel (we - and Kodi - support AMD too, as well as Nvidia) however the underlying video hardware acceleration library favoured by Kodi developers on Linux is called VAAPI and this is supported by Intel hardware so this is where most of the development is.

The library used by AMD and Nvidia hardware is called VDPAU which is stagnating and will most likely die in future, along with Nvidia hardware support (AMD also supports VAAPI, and this is the route for AMD hardware in future, once the necessary changes are made in Kodi).

(2017-06-22, 22:37)kalebroc Wrote: do you or anybody else reading this have any idea of a build that might suit my setup or if there is even a rough timescale to when Libreelec will be able to do 4k HDR playback?

No such build exists, and I honestly couldn't tell you when 4K HDR support will happen - end of the year would be my best guess (around kernel 4.13.y/4.14.y), and this assumes support in various parts of the stack including Kodi. And whether VDPAU will have the necessary support... no clue, but seems unlikely.

(Maybe I'm going out on a limb here, but if it's not obvious from the above: Nvidia hardware is not a good long-term choice for Kodi on Linux)


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Milhouse - 2017-06-22

New LibreELEC.tv Leia build #0622: Generic
(Supercedes previous build)

Code:
# uname -a
Linux NUC 4.11.6 #1 SMP Thu Jun 22 21:07:14 BST 2017 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse) - Version: devel-20170622210557-#0622-g89d6978 [Build #0622]

# Kodi version
(18.0-ALPHA1 Git:423072a). Platform: Linux x86 64-bit

Based on tip of LibreELEC.tv master (89d69787, changelog) and tip of XBMC master (355c8ac9, changelog) with the following modifications: Build Highlights:
  1. [inputstream] change addon interface to new C++ style (might temporarily break addon)
  2. changed: Default libcurl and samba timeout value to 30
  3. Better fix for busybox wget (thanks @Asavah)
  4. New commit on PR12300 fixing crashing issues reported by @Guilouz when using Estuary MODv2
Build Details:
  1. XBMC:
    • [windows][mingwlibs] change installdirectory (PR:12328, 3 commits, 11 files changed)
    • [inputstream] change addon interface to new C++ style (PR:12325, 1 commit, 15 files changed)
    • changed: Default libcurl timeout value to 30 (PR:12320, 2 commits, 1 file changed)
  2. inputstream.rtmp:
    • Change to new C++ based addon interface style (PR:22, 1 commit, 3 files changed)
  3. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] PR:1710: busybox: fix wget with brain-damaged http servers



RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - E92M3 - 2017-06-23

(2017-06-22, 10:46)Milhouse Wrote:
(2017-06-22, 06:23)E92M3 Wrote: Edit: I loaded a clean 8.0.2 and then installed the latest test build from tonight #621, I get a blue spinning wheel when I try to browse for SMB shares. If I hit escape out of the spinning wheel the OS hangs and I have to power reset the NUC. I'll step back to earlier builds and see if I can get lucky.

Do you see the blue spinning wheel every boot? I see it maybe 1 in 10 (restarting Kodi is enough, if you're able to do that from ssh). It seems to be a race condition/deadlock of some kind at startup that is triggered by Samba 4.

Oh and anonymous access (to shares with "Everyone" or "Guest" access and no passwords) is not currently supported but I don't think this should affect browsing.

The times I do not get the spinning wheel I just get a ".." prompt to select a higher level it never lists "workgroup" so I'm unable to browse to my server and connect to my shares.
I can however "sometimes" add a manual location by adding "smb://whatever-server/sharename" and it will prompt me for a username and password, but quite often it rejects it even though I know it's right. another reboot and it will work.
I'm currently loading your build from tonight just to try, but if I go back to 8.0.2 I'm able to browse "workgroup" smb and see my server shares and connect to them. Once they are saved updating seems to be OK. It's only if I'm starting fresh from a update without having the shares saved from 8.0.2.

I have delay kodi for network load and zeroconf disabled. hard wired, local switch gig-e to server.


Yes, same issue with tonight's build, I can't browse just brings up ".." no workgroup etc to browse deeper. I can however still manually add "SMB://whatever/whatever" and it will connect to my shares.
Very odd, I wonder why that changed from 8.0.2 where it works.


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - kalebroc - 2017-06-23

@Milhouse ,

Thank you for all the info, it has certainly helped me. Looks like it's back to Windows 10 for my HTPC, it just sucks that a little €65 android box performs better than a €700 PC for playing back movies !!
Anyway, thank you again for all the help, I'll keep an eye on your builds and maybe sometime in the future I might get my HTPC back running on Libreelec again.

Cheers,

@kalebroc


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Milhouse - 2017-06-23

@E92M3 you haven't answered:
(2017-06-21, 10:16)Milhouse Wrote: Are you trying to access shares on an LE samba server or some other server? Which server on your network is your master browser and does it support NT1? Is your default network workgroup "WORKGROUP" or something else? Have you tried forcing SMB1 in the Kodi Settings > Samba?

At the moment I can only imagine your Samba server doesn't "speak" SMB2+ reliably so you should force SMB1 (NT1) in the Kodi Samba settings.


RE: LibreELEC Testbuilds for x86_64 (Kodi 18.0) - Milhouse - 2017-06-23

New LibreELEC.tv Leia build #0623: Generic
(Supercedes previous build)

Code:
# uname -a
Linux NUC 4.11.6 #1 SMP Fri Jun 23 21:16:04 BST 2017 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse) - Version: devel-20170623210658-#0623-g6703cc5 [Build #0623]

# Kodi version
(18.0-ALPHA1 Git:423072a). Platform: Linux x86 64-bit

Based on tip of LibreELEC.tv master (6703cc59, changelog) and tip of XBMC master (5c2c6239, changelog) with the following modifications: Build Highlights:
  1. openssl: update to openssl-1.0.2l
  2. [fix][Take II] Nuke 'libpng warning: iCCP: known incorrect sRGB profile' warnings and optimize images
Build Details:
  1. LibreELEC.tv:
    • dvb-tools: add blindscan, dvbsnoop, szap and tune-s2 (PR:1681, 7 commits, 9 files changed)
    • inotify-tools: build without doxygen (PR:1716, 1 commit, 1 file changed)
    • busybox: restore missing applets after last bump (PR:1715, 1 commit, 1 file changed)
    • busybox: fix wget with brain-damaged http servers (PR:1710, 1 commit, 1 file changed)
  2. XBMC:
    • Fix massive faults (PR:12338, 2 commits, 2 files changed)
  3. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] PR:1713: openssl: update to openssl-1.0.2l
    • Added: [env] PR:1717: activate swap for all projects
    • Added: [pkg] PR:12345: [fix][Take II] Nuke 'libpng warning: iCCP: known incorrect sRGB profile' warnings and optimize images