Kodi Community Forum
Android Cannot access SMB shares on Windows 10 - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Android (https://forum.kodi.tv/forumdisplay.php?fid=164)
---- Thread: Android Cannot access SMB shares on Windows 10 (/showthread.php?tid=304203)

Pages: 1 2 3


Cannot access SMB shares on Windows 10 - Karateinspace - 2017-01-15

When I try to access SMB shares on a Windows 10 machine from my FireTV stick, I keep getting "invalid argument" errors. Sometimes it allows me to access the share and it's fine, but that's rare and usually it gives me the invalid argument error. I've added the share by both selecting browse and choosing the share, and I've also added it manually through "select network location". I've googled the issue and some sites suggest changing the IRPstacksize in the registry, but I've had no luck with that. This is a really irritating issue and I'd love to find a solution.


RE: Cannot access SMB shares on Windows 10 - flhthemi - 2017-01-16

Smb on 17 is causing problems.I have 2 Android boxes that work fine but my Samsung S10.5 T800 fails with a timeout just trying to access windows workgroup. I've also had it happen the same way with Ubuntu. I'm trying to figure it out too but no joy. Best I can hope for is that someone figures it out and posts the fix, not a work around. We have a couple of those already that help but don't fix it. Like you've discovered trying to manually enter an IP. Somewhere else it will fail because smb isn't working as it should on some devices.


RE: Cannot access SMB shares on Windows 10 - itproman - 2017-02-18

I have the same problem.

I installed Kodi 17 on my Smart TV,but cannot add shares from my Windows 10 PC'.
I have been able to set up Weather,some official addons,but that's all.

I googled the problem and looked through some of the forum discussions and even tried chaning a few settings on the Windows PC,but,it still won't work;won't even show the folders beoyond "users" in fact.

Thankfully,I access the Windows Folders using Plex,so all is not lost.


RE: Cannot access SMB shares on Windows 10 - flhthemi - 2017-02-19

I solved my smb issue by going to my router's firewall settings and turning on NETBIOS. All is just fine and dandy now been working as it should for about a week.


RE: Cannot access SMB shares on Windows 10 - itproman - 2017-02-19

Doesn't help me.

I checked my modem/router's settings and note that netbios is already on.


RE: Cannot access SMB shares on Windows 10 - flhthemi - 2017-02-19

One other suggestion I saw was to turn on netbios on the machine that you are sharing from, the host. This is done via opening Network Sharing Center...

Click on Connections:Ethernet
Click on Properties button (lower left)
Double click internet Protocol Version 4 (TCP/IPv4)
Click Advanced Button lower right
Click the WINS tab
Click the radio button to Enable NetBios over TCP/IP

Might work...


RE: Cannot access SMB shares on Windows 10 - kamby19 - 2017-10-17

(2017-02-19, 23:17)flhthemi Wrote: One other suggestion I saw was to turn on netbios on the machine that you are sharing from, the host. This is done via opening Network Sharing Center...

Click on Connections:Ethernet
Click on Properties button (lower left)
Double click internet Protocol Version 4 (TCP/IPv4)
Click Advanced Button lower right
Click the WINS tab
Click the radio button to Enable NetBios over TCP/IP

Might work...

DID work!  At least for me.  And I tried EVERYTHING else!

Yet when I was struggling with this issue earlier,I was told to turn OFF NetBios over TCP/IP!  That was very bad advice.

Thanks, flhthemi


Cannot access SMB shares on Windows 10 - KaraokeAmerica - 2017-11-12

Interesting. I’ll have to see if net bios is enabled on my windows 10 server as well. I’ve been banging my head on the wall for the same problem for hours today.


Sent from my iPhone


RE: Cannot access SMB shares on Windows 10 - novikorisnik - 2018-01-07

Hi guys. I've just registered to post solution regarding connecting errors with Kodi using windows 10 SMB shares. (getting timeout error after I upgraded from win7 to win10 few days ago).

In windows 10, you have to enable SMB 1.0 because kodi uses this older version of SMB.

Image

As explained here:

SMB/Windows (wiki)

Cheers.


RE: Cannot access SMB shares on Windows 10 - buzzard4312 - 2018-01-25

Thank you for your solution. I came to the same conclusion, that my earlier problem of the so called "invalid argument" had to do with SMB. But I only saw it on the RPi LibreElect version. This version of Kodi implements SMB using all three newer versions. However my version of Windows 10 only provides for SMBv1. So if I wanted to use SMB, I had to set Kodi to SMBv1 max. This was the only way I could connect to shares on my Local Area Network.
Adventures in PC Land should be the title of a best seller.


RE: Cannot access SMB shares on Windows 10 - parula66 - 2018-02-26

I could not get the sc config command (or sc.exe in Powershell) to achieve the result I desired, so I resorted to two registry edits and a reboot.  See new steps below. Try this:
1. Run "tasklist /svc"
In the output, you should see something like this: Browser and LanmanServer running in their own svchost processes. *Sample output below is abbreviated for illustration purposes. You will see a longer list.Image Name                     PID Services
========================= ======== ==============
svchost.exe                   2772 LanmanServer
svchost.exe                   2868 Browser
2. Run these two commands to add the SvcHostSplitDisable registry value set to 1.

REG ADD HKLM\SYSTEM\CurrentControlSet\Services\Browser /v SvcHostSplitDisable /t REG_DWORD /d 1 /f

REG ADD HKLM\SYSTEM\CurrentControlSet\Services\LanmanServer /v SvcHostSplitDisable /t REG_DWORD /d 1 /f

This will reconfigure the Browser service to run in a shared svchost with LanmanServer like in previous versions of Windows.


RE: Cannot access SMB shares on Windows 10 - parula66 - 2018-02-26

Master Browser not working for NON Windows devices in build 1709 and 1703


RE: Cannot access SMB shares on Windows 10 - DaVu - 2018-02-26

Just to mention it...

Enabling the SMB1 support on Windows 10 is a "last resort" solution. SMB1 was disabled for a very good reason. And I agree, that the wiki page, you are referring to, will need (and receive) an update.

SMB1 on Windows 10 was disabled because of security reasons. Enabling it again will open the security hole, which was closed by disabling SMB1, again.

The recommended way should be, to add SMB sources by using the "Select a network location" in Kodi and use the IP instead of the hostname. Also you have to secure your SMB shares with passwords which you have to enter at the specific window in Kodi as well.

Network browsing (to see a share listed under "Network" in Windows File Explorer) was a SMB1 feature and is not supported by SMB2/3. Same counts for "anonymous login". Therefore you will need a password for your SMB shares.


RE: Cannot access SMB shares on Windows 10 - nicestzz - 2018-04-30

same outcome invalid argument even if you use IP address and browse for a directory....


RE: Cannot access SMB shares on Windows 10 - mazey - 2018-04-30

kodi v17 doesnt have smb2/3 support so the only option is to enable smb 1 on a windows 10 machine. turn windows features on/off "Smb 1/Cifs Server" just tick that one. i left automatic removal and client unticked.

browsing hasnt worked for awhile you need to add network location in kodi and put the server name or ip in then you can connect to it.