Kodi Community Forum
Android ALL Kodi17 - (TvHeadend) PVR - SW/HW Decoding issue - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Android (https://forum.kodi.tv/forumdisplay.php?fid=164)
---- Thread: Android ALL Kodi17 - (TvHeadend) PVR - SW/HW Decoding issue (/showthread.php?tid=306137)

Pages: 1 2 3 4


RE: Shield Kodi17 - SW/HW Decoding issue - maxtherabbit - 2017-02-07

I made a backup of the .kodi folder and removed the original Kodi install. After that the notsoshitty version installed fine.

With DVBViewer Recording Service backend it's business as usual, everything just works.

With TVHeadend backend hardware acceleration and deinterlacing works now with Mediacodec surface rendering. It works on all channels, SD and HD, mpeg2 and h264. It also works every time I switch channels.

The only problem is that with TVHeadend backend it detects the aspect ratio incorrectly on all SD (mpeg2) channels. It's 4:3 when it should be 16:9. No problems with aspect ratios with DVBViewer Recording Service.

watch gallery



RE: Shield Kodi17 - SW/HW Decoding issue - fritsch - 2017-02-07

If you don't need tvheadend, don't use it. From all the backend servers it's the worst concerning sending valid data on playback start.


RE: Shield Kodi17 - SW/HW Decoding issue - Burning-Ranger - 2017-02-08

(2017-02-07, 10:58)Koying Wrote: Yep. Untested though, but the actual issue is that the surface is busy when trying to open it a second time, and it thus fails.
Mediacodec non-surface shouldn't have this issue on Shield.

Switching surface off did not solve this problem. So I did try the notsoshitty version, wich is not shitty at all. Here Hardware decoding works always. But i´m also having the weird 4:3 issue (TVHeadend).
Any other known disadvantages with this version?


RE: Shield Kodi17 - SW/HW Decoding issue - fritsch - 2017-02-08

Nope. It was exactly made cause of the above issue. As it does not catch 100% cases we decided against this "shortterm workaround" and decided to do it properly in v18 ... btw. that's why it's called "not so shitty" ;-)


RE: Shield Kodi17 - SW/HW Decoding issue - wrxtasy - 2017-04-22

(2017-02-07, 19:44)maxtherabbit Wrote: The only problem is that with TVHeadend backend it detects the aspect ratio incorrectly on all SD (mpeg2) channels. It's 4:3 when it should be 16:9. No problems with aspect ratios with DVBViewer Recording Service.

watch gallery
There is a Kodi Krypton workaround for this in Settings...

Kodi Settings > Player > Videos > Display 4:3 Videos as Stretch 16:9


RE: Shield Kodi17 - SW/HW Decoding issue - stubi - 2017-05-04

Hi,

i have the same problem with hw/sw-decoding in alternation with my ShieldTV(2017). But the link with the corrected Kodi-version is dead - is it possible, to get the apk-file?

regards
Stubi


RE: Shield Kodi17 - SW/HW Decoding issue - fritsch - 2017-05-05

Building both new as we speak - will be available in the test versions folder: http://mirrors.kodi.tv/test-builds/android/arm/


RE: Shield Kodi17 - SW/HW Decoding issue - stubi - 2017-05-05

Oh, okay. Thanks. I wasnt shure about the correct version, so tried the "vpupdates" and the "samsmaster"...
Both solved the hw/sw-problem, but brought new ones with them Smile
At each programstart kodi deactivates my VNSI-Plugin and, more worse, jumping in my Videofiles (+30sek or next chapter or start at...) is very slow or ends with an crash.

regards
Stubi


RE: Shield Kodi17 - SW/HW Decoding issue - fritsch - 2017-05-05

Nope - it's the notsoshitty build in the above link. You installed a v18 alpha build.


RE: Shield Kodi17 - SW/HW Decoding issue - stubi - 2017-05-05

Thanks for your Reply.
This morning I could not find this version - so i installed the other ones Smile
Now i can see the "notsoshitty"-version. I'll try it out when I get home from work...

kind regards
Stubi


RE: Shield Kodi17 - SW/HW Decoding issue - fritsch - 2017-05-05

As said above: "Building both new AS we speak" - "WILL be available" .. :-)


RE: Shield Kodi17 - SW/HW Decoding issue - stubi - 2017-05-05

Mea culpa - english is not my strength Wink

Stubi


RE: Shield Kodi17 - SW/HW Decoding issue - stubi - 2017-05-05

Finally i could try the right version - i think it now works perfectly.
Thank you very much.

kind regards
Stubi


RE: Shield Kodi17 - SW/HW Decoding issue - fritsch - 2017-05-06

No problem - you are welcome. Future v18 builds will improve these things even more (after vpupdates was merged).


RE: Shield Kodi17 - SW/HW Decoding issue - Eureka - 2017-05-29

Is this just related to PVR? I see the specs on another thread that resemble my blu-ray rips and wanted to see if this would be a problem watching movies and TV shows (mainly Japanese and British blu-rays).

http://forum.kodi.tv/showthread.php?tid=309717&pid=2552817#pid2552817


This forum uses Lukasz Tkacz MyBB addons.