Kodi Community Forum
Bug: Kodi 17 tvshow add from NFO stops on season where file is not found - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Windows (https://forum.kodi.tv/forumdisplay.php?fid=59)
---- Thread: Bug: Kodi 17 tvshow add from NFO stops on season where file is not found (/showthread.php?tid=307736)



Bug: Kodi 17 tvshow add from NFO stops on season where file is not found - Rayman4449 - 2017-02-21

I've found a bug with Kodi 17 where when adding tvshows from NFO files that if a file is encountered that does not have NFO files associated with it (ie doesn't have info that Kodi can process) the TV show adding stops on that season. So if you had the problem with a file in Season 2 and you had 6 more seasons after it, the adding stops with Season 2 and the rest don't add to the library. In the past, Kodi would just skip over any files or video files it encountered that it couldn't find and move to the next file and keep adding.(which is what I would expect and want Kodi to do)

From looking at the logs it appears that there is another issue that it still looks for directories that no longer exist even if you have deleted them and run a Clean on the database.


Example from Log file:
07:50:13.901 T:19136 ERROR: CScraperParser:Tonguearse: Could not find scraper function GetEpisodeList
07:50:13.901 T:19136 ERROR: ADDON::CScraper::Run: Unable to parse web site
07:50:13.901 T:19136 WARNING: No information found for item 'smb://WEBSURFER/TV Shows12/Law & Order/All Shows/', it won't be added to the library.
07:50:13.902 T:19136 WARNING: VIDEO::CVideoInfoScanner:Tonguerocess directory 'smb://WEBSURFER/TV Shows12/Law & Order/Season 1/' does not exist - skipping scan.
07:50:13.902 T:19136 WARNING: VIDEO::CVideoInfoScanner:Tonguerocess directory 'smb://WEBSURFER/TV Shows12/Law and Order/' does not exist - skipping scan.
07:50:13.903 T:19136 WARNING: VIDEO::CVideoInfoScanner:Tonguerocess directory 'smb://WEBSURFER/TV Shows12/Law and Order/All Shows/' does not exist - skipping scan.
07:50:13.904 T:19136 WARNING: VIDEO::CVideoInfoScanner:Tonguerocess directory 'smb://WEBSURFER/TV Shows12/Law and Order/Season 1/' does not exist - skipping scan.
07:50:14.217 T:19136 ERROR: CScraperParser:Tonguearse: Could not find scraper function GetEpisodeList
07:50:14.217 T:19136 ERROR: ADDON::CScraper::Run: Unable to parse web site
**********************************

This entry is the one I'm talking about for files without NFO files: 07:50:13.901 T:19136 WARNING: No information found for item 'smb://WEBSURFER/TV Shows12/Law & Order/All Shows/', it won't be added to the library.

These are the entries of old directories that have long been deleted and cleaned: 07:50:13.902 T:19136 WARNING: VIDEO::CVideoInfoScanner:Tonguerocess directory 'smb://WEBSURFER/TV Shows12/Law and Order/' does not exist - skipping scan.
07:50:13.903 T:19136 WARNING: VIDEO::CVideoInfoScanner:Tonguerocess directory 'smb://WEBSURFER/TV Shows12/Law and Order/All Shows/' does not exist - skipping scan.
07:50:13.904 T:19136 WARNING: VIDEO::CVideoInfoScanner:Tonguerocess directory 'smb://WEBSURFER/TV Shows12/Law and Order/Season 1/' does not exist - skipping scan.


Notes:
- I put my Episodes in a single folder 'All Shows' but I've had them in separate folders "Season 1, Season 2, etc with no change"
- This behavior of stopping adding in season with extra file/file not found happens only with NFO file source scan, not when using TVDB scrapper as the source.


I'm posting this out here in the regular forums to get any general input before I move to posting this as a formal bug.


This forum uses Lukasz Tkacz MyBB addons.