Kodi Community Forum
Lost websocket connection - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Add-on Support (https://forum.kodi.tv/forumdisplay.php?fid=27)
+---- Forum: Web Interfaces (https://forum.kodi.tv/forumdisplay.php?fid=156)
+----- Forum: Chorus 2 (https://forum.kodi.tv/forumdisplay.php?fid=268)
----- Thread: Lost websocket connection (/showthread.php?tid=308456)

Pages: 1 2


RE: Lost websocket connection - eldakka - 2022-01-20

Some further information on identifying this issue.

On doing a netstat on the kodi server you can see that the port is only LISTENING locally (or not at all if remote control is off even for this system):
[email protected]:~$ netstat -nlut | grep :9090
tcp        0      0 127.0.0.1:9090          0.0.0.0:*               LISTEN     
tcp6       0      0 ::1:9090                :::*                    LISTEN     


But after enabling settings→services→control→Allow remote control from applications on other systems, the LISTEN port shows open to all:
[email protected]:~$ netstat -nlut | grep :9090
tcp        0      0 0.0.0.0:9090            0.0.0.0:*               LISTEN     
tcp6       0      0 :::9090                 :::*                    LISTEN   



RE: Lost websocket connection - mata7 - 2022-03-26

(2020-04-29, 20:27)DjZU Wrote: I run into the same problem and could solve it.

Make sure that your firewall is allowing incoming traffic for the EventServer listening on the UDP port 9777 (this is the default port as seen in your 'guisettings.xml' file in 'userdata' folder). See https://kodi.wiki/view/EventServer#Event_Clients_and_the_EventServer

Make sure that your firewall is allowing incoming traffic for the JSON-RPC API listening on the TCP port 9090 by default. See https://kodi.wiki/view/JSON-RPC_API#WebSocket
If you ever changed this port in your 'advancedsettings.xml' file in 'userdata' folder (see https://kodi.wiki/view/Advancedsettings.xml#jsonrpc), then you also have to give the same value to 'socketsPort:' on line 31 at this time in the file 'kodi-webinterface.js' located in '/usr/share/kodi/addons/webinterface.default/js/' for Linux. Note that this file may be replaced and your change erased in case of Kodi update.

I also posted this answer on https://github.com/xbmc/chorus2/issues/274#issuecomment-621379839

thank you that fix it for me also


RE: Lost websocket connection - DjDiabolik - 2022-06-08

Sorry but recently i have start to obtain this errors when open the Chorus2 from my PC using PC.

I have try to understand how i need to enable or disable........ read the comment #12 report as solution but i don't understand. I have set the port for WEBSERVER to 80 so from my pc i need simply to open 192.168.1.4 (ip of my pi2 on my home network) to open chorus2.
But it's simply unusable because i obtain this error appears on bottom right corner most frequently.

From kodi settings....... i need only to leave activated one of two option and not both option (things default setting) ?? How i need to do to fix this issue ?


RE: Lost websocket connection - Klojum - 2022-06-08

(2022-06-08, 03:05)DjDiabolik Wrote: But it's simply unusable because i obtain this error appears on bottom right corner most frequently.

And exactly what error is this?


RE: Lost websocket connection - DjDiabolik - 2022-06-09

(2022-06-08, 04:54)Klojum Wrote:
(2022-06-08, 03:05)DjDiabolik Wrote: But it's simply unusable because i obtain this error appears on bottom right corner most frequently.

And exactly what error is this?
oh.. it's appears "lost websocket" and i need manually to refresh page on pc browser because chorus become unresponsive...


This forum uses Lukasz Tkacz MyBB addons.