Kodi Community Forum
Win Extra fanart not cycling - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Skins Support (https://forum.kodi.tv/forumdisplay.php?fid=67)
+---- Forum: Aeon Nox: Silvo (https://forum.kodi.tv/forumdisplay.php?fid=142)
---- Thread: Win Extra fanart not cycling (/showthread.php?tid=309605)

Pages: 1 2


Extra fanart not cycling - nprince - 2017-03-14

Hi

I use Media Centre Master to download metadata and from all my research the format it uses for extra fanart is correct - folder within movie folder named 'extrafanart' and jpg files called fanart1.jpg, fanart2.jpg. I have the skin setting radio buttons on for Fanart and Cycle Fanart, but there is only ever one image with no cycling.

I have tried different views - TriPanel, InfoWall, List etc etc but they all behave the same.

I have looked at the log file, but nothing related to fanart is there.

I've run out of things to look at.

Any ideas?

Thanks


RE: Extra fanart not cycling - mikeSiLVO - 2017-03-14

You need script.toolbox installed and then you will see a button called "Download extrafanart"

In my version I named it Cache cause that is is technically what it is doing...
Image


RE: Extra fanart not cycling - nprince - 2017-03-15

Thanks for the info Mike. That fixed the issue.

One more thing you may be able to help with - are you able to do anything to distinguish between bluray movies, dvd's and 3d blurays in the skin? For example, displaying a bluray cover like the physical bluray cover? Something like this:
http://tinypic.com/view.php?pic=73pkxe&s=5#.WMkm4oVOKUk

Thanks for your help


RE: Extra fanart not cycling - mikeSiLVO - 2017-03-16

In my version I added all that stuff Wink
Image


RE: Extra fanart not cycling - nprince - 2017-03-19

Hi Mike

That's what I am after. How do you add this? Is it another add-on, settings in the skin, or in the actual metadata that is downloaded?

Thanks
Neil


RE: Extra fanart not cycling - mikeSiLVO - 2017-03-21

Just install the skin and activate the necessary settings in the side menu for each view.

I added all that extra stuff but it comes with the caveat of needing to be setup in the correct way.


RE: Extra fanart not cycling - nprince - 2017-03-23

Hi Mike

Fairly new to all this, but it appears you have a modded version of the Aeon Nox skin. Is this the skin I need to install to get the settings as I can't seem to find anything in Aeon Nox. Is this the correct thread to install your modded version?

http://forum.kodi.tv/showthread.php?tid=210069

Thanks
Neil


RE: Extra fanart not cycling - mikeSiLVO - 2017-03-23

Yep, that's it.

In OG Nox 5 there is no cases so you would have to use a mod, modify the skin yourself, or try out my version and see if it works for you.

In the thread you linked to there is a FAQ in the second post or direct link in my signature.

Please read that and if it doesn't help, let me know in the skin thread and we'll get it sorted Wink


RE: Extra fanart not cycling - tehowell - 2019-03-31

(2017-03-14, 14:35)mikeSiLVO Wrote: You need script.toolbox installed and then you will see a button called "Download extrafanart"

In my version I named it Cache cause that is is technically what it is doing...
Image

Hi all,

I'm also seeing this issue of static movie backgrounds even though "extra-fanart" is selected.  Everything else I've tested so far looks good.  (limited to VIDEO_TS folders and a few MKVs)

Specs: 
Nvidia Shield Android TV (SysExp 7.2.3) / Kodi 18 Leia / Aeon Nox SILVO

Movie/fanart is set up this way; 

<SMB Share>
       |--- <movie> 
                  |--- <VIDEO_TS> / MKV 
                  |--- movie.xml
                  |--- fanart.jpg 
                  |--- <etrafanart> 
                  |           |--- fanart1.jpg 
                  |           |--- fanart2.jpg 
                 etc. 

As suggested above, I tried installing Toolbox Script (latest version).  However in my case, it didn't reveal the cache configuration option.  I still see only... 

Fanart  (which is enabled)
 - Extra-fanart  (which is enabled)
Fallback:Movies

Does anyone know what I'm missing?   

(Thanks in advance for not replying "brain power" or similar.)


RE: Extra fanart not cycling - Karellen - 2019-03-31

@tehowell

Do you have Artwork Beef installed?

Image


RE: Extra fanart not cycling - tehowell - 2019-03-31

(2019-03-31, 00:33)Karellen Wrote: @tehowell

Do you have Artwork Beef installed?

Image

No I don't. 
The description talks about downloading artwork.  Does this mean from my movie folders to the Kodi client?  
I use MediaCenterMaster to maintain the metadata in my movie folders, including artwork.  Will Artwork Beef change/add anything there?  Thanks for your help...


RE: Extra fanart not cycling - Karellen - 2019-03-31

It does both. If you do not have local artwork, then it will download it for you if you enable those options

You are using the extrafanart folder, but AeonNox:Silvo transferred to the new method of fanartx, so you need artwork beef as the "middle man" to convert from the old format to the new.

New method description... https://forum.kodi.tv/showthread.php?tid=337089


RE: Extra fanart not cycling - tehowell - 2019-03-31

Replying to my own post.  

I Googled and found a description of artwork beef.  Let me read through it and see if I can understand what will change.


RE: Extra fanart not cycling - tehowell - 2019-03-31

Wow, you're fast on the reply!  
I'm a newbie here and apparently not able to edit my posts.  I assume that will come later.  
I think I understand and will report back.


RE: Extra fanart not cycling - tehowell - 2019-03-31

(2019-03-31, 00:33)Karellen Wrote: @tehowell

Do you have Artwork Beef installed?

Image

How do I install Artwork Beef?  

I tried the typical method of using the File Manager to add a source for the RMRector repo at; 
https://github.com/rmrector/repository.rector.stuff/raw/master/latest/repository.rector.stuff-latest.zip

After adding the source, I'm unable to install the repo from the zip file.  Am I using the right url?  Is there another way?


This forum uses Lukasz Tkacz MyBB addons.