Kodi Community Forum
Android [Samsung] Kodi - nothing but loud noise after Android 7 update - Printable Version

+- Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Android (https://forum.kodi.tv/forumdisplay.php?fid=164)
+---- Thread: Android [Samsung] Kodi - nothing but loud noise after Android 7 update (/showthread.php?tid=312114)

Pages: 1 2 3 4 5 6 7


[Samsung] Kodi - nothing but loud noise after Android 7 update - wdintx - 2017-04-12

My Kodi worked perfectly on a Samsung Note 5 up until Sprint pushed an Android update yesterday. Now, Kodi 17.1 opens fine, looks fine, but as soon as it boots, loud noise is all you get for audio. It almost sounds like white noise, but also sounds like it could be some sort of audio file.

I've tried uninstalling and reinstalling Kodi both from the Google Play store and downloading and installing Kodi directly from the Kodi download page, same result.

Interestingly enough, I also tried downloading SPMC to see if it would work and it functions the same way. Everything looks good, but all you hear is loud noise that even turning the media volume to zero doesn't affect. It's apparent that whatever change they made in Android is affecting both XBMC/Kodi and the fork SPMC the same way.

Kodi 17.1 Git:20170320-797847d

Android 7.0
Security Patch March1, 2017
Baseband Version N920VPU3DQC5
Kernel Version 3.10.61-10809541[/php]


RE: Kodi opens but has nothing but loud noise after Android 7 update - Tinwarble - 2017-04-12

Was there a question in there? Or were you just reporting that you're having issues?

If your looking for help, then you would at least need to provide a Debug log (wiki).

Most likely though, it's probably something broken in the update (since it only started after) and you'll have to wait for Samsung/Sprint to push out a bug fix.


RE: Kodi opens but has nothing but loud noise after Android 7 update - kgb87 - 2017-04-16

Same here!
I think the problem is with Kodi 17+ it does not have to do with Samsung update... Kodi 16 is working fine!
Whenever you plug in the headphones in your device (note 5) there is a loud buzzing sound coming out from the headphones that will destroy your hearing... if you take them off and put them back in the device it is ok ... after you play smth then it starts again so you have to do the headphone plugin/out process again... when the playing stops again the big loud buzz...
I am sure that this is a Kodi bug with Android 7... this is destroying Kodi experience...
The same issue is with SPMC also as it is using Kodi 17.
Attached is the log as you requested to the user that started the thread... but it looks ok as far as i understand...

Thanks

https://ibb.co/hYtcqk


RE: Kodi opens but has nothing but loud noise after Android 7 update - Tinwarble - 2017-04-16

That is not a Debug log (wiki), <<<< follow the link.


RE: Kodi opens but has nothing but loud noise after Android 7 update - kgb87 - 2017-04-17

Please find below the debug log


Kodi Log


RE: Kodi opens but has nothing but loud noise after Android 7 update - Powerhouse - 2017-04-17

@kgb87 "The same issue is with SPMC also as it is using Kodi 17" You are wrong, SPMC is based off Kodi 16.


RE: Kodi opens but has nothing but loud noise after Android 7 update - Martijn - 2017-04-17

Samsung then probably fucked up whatever they put in the firmware


RE: Kodi opens but has nothing but loud noise after Android 7 update - mnemon07 - 2017-04-17

Martijn, you are probably right, as I am having the same issue with Samsung Galaxy S6 on Sprint. However, the only app affected appears to be Kodi. Also, according to some posts, BT headphones should work OK, unfortunately I can't verify this.


RE: Kodi opens but has nothing but loud noise after Android 7 update - Arkaic - 2017-04-18

I too have been having the same audio issues with wired headphones after the Android N update on both mine and my wife's phones. However, I can confirm that bluetooth headphones do still work correctly.


RE: Kodi opens but has nothing but loud noise after Android 7 update - kgb87 - 2017-04-18

Well, of course the issue is with the samsung update... however Kodi is the only app that is affected!
And in my opinion the application should adapt to the OS and devices not the device and the OS to the application...
So all samsung users are waiting for a Kodi update with the fix... or at least a workaround!!!

@Powerhouse if you use Kodi 16 is ok (but if you install plugins that are meant for kodi17 the player will crash)! And I tested SPMC from the playstore and it looks that it has updated to 17 and it has the issue


RE: Kodi opens but has nothing but loud noise after Android 7 update - fritsch - 2017-04-18

The log is funny.

Replace: https://github.com/xbmc/xbmc/blob/Krypton/xbmc/cores/AudioEngine/Sinks/AESinkAUDIOTRACK.cpp#L314 with:
Code:
(false && CJNIAudioManager::GetSDKVersion() >= 21 && m_format.m_channelLayout.Count() == 2)

That shitty device does not accept FLOAT output while it is supported by the OS.

Will prepare a workaround at home.


RE: Kodi opens but has nothing but loud noise after Android 7 update - fritsch - 2017-04-18

Build with kryptsamsung in name will appear here in some hours: http://mirrors.kodi.tv/test-builds/android/arm/


RE: Kodi opens but has nothing but loud noise after Android 7 update - fritsch - 2017-04-19

So?


RE: Kodi opens but has nothing but loud noise after Android 7 update - kgb87 - 2017-04-19

Everything looks ok for me (Samsung Note 5).

@fritsch thank you very much!


RE: Kodi opens but has nothing but loud noise after Android 7 update - Parzival419 - 2017-04-19

Yep, Works great for me as well ( Samsung Note 5) Thanks!!!!


This forum uses Lukasz Tkacz MyBB addons.