Kodi Community Forum
v17 [BUG] Frame skips caused by forced subtitles - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Video Support (https://forum.kodi.tv/forumdisplay.php?fid=264)
--- Thread: v17 [BUG] Frame skips caused by forced subtitles (/showthread.php?tid=315216)



[BUG] Frame skips caused by forced subtitles - jd17 - 2017-05-28

Hello!

I originally reported this bug in the LibreELEC AMLogic forum:
https://forum.libreelec.tv/thread/8100-bug-s905x-krypton-frame-skips-caused-by-burned-in-forced-subtitles/

However, it turns out this is a global Krypton bug, since I was able to reproduce it on a RPi2 and others reproduced it in Windows.


Issue description:
Certain types of forced subtitles from a Blu-ray cause one or two frame skips every time a new line of subtitle is displayed.

This does not happen in Jarvis builds.
It also does not happen in my Leia nightly build in Windows.

How to reproduce:
Play linked sample file from Avatar (Blu-ray remux) and monitor PlayerDebug for frame skips.

The subtitle in question seems to be a special (rare) kind, since it looks like it is part of the global English subtitle, which does not have a forced flag.
However, it is still being displayed automatically for foreign language parts.
The font is different then, too (quite exotic).

Sample:
https://ufile.io/u9u48

Log:
https://ufile.io/r2v42


RE: [BUG] Frame skips caused by forced subtitles - kszaq - 2017-05-28

FWIW I was able to reproduce the skips on Windows when using Intel HD 4000 (i7-3720QM) but not when using NVidia card.


RE: [BUG] Frame skips caused by forced subtitles - jd17 - 2017-05-30

Could someone look into this? Smile
Is there information missing that might be needed from me?

Thanks Team Kodi. Smile


RE: [BUG] Frame skips caused by forced subtitles - jd17 - 2017-06-06

Any insights yet? Smile


RE: [BUG] Frame skips caused by forced subtitles - jd17 - 2017-06-17

I have to admit that I feel a bit ignored... Tongue


RE: [BUG] Frame skips caused by forced subtitles - skyhigh69 - 2017-11-01

Is this issue being addressed?


RE: [BUG] Frame skips caused by forced subtitles - FernetMenta - 2017-11-02

I don't look into v17 issues anymore. Only v18


This forum uses Lukasz Tkacz MyBB addons.