Kodi Community Forum
Unable to load plugin in MP2 2.1.2 - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: PVR & Live TV Support (https://forum.kodi.tv/forumdisplay.php?fid=167)
+---- Forum: MediaPortal (https://forum.kodi.tv/forumdisplay.php?fid=171)
---- Thread: Unable to load plugin in MP2 2.1.2 (/showthread.php?tid=325116)



Unable to load plugin in MP2 2.1.2 - corvy - 2017-12-06

I am running a setup with some MP2 clients and some Kodi clients and the other day I upgraded from 1.18 to 2.1.2 but I am unable to get the Kodi plugin to load. After a lot of research I have enabled DEBUG logging and found the following:

Code:

[2017-12-06 07:20:45,076] [21883  ] [TVService] [DEBUG] - Exception while loading ITvServerPlugin instances: TVServerKodi.TVServerKodiPlugin
[2017-12-06 07:20:45,077] [21884  ] [TVService] [DEBUG] - System.InvalidCastException: Unable to cast object of type 'TVServerKodi.TVServerKodiPlugin' to type 'TvEngine.ITvServerPlugin'.
   ved TvService.PluginLoader.LoadPlugin(String strFile)
[2017-12-06 07:20:45,077] [21884  ] [TVService] [DEBUG] - Unable to cast object of type 'TVServerKodi.TVServerKodiPlugin' to type 'TvEngine.ITvServerPlugin'.
[2017-12-06 07:20:45,077] [21884  ] [TVService] [DEBUG] -    ved TvService.PluginLoader.LoadPlugin(String strFile)

I have tried to download the newest DLL again but to no avail. Not sure why it does not load. The version I use is v1.16.0.137 for MP2.1 final.


RE: Unable to load plugin in MP2 2.1.2 - corvy - 2017-12-06

Found this new DLL in another thread, downloading this fixed it! Big Grin 

https://www.dropbox.com/s/qrkys4spf1xm4yb/MediaPortal_2_1_2_TVServerKodi_plugin_rev138.zip?dl=1

Thanks!


This forum uses Lukasz Tkacz MyBB addons.