Kodi Community Forum
Unable to connect any client to MP2 TVServer - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: PVR & Live TV Support (https://forum.kodi.tv/forumdisplay.php?fid=167)
+---- Forum: MediaPortal (https://forum.kodi.tv/forumdisplay.php?fid=171)
---- Thread: Unable to connect any client to MP2 TVServer (/showthread.php?tid=326076)



Unable to connect any client to MP2 TVServer - xben - 2017-12-28

Hi,

I first tried nextPVR, was unstable to me...
Then I tried ArgusTV, was too slow to me...
Then I tried WMC, crashed all the time...

Now I'm trying MP2, but kodi does not connect to it, even on the same PC where the server is running.

The latest version of TVServerkodi plugin is installed on MP2. There is no error message on kodi. The shares (record/timeshift repositories) are accessible on both clients
 
I tried on Kodi Krypton 17.6 (android box) and Kodi Leia 18 (PC Win7, on which the server is running), with the same results : 

16:57:41.490 T:2556   DEBUG: AddOnLog: MediaPortal PVR Client: Connection state change (1 -> 7)
16:57:41.490 T:2556   DEBUG: AddOnLog: MediaPortal PVR Client: GetConnectionString:
16:57:41.490 T:2556   DEBUG: PVR - PVR::CPVRClient::cb_connection_state_change - state for connection '' on client 'MediaPortal PVR Client' changed from '1' to '7'
16:57:41.491 T:3952   DEBUG: Thread JobWorker start, auto delete: true
16:57:41.491 T:3952   ERROR: PVR - PVR::CPVRClients::ConnectionStateChange - invalid handler data
16:57:43.533 T:2556   DEBUG: AddOnLog: MediaPortal PVR Client: Connection state change (7 -> 1)
16:57:43.533 T:2556   DEBUG: AddOnLog: MediaPortal PVR Client: GetConnectionString:
16:57:43.533 T:2556   DEBUG: PVR - PVR::CPVRClient::cb_connection_state_change - state for connection '' on client 'MediaPortal PVR Client' changed from '7' to '1'
16:57:43.561 T:3952   ERROR: PVR - PVR::CPVRClients::ConnectionStateChange - invalid handler data


I tried everything... wifi, wired, disabling Firewall, using IP instead of hostname, disabling IPV6, rebooting, etc etc.. My setup worked fine with NPVR and Argus but using MP2 I can't even try it remotely.

Any idea before I throw this one to the garbage too?

Thanks!!


RE: Unable to connect any client to MP2 TVServer - xben - 2017-12-28

SOLVED

I posted my issue in mediaportal forum and it looks like MP2.1.3 does not work with the most up to date tvserverkodi plugin! I just had to install the MP2.1 final version and it worked right away!


This forum uses Lukasz Tkacz MyBB addons.