Kodi Community Forum
v18 PVR deinterlacing issue - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Video Support (https://forum.kodi.tv/forumdisplay.php?fid=264)
--- Thread: v18 PVR deinterlacing issue (/showthread.php?tid=326616)

Pages: 1 2 3 4 5


RE: PVR deinterlacing issue - maxtherabbit - 2018-09-02

Hardware deinterlacing is working for me with this build. The stutter is still there. It's like the picture "jumps" horizontally once per second.

I  tried with hardware acceleration disabled. Deinterlacing only works if I turn it off and on again. However there is no stutter when playing the video.


RE: PVR deinterlacing issue - fritsch - 2018-09-02

Which one of those? There are two builds.


RE: PVR deinterlacing issue - maxtherabbit - 2018-09-02

(2018-09-02, 11:44)fritsch Wrote: Which one of those? There are two builds.
I was talking about Build1 (deint3).

I now tried Build2 (deint4) and it is working well. It looks as good as KodiSetup-20180807-164db1c2-master-x64. Deinterlacing works and no stuttering.


RE: PVR deinterlacing issue - fritsch - 2018-09-02

Lol :-) In short: I wait for other testers.

Cause Build1 removes the fernetmenta commit. Build2 (deint4) adds it back in and removes the "smooth playback" commit by @afedchin - I really wonder that deint3 does _anything_ at all different in comparison to current nightly. According to your testing: https://github.com/xbmc/xbmc/pull/14278 this breaks deinterlacing, but the commit removed from deint3 also "fixes" something :-) while it does not harm in deint4.

Curious on the results of the others.


RE: PVR deinterlacing issue - axlt2002 - 2018-09-02

(2018-09-02, 09:07)fritsch Wrote: Please try the build resulting from here: http://jenkins.kodi.tv/job/WIN-64/6521/ it will land here: http://mirrors.kodi.tv/test-builds/windows/win64/ and has deint3 in its name

Edit:
Build1: http://mirrors.kodi.tv/test-builds/windows/win64/KodiSetup-20180902-7dace075-deint3-x64.exe
Build2: http://mirrors.kodi.tv/test-builds/windows/win64/KodiSetup-20180902-d7ff26f8-deint4-x64.exe

Any of those builds working?
I will test the "deint4" this evening and report back to this thread as soon as possible. Thanks for now.

Just for common understanding: did you work on that builds?


RE: PVR deinterlacing issue - fritsch - 2018-09-02

The builds are simple: deint3 removes fernetmenta's commit; deint4 removes afedchin's commit and our friends jenkins has built it. No really much work, just 10 seconds git foo.


RE: PVR deinterlacing issue - axlt2002 - 2018-09-02

Got it. So I will test both of them...

Keep in touch!


RE: PVR deinterlacing issue - axlt2002 - 2018-09-02

I'm sorry to report back that both builds are not working for me...

I have also tried the KodiSetup-20180807-164db1c2-master-x64 build, but the problem is there too.

I'm experiencing this with live TV using Argus TV addon but I don't think the issue is due to it.

May be I can post a log for both builds?


RE: PVR deinterlacing issue - fritsch - 2018-09-02

Okay - that's what I expected :-) and this is why I made the builds. Both commits are perfectly fine and have no influence on deinterlacing. Now what I wonder: Why the other guy before you says: deint4 works, deint3 also "works" but "nightly" does not :-) You see, two testers 3 opinions.


PVR deinterlacing issue - popy - 2018-09-02

Not tested the builds but deinterlacing with dxva2 was also broken on my last tests on early August build, so the commits should have no impact. As you already stated.
With sw decoding and my workaround, deinterlacing is working with DVBViewer pvr and other media.

But DXVA is currently broken on my 1030 nvidia. Stuttering on pvr with no refresh rate change and stuttering after refresh rate change to 24hz with 24 hz media.
Yeah, that's the OSD in foreground thing...


RE: PVR deinterlacing issue - axlt2002 - 2018-09-02

Hi guys!

So, the only thing I can do is to help the developers by providing some logs for live TV using Argus TV PVR addon:
 
  • First log: the TV channel playback starts without issues but after few seconds Kodi is no more able to deinterlace correctly the video
  • Second log: same as above but after the issue started, I went to the video settings, disabled and enabled the DVXA deinterlacing method and, after that, everything works ok

In the second case, if i change the TV channel, the issue comes back.

Hope the logs can be useful.

Alex

P.S.: I wasn't able to use pastebin since the site was freezing when copying the logs...


RE: PVR deinterlacing issue - maxtherabbit - 2018-09-02

Sorry for causing confusion with my previous posts. I got mixed up while testing with diiferent DXVA2 settings.

After some more testing with DXVA2 ON deinterlacing seems to work on August nightly builds and both of the test builds.

With DXVA2 turned OFF deinterlacing didn't work at first, but I got it working by turning deinterlacing off and on again and selecting "Set as default for all media" in video settings.

The stuttering video seems to be a separate issue that started to appear for me since KodiSetup-20180808-f25baa5f-master-x64. The first test build also had the same stuttering while the second build didn't. Having an overlay like the main menu on top of the video seems to reduce the stutter.


RE: PVR deinterlacing issue - axlt2002 - 2018-09-03

(2018-09-02, 22:32)maxtherabbit Wrote: After some more testing with DXVA2 ON deinterlacing seems to work on August nightly builds and both of the test builds.
(2018-09-02, 22:32)maxtherabbit Wrote: With DXVA2 turned OFF deinterlacing didn't work at first, but I got it working by turning deinterlacing off and on again and selecting "Set as default for all media" in video settings.
 Hi maxtherabbit!

One question for clarification: ​​​​​​to which DXVA2 option are you referring to? Is the one that can be found in the video settings while a video is playing? If yes, I have just a DXVA option (without 2) and it works completely the opposite as you described...

As described in my previous post, if it is ON (default setting), the deinterlacing doesn't work; if I turn it OFF and agian ON, the deinterlacing starts to work properly (until I change the TV channel).

Have a great day!

Alex


RE: PVR deinterlacing issue - maxtherabbit - 2018-09-03

(2018-09-03, 09:05)axlt2002 Wrote:
(2018-09-02, 22:32)maxtherabbit Wrote: After some more testing with DXVA2 ON deinterlacing seems to work on August nightly builds and both of the test builds.
(2018-09-02, 22:32)maxtherabbit Wrote: With DXVA2 turned OFF deinterlacing didn't work at first, but I got it working by turning deinterlacing off and on again and selecting "Set as default for all media" in video settings.
 Hi maxtherabbit!

One question for clarification: ​​​​​​to which DXVA2 option are you referring to? Is the one that can be found in the video settings while a video is playing? If yes, I have just a DXVA option (without 2) and it works completely the opposite as you described...

As described in my previous post, if it is ON (default setting), the deinterlacing doesn't work; if I turn it OFF and agian ON, the deinterlacing starts to work properly (until I change the TV channel).

Have a great day!

Alex  
 It's in Settings -> Player -> Allow hardware acceleration - DXVA2


RE: PVR deinterlacing issue - axlt2002 - 2018-09-03

(2018-09-03, 09:37)maxtherabbit Wrote:
(2018-09-03, 09:05)axlt2002 Wrote:
(2018-09-02, 22:32)maxtherabbit Wrote:  
 It's in Settings -> Player -> Allow hardware acceleration - DXVA2   
Thanks for the clarification.

The point is that DXVA2 is ON by default in Kodi and in that case deinterlacing is not working for me. So it just surprises me when you write that with DXVA2 ON deinterlacing is working...it is really a weird issue...


This forum uses Lukasz Tkacz MyBB addons.