Kodi Community Forum
Release Amazon Echo Alexa Video Skill for Kodi - Printable Version

+- Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Supplementary Tools for Kodi (https://forum.kodi.tv/forumdisplay.php?fid=116)
+--- Thread: Release Amazon Echo Alexa Video Skill for Kodi (/showthread.php?tid=327562)



RE: Amazon Echo Alexa Video Skill for Kodi - melons2 - 2018-09-14

I went into Alexa from the website and un-linked all devices to start over. When I go into device discovery it says that it could not find any device to link? I have a house full of them, a bridge, and accessory devices (ligtbulbs, door locks, etc.) they all work and communicate.
Should I completely start over from zero and reinstall everything?

Didn't make the start over moves pondered above....... suddenly works on two different instances that quit working yesterday off and on and again today.......no rhyme or reason?

EDIT:
Today 9/14/2018 9am cst, it has gone back to: Connected / Disconnected.


RE: Amazon Echo Alexa Video Skill for Kodi - tkislan - 2018-09-14

(2018-09-14, 00:12)melons2 Wrote: I went into Alexa from the website and un-linked all devices to start over. When I go into device discovery it says that it could not find any device to link? I have a house full of them, a bridge, and accessory devices (ligtbulbs, door locks, etc.) they all work and communicate.
Should I completely start over from zero and reinstall everything?

Didn't make the start over moves pondered above....... suddenly works on two different instances that quit working yesterday off and on and again today.......no rhyme or reason?

EDIT:
Today 9/14/2018 9am cst, it has gone back to: Connected / Disconnected.
Could you try this new version?
https://www.dropbox.com/s/v6iktl1rkln5w9g/plugin.video.kodiconnect-0.1.20.zip?dl=1

If it still doesn't help, it would help if you could enable debug logs in Kodi, and send me the logs
cc @hslansky


RE: Amazon Echo Alexa Video Skill for Kodi - hslansky - 2018-09-14

(2018-09-14, 16:32)tkislan Wrote:
(2018-09-14, 00:12)melons2 Wrote: I went into Alexa from the website and un-linked all devices to start over. When I go into device discovery it says that it could not find any device to link? I have a house full of them, a bridge, and accessory devices (ligtbulbs, door locks, etc.) they all work and communicate.
Should I completely start over from zero and reinstall everything?

Didn't make the start over moves pondered above....... suddenly works on two different instances that quit working yesterday off and on and again today.......no rhyme or reason?

EDIT:
Today 9/14/2018 9am cst, it has gone back to: Connected / Disconnected.
Could you try this new version?
https://www.dropbox.com/s/v6iktl1rkln5w9g/plugin.video.kodiconnect-0.1.20.zip?dl=1

If it still doesn't help, it would help if you could enable debug logs in Kodi, and send me the logs
cc @hslansky   
Tried the new version and still having the same problem, it is very sporadic.  Link to logfile: https://pastebin.com/2UYTaAyj


RE: Amazon Echo Alexa Video Skill for Kodi - tkislan - 2018-09-14

(2018-09-14, 20:55)hslansky Wrote:
(2018-09-14, 16:32)tkislan Wrote:
(2018-09-14, 00:12)melons2 Wrote: I went into Alexa from the website and un-linked all devices to start over. When I go into device discovery it says that it could not find any device to link? I have a house full of them, a bridge, and accessory devices (ligtbulbs, door locks, etc.) they all work and communicate.
Should I completely start over from zero and reinstall everything?

Didn't make the start over moves pondered above....... suddenly works on two different instances that quit working yesterday off and on and again today.......no rhyme or reason?

EDIT:
Today 9/14/2018 9am cst, it has gone back to: Connected / Disconnected.
Could you try this new version?
https://www.dropbox.com/s/v6iktl1rkln5w9g/plugin.video.kodiconnect-0.1.20.zip?dl=1

If it still doesn't help, it would help if you could enable debug logs in Kodi, and send me the logs
cc @hslansky    
Tried the new version and still having the same problem, it is very sporadic.  Link to logfile: https://pastebin.com/2UYTaAyj 
Thanks, that actually helped a lot .. I've prepared a new version (hopefully last one). It should fix the issue for you
I didn't catch this, as it is related to slower connection to the server.

https://www.dropbox.com/s/2l8rqkxxcbqsxa0/plugin.video.kodiconnect-0.1.21.zip?dl=1


RE: Amazon Echo Alexa Video Skill for Kodi - hslansky - 2018-09-15

(2018-09-14, 21:03)tkislan Wrote:
(2018-09-14, 20:55)hslansky Wrote:
(2018-09-14, 16:32)tkislan Wrote: Could you try this new version?
https://www.dropbox.com/s/v6iktl1rkln5w9g/plugin.video.kodiconnect-0.1.20.zip?dl=1

If it still doesn't help, it would help if you could enable debug logs in Kodi, and send me the logs
cc @hslansky    
Tried the new version and still having the same problem, it is very sporadic.  Link to logfile: https://pastebin.com/2UYTaAyj    
Thanks, that actually helped a lot .. I've prepared a new version (hopefully last one). It should fix the issue for you
I didn't catch this, as it is related to slower connection to the server.

https://www.dropbox.com/s/2l8rqkxxcbqsxa0/plugin.video.kodiconnect-0.1.21.zip?dl=1   
I hate to be the bearer of bad news, but alas this version is failing as well (log below).  However, the connected/disconnected messages are spaced further apart, as opposed to rapid succession, and eventually it does connect.  Please let me know if you need any additional information to try and resolve the problem.

https://pastebin.com/d2rn0Lb1


RE: Amazon Echo Alexa Video Skill for Kodi - tratzum - 2018-09-16

Is there a chance I could be added to try this out. It seems really fun and intereating to be able to control KODI through Alexa.


RE: Amazon Echo Alexa Video Skill for Kodi - melons2 - 2018-09-18

OK, here is a new one.....one setup(instance) is working fine the other one in a different room is doing the "Connected / Disconnect" error. Strange.
I'm on LEIA nightly 09/16/18 Windows 10, new dell cpu's and a gig Ethernet connection in both rooms........?


RE: Amazon Echo Alexa Video Skill for Kodi - karajorma - 2018-09-19

I'd also like to try this out but I can't even figure out how to contact tkislan to ask for permission!


RE: Amazon Echo Alexa Video Skill for Kodi - karajorma - 2018-09-20

Seriously. Whenever I try to send a PM it tells me I don't have permission.


RE: Amazon Echo Alexa Video Skill for Kodi - tjay260476 - 2018-09-20

You need time spent on the forum and a number of posts before PMing members, please don’t spam post just to get PMs. This is an anti-spam measure.


RE: Amazon Echo Alexa Video Skill for Kodi - karajorma - 2018-09-20

Yeah, I figured that was the case. But if that's so, how can I contact tkislan then? The github page doesn't appear to have any contact details either.


RE: Amazon Echo Alexa Video Skill for Kodi - Mario S. - 2018-09-23

Can you invite me please tkislan I have send you an pm with my email address.


RE: Amazon Echo Alexa Video Skill for Kodi - hslansky - 2018-09-25

(2018-09-15, 03:37)hslansky Wrote:
(2018-09-14, 21:03)tkislan Wrote:
(2018-09-14, 20:55)hslansky Wrote: Tried the new version and still having the same problem, it is very sporadic.  Link to logfile: https://pastebin.com/2UYTaAyj    
Thanks, that actually helped a lot .. I've prepared a new version (hopefully last one). It should fix the issue for you
I didn't catch this, as it is related to slower connection to the server.

https://www.dropbox.com/s/2l8rqkxxcbqsxa0/plugin.video.kodiconnect-0.1.21.zip?dl=1     
I hate to be the bearer of bad news, but alas this version is failing as well (log below).  However, the connected/disconnected messages are spaced further apart, as opposed to rapid succession, and eventually it does connect.  Please let me know if you need any additional information to try and resolve the problem.

https://pastebin.com/d2rn0Lb1  
Any update on the connect/disconnect issue?


RE: Amazon Echo Alexa Video Skill for Kodi - MoshePupkin - 2018-09-29

Does it actually work? Everything I've tried so far didn't...


RE: Amazon Echo Alexa Video Skill for Kodi - tkislan - 2018-09-30

(2018-09-25, 19:47)hslansky Wrote:
(2018-09-15, 03:37)hslansky Wrote:
(2018-09-14, 21:03)tkislan Wrote: Thanks, that actually helped a lot .. I've prepared a new version (hopefully last one). It should fix the issue for you
I didn't catch this, as it is related to slower connection to the server.

https://www.dropbox.com/s/2l8rqkxxcbqsxa0/plugin.video.kodiconnect-0.1.21.zip?dl=1     
I hate to be the bearer of bad news, but alas this version is failing as well (log below).  However, the connected/disconnected messages are spaced further apart, as opposed to rapid succession, and eventually it does connect.  Please let me know if you need any additional information to try and resolve the problem.

https://pastebin.com/d2rn0Lb1   
Any update on the connect/disconnect issue? 
Sorry, I didn't have much time in past few days.
But I will address this issue today. And hopefully find a fix for this regression


This forum uses Lukasz Tkacz MyBB addons.