Kodi Community Forum
i must be stupid - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Supplementary Tools for Kodi (https://forum.kodi.tv/forumdisplay.php?fid=116)
+---- Forum: Ember Media Manager (https://forum.kodi.tv/forumdisplay.php?fid=195)
---- Thread: i must be stupid (/showthread.php?tid=327585)



i must be stupid - thea - 2018-01-25

Wondering how to get this program to work. Trying to scrape collection on latest alpha; program hits an error like I/ recovery not valid , it freezes than shuts down loosing 15 hours of scrape with no results. How do you get this to occasional save its progress as it goes along; at this rate it will never get bye the scrape mode. sighs......


i must be stupid - mchp92 - 2018-01-25

Perhaps you should be more specific abt your specific situation
Which kodi version do you run
How exactly did you define your media sources
How do you connect to your media sources
Are u using correct connect credetials
Paste your log file and link it to here
Etc etc


RE: i must be stupid - Klojum - 2018-01-25

(2018-01-25, 04:34)thea Wrote: Wondering how to get this program to work. Trying to scrape collection on latest alpha; program
Perhaps you should start with a stable version (v17.6, the last stable one for now) of the Kodi application. The v18 version development has started not that long ago, so lots of errors/bug are bound to happen. It's not the best choice if you want to get to know a new application. Start with something that is proven to be okay. Smile


RE: i must be stupid - DanCooper - 2018-01-25

I think he talks about Ember and not Kodi...


RE: i must be stupid - thea - 2018-01-25

yes I'm trying out ember, is there a stable version?


RE: i must be stupid - Fail$tyle420 - 2018-01-25

Use latest alpha from: https://forum.kodi.tv/showthread.php?tid=316733

It's stable and works great.  We don't know what your settings are and that may be an issue.  It could be as simple as a memory issue (downloading too many fanarts) since you are saying it's taking 15 hours to scrape.  That's a huge collection!  Does everything work correctly when you scrape a single movie?  If so, try scraping 50 movies.  If that works, then move up to 100 movies.  You could also upload your profile's settings files to a site and link here, maybe Dan would be willing to download them and check them on his end?


RE: i must be stupid - DanCooper - 2018-01-25

(2018-01-25, 04:34)thea Wrote: it freezes than shuts down loosing 15 hours of scrape with no results

It's not really loosed. The problem is, that SQLite uses a temporary database while multiple scraping. If Ember hangs or crash while scraping, it's not always possible to write the temp data to the final database. So after restart the database shows the old state, even all (or partially) movie are scraped and the local NFO and images are created. At this point you can simply reload all movies with Tolls => Reload all movies to get the real state of your files.

I know that's a crappy solution, but soon I'll start the rewrite that part so that the database will be saved even if Ember run in a complete crash.


RE: i must be stupid - thea - 2018-01-25

Ok the link, you provided works and this version works as well for 1 movie. The version I had tried was listed in the first post of the main thread. Now I'll try throwing it at 1 of my network drives. Its just I'm starting to look beyond meta/browser for better tv scraping. maybe this will be the one.


This forum uses Lukasz Tkacz MyBB addons.