Kodi Community Forum
Solved No year or cast after scraping movies - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Development (https://forum.kodi.tv/forumdisplay.php?fid=32)
+--- Forum: Scrapers (https://forum.kodi.tv/forumdisplay.php?fid=60)
--- Thread: Solved No year or cast after scraping movies (/showthread.php?tid=335245)



No year or cast after scraping movies - speedracerx0509 - 2018-09-05

Greetings.  Been a Kodi user for many years.  Recently, when I have been scraping my movies with TMDb scraper, half of the movies are without year or cast.  If I go into the movie information and refresh manually, in pops in the year and cast.  Any ideas why this is happening?  I've tried other scrapers and the same thing happens.


RE: No year or cast after scraping movies - Karellen - 2018-09-05

Debug Log.

Also check you are using the latest scraper. Have no idea what version Kodi you are using, so you need to check scraper version for yourself.

A lot to be said for providing proper info first up.


RE: No year or cast after scraping movies - speedracerx0509 - 2018-09-06

Using Kodi 17.6 and The Movie Database 5.1.3
debug file   https://paste.kodi.tv/cacikokihi


RE: No year or cast after scraping movies - Karellen - 2018-09-06

Thanks

A quick look at your log reveals you are using nfo files for many of the movies. When nfo files are detected, the scraper does not work. The scanner simply scans the data from the nfo file into the library.

Check your nfo files to ensure they contain the information that you state is missing.

DEBUG: GetMovieId (smb://DESKTOP/Movies 8/Atomic.Blonde.2017.1080p.BluRay.X264-AMIABLE[rarbg]/Atomic.Blonde.2017.1080p.BluRay.X264-AMIABLE.mkv), query = select idMovie from movie where idFile=462
DEBUG: CSMBFile::Open - opened smb://DESKTOP/Movies 8/Atomic.Blonde.2017.1080p.BluRay.X264-AMIABLE[rarbg]/Atomic.Blonde.2017.1080p.BluRay.X264-AMIABLE.nfo, fd=10000



RE: No year or cast after scraping movies - speedracerx0509 - 2018-09-06

Interesting.  That is probably it.  I'm going to experiment a bit with this.  Thanks Karellen!


RE: No year or cast after scraping movies - speedracerx0509 - 2018-09-07

Erased all my nfo's and re created them via a fresh export and all is well.  Smile


RE: No year or cast after scraping movies - Karellen - 2018-09-07

Great to hear. Smile I'll mark this is as solved.


No year or cast after scraping movies - Karellen - 2018-09-07

Thread marked solved.


This forum uses Lukasz Tkacz MyBB addons.