Kodi Community Forum
[split] [BUG] Local addresses don't get resolved when a proxy is configured - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Discussions (https://forum.kodi.tv/forumdisplay.php?fid=222)
+--- Forum: Off-Topic (https://forum.kodi.tv/forumdisplay.php?fid=113)
--- Thread: [split] [BUG] Local addresses don't get resolved when a proxy is configured (/showthread.php?tid=336366)



[split] [BUG] Local addresses don't get resolved when a proxy is configured - corvy - 2018-10-11

I have the same issue. I use a proxy server as a jump box for VPN and that works just fine, but it also captures all LAN connections. The proxy does direct connection to the LAN device but all streams from PVR, movie library etc all go first to the proxy, then to the device. This adds another hop to the stream, and although it works fine, it is far from ideal to add this extra step. Especially for PVR streaming I find it is much more stable with direct connection.
My thinking is to add a button like this:

Image

That would help alot! If anyone know a “hack” on console to achieve the same I welcome that approach too. I am not afraid to SSH in and set this setting manually somewhere.

A console "hack" is also welcome!


RE: [split] [BUG] Local addresses don't get resolved when a proxy is configured - Klojum - 2018-10-11

Posts related to VPN are to be held in the Off-topic section as per our VPN policy (wiki).

Post split off and moved.


RE: [split] [BUG] Local addresses don't get resolved when a proxy is configured - corvy - 2018-10-12

Ok I understand but this is not a VPN question, rather a Proxy one. Just strike what the proxy is used for, but same issue in any case. Smile


This forum uses Lukasz Tkacz MyBB addons.