Kodi Community Forum
v18 Option to hide 'connection lost' message removed in Kodi 18. Why? - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: PVR & Live TV Support (https://forum.kodi.tv/forumdisplay.php?fid=167)
--- Thread: v18 Option to hide 'connection lost' message removed in Kodi 18. Why? (/showthread.php?tid=338069)



Option to hide 'connection lost' message removed in Kodi 18. Why? - jhschulz - 2018-12-04

Hi,

I have three Kodi boxes around the house and one 'server' with TVHeadend and Emby. The server is not running all time, because most of the time it would only consume energy without being used. The server shuts down itself if no longer used and is started only on demand via Wake-On-RTC for timer recordings and via WOL if one of the Kodi boxes is started.

The server needs a few seconds to be up and running, so at the time the Kodi PVR client initially tries to access the PVR backend, it is not yet running. As a result, a 'no connection' error message is displayed. A few seconds later the backend is available and the client successfully connects.

Before Kodi 18 there was an option in the PVR settings to disable the error message, and I used it to get rid of the message. In Kodi 18 this option has been removed and now I always get this annoying error message that irritates everybody else in the house ("Look fast, something is broken, there was an error message!!!")

Why has this option been removed? Is there another way now to hide this message?


RE: Option to hide 'connection lost' message removed in Kodi 18. Why? - jhschulz - 2018-12-06

Nobody knows why this option has been removed or how to hide this annoying error message?


RE: Option to hide 'connection lost' message removed in Kodi 18. Why? - jhschulz - 2018-12-28

As nobody answers my question, I did some research myself.

The Kodi v18 changelog contains the following entry under "Live TV and PVR":
Quote:Removed setting 'hide connection lost warning'

If I see it right, it has been removed by @ksooo with the following comment:
Quote:Cleanup. We do not need this setting anymore since we have "async connect" for pvr client addons (introduced with krypton), because we do no longer try to load addons in a (potential endless) loop.

I don't understand this comment, but it looks to me as if this option had different reasons. One reasons seems to be gone, but the other reason (the reason why I used it) is still there, so we still need this option! Or a different way to hide the error message if the PVR backend server is not yet running within the first x seconds after kodi has started.


Option to hide 'connection lost' message removed in Kodi 18. Why? - ksooo - 2018-12-29

The setting will not return, sorry.

The pop-up appears for a reason. As long as the server is not up, your family crying there is something wrong is absolutely right. As long as the server is not up they will not be able to watch Live TV or use any other feature provided by your TV server. Tell that your family, please.


RE: Option to hide 'connection lost' message removed in Kodi 18. Why? - jhschulz - 2018-12-30

Yes, you are right, usually the error message has a reason and completely hide this message is not a perfect solution. But if this message pops up at (nearly) every start of Kodi just because the TV server needs (only) 3-4 more seconds to be up and running, the message is not really useful and the option to hide this message is better than nothing.

I could tell my family what this error message is about, but all they will understand is: "Ignore the error message that pops up at the start of Kodi". As a result, this message will be completely useless (but still annoying). And even more, they will ignore any error message that may pop up - not a good idea! That's why I decided to hide this message in the past, even if that's not perfect either.

Of course, there are other solutions possible the solve the problem of a server not being available immediately at the start of Kodi. But they are more complex to implement than to bring back something that already existed. As I already wrote, there could be an option to hide the "no connection" message within the first x seconds. So, in case the TV server only needs a few more seconds until it is available, but will be available within the first x seconds, there will be no (useless) error message. But if there is a real problem (server not available at all), there will be an error message (after x seconds). That would be perfect, but of course it is more complex to implement, that's why I didn't ask for it initially.


RE: Option to hide 'connection lost' message removed in Kodi 18. Why? - wsnipex - 2018-12-30

why not just delay the startup of kodi until the tvserver is running?


Option to hide 'connection lost' message removed in Kodi 18. Why? - ksooo - 2018-12-30

Maybe increase connection timeout value in pvr.hts settings?


RE: Option to hide 'connection lost' message removed in Kodi 18. Why? - jhschulz - 2019-01-02

Increasing the connection timeout value in pvr.hts settings has no effect. No matter what value I set there, the "no connection" error message always pops up 2-3 seconds after Kodi has started.

I decided to delay the startup of Kodi now, until the server is available. This is not perfect, because that way the total startup takes longer than before (first wait until the server is up, than start Kodi and wait until Kodi is started), but it has the advantage that everything is up and running as soon as Kodi is started.

To do this, I use the following autostart.sh (LibreELEC) now:
Quote: #!/bin/sh

# Check if server is running
ping -c1 -w1 servername >/dev/null 2>&1

# If not running...
if [ $? -ne 0 ]
then
   # ...wake up server
   ether-wake -b xx:xx:xx:xx:xx:xx >/dev/null 2>&1

   # Wait 5 seconds
   sleep 5

   # Check and wait up to 20 seconds until server is running
   ping -c1 -w20 servername >/dev/null 2>&1
fi

The script only waits until a ping to the server is successful, and not until the services (tvheadend and emby) are running, because the time Kodi needs to start (after the script ended) is long enough for the services to start.