Kodi Community Forum
Emulator support on Linux? - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Game support (https://forum.kodi.tv/forumdisplay.php?fid=292)
--- Thread: Emulator support on Linux? (/showthread.php?tid=340320)

Pages: 1 2


Emulator support on Linux? - bgemmill - 2019-02-04

Hello all,

I'm trying to make game support go on ubuntu bionic, and it looks like the PPA doesn't contain any emulator cores:
https://launchpad.net/~team-xbmc/+archive/ubuntu/ppa?field.series_filter=bionic

For reference, it looks like a bunch are available for other platforms:
http://mirrors.kodi.tv/addons/leia/

kodi-game-libretro in particular appeared to have a debian packaging issue since resolved, thanks @wsnipex:
https://github.com/xbmc/xbmc/issues/15366
https://github.com/kodi-game/game.libretro/tree/master/debian

That clued me in to looking for other /debian/ folders in the emulator core directories but I couldn't find any. For example, PSX:
https://github.com/kodi-game/game.libretro.beetle-psx

Additionally, looking at the repository chain from the main kodi repo, only a few items are referenced from kodi-game at all:
https://github.com/xbmc/xbmc/blob/master/cmake/addons/bootstrap/repositories/binary-addons.txt
https://github.com/xbmc/repo-binary-addons

Looking at one of the few that did make the reference, 2048, it doesn't appear to have ubuntu as a build target:
https://github.com/xbmc/repo-binary-addons/blob/master/game.libretro.2048/game.libretro.2048.txt
https://github.com/kodi-game/game.libretro.2048/blob/master/Jenkinsfile

Is this all expected?

I'd love to test this out, and wanted to check if I'm going about this the wrong way by using ubuntu.


RE: Emulator support on Linux? - wsnipex - 2019-02-04

yes, packaging is missing for game addons.
https://github.com/fetzerch/kodi-game-scripting/pull/55#issuecomment-460053733 should remedy that


RE: Emulator support on Linux? - DaVu - 2019-02-06

@amzoun95 

Could you please do not post links to sites we have banned from our forums?

Please consider reading the forum rules you have accepted by joining our forums if you haven't done that yet.

Thanks in advance.


RE: Emulator support on Linux? - zachmorris - 2019-02-16

I see addons in the nightly-ppa. Just wondering if thats where they will live in general? If so, I'll add that to the 'Getting Started' post.


RE: Emulator support on Linux? - wsnipex - 2019-02-16

once they got some testing I'll also copy them to the stable ppa


RE: Emulator support on Linux? - haraldini - 2019-02-20

Looks like half of them are failing to build


RE: Emulator support on Linux? - arkpoah - 2019-02-24

Any update ?
It would great to have these packages !  Big Grin


RE: Emulator support on Linux? - disaacso - 2019-02-24

wintermute0110 has written a script that works very well to build them on your own.  he has very clear instructions on his git page, it takes ~15 minutes to build most of the emulators, mame not included.  Tips from when I built:

1) you don't have to build kodi, but you do have to import kodi-source.  When you do import kodi-source you must do it as user kodi by typing "su kodi" in the terminal window, it will then ask for your password which hopefully you remember.

2) After that return to your normal user, "su 'user name here'"

3) Once everything is built you will need to copy the *emulator.so files from the build folder to /usr/lib/x86_64-linux-gnu/kodi/addons


RE: Emulator support on Linux? - arkpoah - 2019-02-24

nice, thanks !


RE: Emulator support on Linux? - wsnipex - 2019-02-24

or you install them from the nightly ppa and help testing


RE: Emulator support on Linux? - arkpoah - 2019-02-25

It is what I done but as haraldini said, lots of them have failed to build


RE: Emulator support on Linux? - disaacso - 2019-02-25

(2019-02-24, 23:02)wsnipex Wrote: or you install them from the nightly ppa and help testing
 I looked at this route but it seems like most of the emulators failed to build.  It looks like there was a missing dependency, but you would know much more than I would about that.  I installed virtual-jaguar and fbalpha from ppa and they work well in the little bit I've played around.  For snes9x and beetle-psx I had to build on my own.  I can report these findings on github if you like.


RE: Emulator support on Linux? - arkpoah - 2019-02-25

For my part I had a big memory leak when testing fbalpha with mortal kombat : Memory graph


RE: Emulator support on Linux? - arkpoah - 2019-02-25

same issue with anothers emulators, should be my system ^^


RE: Emulator support on Linux? - htpcero - 2019-03-25

Checking both Unstable and Stable PPAs (@wsknippex) , par example

https://launchpad.net/%7Eteam-xbmc/+archive/ubuntu/unstable/+index?batch=75&memo=75&start=75

I cant find any emulator at all there. Am I looking for instalable emulators in the wrong place? Is there another PPA for emulators that people are using?

This is for Bionic running Kodi 18.1 (stable)


This forum uses Lukasz Tkacz MyBB addons.