Kodi Community Forum
First time adding music to kodi issues. - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Music Support (https://forum.kodi.tv/forumdisplay.php?fid=263)
--- Thread: First time adding music to kodi issues. (/showthread.php?tid=341968)



First time adding music to kodi issues. - mxlance - 2019-03-13

I have been using Kodi for video and live TV since 2012.
This is the First time adding music to kodi.

So i am doing a test run and it is not working.
I am sure this is operator error, need some help sorting this out.

Kodi 18.1 on Kubuntu 18.10
I used Picard to tad 3 Artists as follows:
Kodi Music
    'Til Tuesday
        Voices Carry
            01-'Til Tuesday-Love in a Vacuum.mp3  
    10cc
        I'm Not In Love: The Essential 10cc
            CD1
                1-01-10cc-I'm Not in Love.flac
                1-02-10cc-Life Is a Minestrone.flac
    David Gray
        Gold in a Brass Age

I added the source >Kodi Music, to kodi which scanned in.
The album art and artist name appears in the library but no files/songs.

when i try to view anything in the library i get:
Library update-Music library needs to rrescan tags from files. Yes or No
Library update-Fetch additional information for albums and artists? Yes or No

The odd thing is everything shows fine if i go to files.

Log:
https://paste.kodi.tv/ipinuxadoz

thank you


RE: First time adding music to kodi issues. - DaveBlake - 2019-03-13

"The album art and artist name appears in the library but no files/songs" - well that is unusual. Having tagged using Picard then generally tags should be OK, and the fact that you see albums and artists means tha Kodi as successfully derived these from the tags.

Lots of errors in the log, but most relate to PVR  - I know nothing about that and it doesn't relate to your music issue, but it might be something else you want to pursue (with someone else). I can also see Embly mentioned, another thing I know nothing about but that could be contributing depending on where your music files are located.

Errors like
Code:
ERROR: GetDirectory - Error getting /media/deepcat2/VaultA/MUSIC AND PHOTOS/ KODI MUSIC/10cc/ I’m Not In Love- The Essential 10cc/
imply that Kodi is unable to access the folders that contain the music files. That would explain why nothing is played, but not why Library update dialogs are being dispalyed.

I would expect the songs to be in the library and show when you navigate from artist or album. Do they?

The issue could be about how your media source is mounted or connected to your Linux device. I vaguely remember another user having a similar issue, I'll see if I can find it.

Meanwhile it might be informative to see your sources.xml and MyMusic72.db files, if you can put them somewhere and PM me a link.


RE: First time adding music to kodi issues. - mxlance - 2019-03-13

quote: " I would expect the songs to be in the library and show when you navigate from artist or album. Do they?"
No they do not, yet in Music>Files>Kodi Music (My Source) all song are displayed.

I disabled the PVR and Emby and rebooted with Esuary.
I also moved the files to my home folder and re-added them to kodi.
Same result as before.

the file you requested
https://ln.sync.com/dl/5b6a9a8e0/6dpmsty2-n53zrzuq-amkf66au-6rh4mdj6

thank you for the help


RE: First time adding music to kodi issues. - mxlance - 2019-03-13

Something i forgot to mention.
In Artists "10cc" is labled (Missing) other artists are displayed.
In Albums The 10cc album is displayed but still no songs
crazy


RE: First time adding music to kodi issues. - mxlance - 2019-03-13

I have it working, so far.
As a last-ditch effort i removed my kodi data folder rebooted kodi clean and added the music just as before.
It worked, so there must be some conflict from an addon or something.
Now i will try reinstalling things to see if i can get thing working with the PVR and Emby.

Any tips are welcome
Thank you again for the help


RE: First time adding music to kodi issues. - DaveBlake - 2019-03-13

OK, I can see the problem but don't understand how it happened. The role table is empty, whereas it should contain at least one record, and that absence would prevent songs from showing on the GUI.  Also the first artist entry, which should be a default, has been overwritten (hence seeing "missing"). Very weird.

All I can do is write it off as a db corruption (while casting suspicious glances at Embly!). Since you have only tested with 3 albums it is simple to delete the MyMusic72.db file and start again, when you restart Kodi it will recreate a new db.

But I also notied that the music source has a folder name that starts with a space (space KODI MUSIC)
"/home/deepcat2/Music/ KODI MUSIC/10cc/"
that seems really odd and I'm sure could upset something somewhere.

So my advice would be to start again. Remove the current source (changes sources.xml) and delete MyMusic72.db. Move your music to a path without a space at start of any folder names. Finally try adding music source and scanning again.

I hope this first trial experience does not put you off, Kodi makes a great music player and using the library offers a rich way to explore your music collection and decide what to play.


RE: First time adding music to kodi issues. - mxlance - 2019-03-13

I restored my original .kodi data folder.
Tuned all my addon back on emby and pvr.
Removed the current source and delete MyMusic72.db. Move the space at start of any my source. Re-added music source and scanned again.

All is working as expected now. Thank you for the tips.
i am looking forward to using kodi for music still. The only issue i see going forward is my unlearning itunes and to try to not make kodi work like itunes.

Thank You again


This forum uses Lukasz Tkacz MyBB addons.