Kodi Community Forum
Xonfluence (Leia v18.x & Matrix v19.x) (Krypton 17 = deprecated) - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Skins Support (https://forum.kodi.tv/forumdisplay.php?fid=67)
+---- Forum: Confluence (https://forum.kodi.tv/forumdisplay.php?fid=125)
---- Thread: Xonfluence (Leia v18.x & Matrix v19.x) (Krypton 17 = deprecated) (/showthread.php?tid=346302)



RE: Xonfluence (Jarvis v16.x & Krypton v17.x) - Helly1206 - 2016-06-04

(2016-06-04, 20:19)jmh2002 Wrote: For information, regarding tracking down this bug, I recently did a fresh clean set up of Xonfluence from new and I didn't have any problems.

In addition, Global Search has not been installed on my setup for a long time, so of course it's greyed out in the scripts in the first place.

The button would disappear after a restart when you uninstall or disable the addon, but the fix will cause an immediate disappear or appear if addon is installed or uninstalled.


RE: Xonfluence (Jarvis v16.x & Krypton v17.x) - Helly1206 - 2016-06-04

New release for Jarvis:

3.2.14
- Fixed appearance of addon button in case addons disabled or uninstalled #1124

and new release for Krypton:

3.3.2
- Fixed addon browser window
- Fixed appearance of addon button in case addons disabled or uninstalled #1124

Enjoy.
Helly.


RE: Xonfluence (Jarvis v16.x & Krypton v17.x) - aocid - 2016-06-04

(2016-06-03, 20:05)Helly1206 Wrote:
(2016-05-29, 23:50)aocid Wrote: Hello Helly,

Love your skin! But have not been able to install it since the CCM days. I am not the most advanced user but not a beginner either, just bear with me and hope you can help me go back to using your skin.

I just installed the May 22 Kodi version for Apple tv 4 which is 'Kodi 17.0-ALPHA2 Git:2016-05-22-5e33e2b'.
I was able to transfer (with dropbox) and install the latest hellyrepo you provided today at 8:05 but when I go to Look and Feel>Skin, the folder is empty.
I also tried to install the .zip file of the skin you provided yesterday but I get the message "the dependency on xbmc.gui 5.10.0 could not.." and that is all I can read.

What should I do ?

Thanks for all your work!

My stupid mistake. Will be fixed in the next release.

Thanks,
Helly.

Thank you so much for the reply.

Not sure if that is your "stupid mistake". It is probably just me.

Can you confirm on this? Am I doing something wrong when trying to install the skin?

Thanks for all the great work!


RE: Xonfluence (Jarvis v16.x & Krypton v17.x) - sylvio2000 - 2016-06-05

Thank you very much.
The last update did the trick. The search bar is gone Smile


RE: Xonfluence (Jarvis v16.x & Krypton v17.x) - Helly1206 - 2016-06-05

(2016-06-04, 20:51)aocid Wrote:
(2016-06-03, 20:05)Helly1206 Wrote:
(2016-05-29, 23:50)aocid Wrote: Hello Helly,

Love your skin! But have not been able to install it since the CCM days. I am not the most advanced user but not a beginner either, just bear with me and hope you can help me go back to using your skin.

I just installed the May 22 Kodi version for Apple tv 4 which is 'Kodi 17.0-ALPHA2 Git:2016-05-22-5e33e2b'.
I was able to transfer (with dropbox) and install the latest hellyrepo you provided today at 8:05 but when I go to Look and Feel>Skin, the folder is empty.
I also tried to install the .zip file of the skin you provided yesterday but I get the message "the dependency on xbmc.gui 5.10.0 could not.." and that is all I can read.

What should I do ?

Thanks for all your work!

My stupid mistake. Will be fixed in the next release.

Thanks,
Helly.

Thank you so much for the reply.

Not sure if that is your "stupid mistake". It is probably just me.

Can you confirm on this? Am I doing something wrong when trying to install the skin?

Thanks for all the great work!

The dependency issue is my stupid mistake. Why your look and feel folder is empty, I don't know. Did you install the latest repo version (as I changed the download locations last week). You can try to update the repo or install the latest zip file.

Helly.


RE: Xonfluence (Jarvis v16.x & Krypton v17.x) - aocid - 2016-06-05

(2016-06-05, 08:23)Helly1206 Wrote:
(2016-06-04, 20:51)aocid Wrote:
(2016-06-03, 20:05)Helly1206 Wrote: My stupid mistake. Will be fixed in the next release.

Thanks,
Helly.

Thank you so much for the reply.

Not sure if that is your "stupid mistake". It is probably just me.

Can you confirm on this? Am I doing something wrong when trying to install the skin?

Thanks for all the great work!

The dependency issue is my stupid mistake. Why your look and feel folder is empty, I don't know. Did you install the latest repo version (as I changed the download locations last week). You can try to update the repo or install the latest zip file.

Helly.

Can you link me to the latest files I should try now?


RE: Xonfluence (Jarvis v16.x & Krypton v17.x) - Helly1206 - 2016-06-05

(2016-06-05, 17:25)aocid Wrote:
(2016-06-05, 08:23)Helly1206 Wrote:
(2016-06-04, 20:51)aocid Wrote: Thank you so much for the reply.

Not sure if that is your "stupid mistake". It is probably just me.

Can you confirm on this? Am I doing something wrong when trying to install the skin?

Thanks for all the great work!

The dependency issue is my stupid mistake. Why your look and feel folder is empty, I don't know. Did you install the latest repo version (as I changed the download locations last week). You can try to update the repo or install the latest zip file.

Helly.

Can you link me to the latest files I should try now?

It's the one linked at in the first post


RE: Xonfluence (Jarvis v16.x & Krypton v17.x) - gjwAudio - 2016-06-06

Hi Helly

Thank you for Krypton-izing the Xonfluence skin... I've been waiting since February for such good news !

Unfortunately, the installation/update from the temporary Uukrul version to your v3.3.2 is being difficult. FYI, I'm running Kodi v17 from the latest Milhouse build of LibreELEC (#0605).

Roadblock #1 - Uncooperative Repo:
Using the link from post #1 of this thread, I deleted/ refreshed the hellyrepo.kodi.zip THREE times without success. Navigating to Look and Feel > Skin, the folder is empty - same as reported by aocid above.

So I downloaded the MASTER from your github for manual install. Nope... instead there is:

Roadblock #2 - Unsatisfied Dependency:
Kodi is complaining "The dependency on xbmc.gui version 5.11.0 could not be satisfied". Hmmm - is there a typo lurking somewhere amongst the weeds ?

For what it's worth, here's the debug log of attempting to install from the MASTER zip. Has anyone else got this to work ?

Thanks for looking into the trouble Blush

additional intell from the LibreELEC thread...
Kodi master is now at xbmc.gui 5.12.0 (see #0502 for the bump) with no backward compatability for older versions, so a skin that only supports xbmc.gui 5.11.0 will have problems. xbmc.gui is configured here.
HTH Wink


RE: Xonfluence (Jarvis v16.x & Krypton v17.x) - sylvio2000 - 2016-06-07

I have recognized that the home menu appears really late after starting Kodi especially on the FireTVStick.

FireTVStick = 10sec
FireTV1 = 4sec
FireTV2 = almost instantly

With the original Confluence skin the home menu appears on all devices almost instantly.


RE: Xonfluence (Jarvis v16.x & Krypton v17.x) - cydine - 2016-06-09

Hi Helly.

After the latest update the random fanart script is broken for me. The script cannot be enabled in settings. When you save and go back in to settings, it is disabled again.

Running 16.1.


RE: Xonfluence (Jarvis v16.x & Krypton v17.x) - rickyman - 2016-06-09

do u guys have any screenshot of this skin for kodi 17?


RE: Xonfluence (Jarvis v16.x & Krypton v17.x) - ohjays - 2016-06-10

There appears to be a typo in the includes.xml for 3.2.14

21:29:12 T:5140 ERROR: Unmatched [
21:29:12 T:5140 ERROR: Error parsing boolean expression Skin.HasSetting(ScriptDisableTVTunes) | [!Skin.HasSetting(ScriptDisableTVTunes) + !System.HasAddon(script.tvtunes)
2

should the line#2317 not read as follows?
<onunload condition="Skin.HasSetting(ScriptDisableTVTunes) | [!Skin.HasSetting(ScriptDisableTVTunes) + !System.HasAddon(script.tvtunes)]">Skin.Setbool(DisableTVTunes)</onunload>

which fixes this error


RE: Xonfluence (Jarvis v16.x & Krypton v17.x) - Helly1206 - 2016-06-10

(2016-06-09, 19:35)cydine Wrote: Hi Helly.

After the latest update the random fanart script is broken for me. The script cannot be enabled in settings. When you save and go back in to settings, it is disabled again.

Running 16.1.

You found a bug.

Solved in the next release.

Thanks.
Helly.


RE: Xonfluence (Jarvis v16.x & Krypton v17.x) - Helly1206 - 2016-06-10

(2016-06-10, 12:06)ohjays Wrote: There appears to be a typo in the includes.xml for 3.2.14

21:29:12 T:5140 ERROR: Unmatched [
21:29:12 T:5140 ERROR: Error parsing boolean expression Skin.HasSetting(ScriptDisableTVTunes) | [!Skin.HasSetting(ScriptDisableTVTunes) + !System.HasAddon(script.tvtunes)
2

should the line#2317 not read as follows?
<onunload condition="Skin.HasSetting(ScriptDisableTVTunes) | [!Skin.HasSetting(ScriptDisableTVTunes) + !System.HasAddon(script.tvtunes)]">Skin.Setbool(DisableTVTunes)</onunload>

which fixes this error

Fixed in the next release.

Thanks.
Helly.


RE: Xonfluence (Jarvis v16.x & Krypton v17.x) - Helly1206 - 2016-06-10

(2016-06-06, 09:57)gjwAudio Wrote: Hi Helly

Thank you for Krypton-izing the Xonfluence skin... I've been waiting since February for such good news !

Unfortunately, the installation/update from the temporary Uukrul version to your v3.3.2 is being difficult. FYI, I'm running Kodi v17 from the latest Milhouse build of LibreELEC (#0605).

Roadblock #1 - Uncooperative Repo:
Using the link from post #1 of this thread, I deleted/ refreshed the hellyrepo.kodi.zip THREE times without success. Navigating to Look and Feel > Skin, the folder is empty - same as reported by aocid above.

So I downloaded the MASTER from your github for manual install. Nope... instead there is:

Roadblock #2 - Unsatisfied Dependency:
Kodi is complaining "The dependency on xbmc.gui version 5.11.0 could not be satisfied". Hmmm - is there a typo lurking somewhere amongst the weeds ?

For what it's worth, here's the debug log of attempting to install from the MASTER zip. Has anyone else got this to work ?

Thanks for looking into the trouble Blush

additional intell from the LibreELEC thread...
Kodi master is now at xbmc.gui 5.12.0 (see #0502 for the bump) with no backward compatability for older versions, so a skin that only supports xbmc.gui 5.11.0 will have problems. xbmc.gui is configured here.
HTH Wink

#1: Which version of the repo are you using? Which kodi version does your special milhouse built say it is? I tested with alpha builds, as stay are concidered to be more stable. I don't know about the milhouse build.

#2: The alpha build is using 5.11.0, test build are using 5.12.0. I'm aware of that, I don't change until a next stable build using 5.12.0.

Thanks,
Helly.


This forum uses Lukasz Tkacz MyBB addons.