Kodi Community Forum
Beta Kodi 19 not creating music db - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Music Support (https://forum.kodi.tv/forumdisplay.php?fid=263)
--- Thread: Beta Kodi 19 not creating music db (/showthread.php?tid=347600)

Pages: 1 2


Kodi 19 not creating music db - M1lQU3 - 2019-09-28

First off:
-I upgraded to beta matrix build because of set image handling.

-I imported my bakups of my databases from kodi 17.xx

-once I realized that kodi wasnt creating a db...i deleted my prior db in users folder abd kodi created a new db, but nothing is scraping

- I switched scrapers by adding new addons through media/audio in the settings menu...still not scraping my audio


Help. TIA


RE: Kodi 19 not creating music db - M1lQU3 - 2019-09-28

***** correction:   not scraping from remote shares.  Neither gdrive or onedrive work.  Movies scrape fine.


RE: Kodi 19 not creating music db - Karellen - 2019-09-28

I have no idea what skill level you have with Kodi, so maybe start off with the Guide and you might find where you are going wrong... https://kodi.wiki/view/HOW-TO:Create_Music_Library


RE: Kodi 19 not creating music db - M1lQU3 - 2019-09-28

(2019-09-28, 03:15)Karellen Wrote: I have no idea what skill level you have with Kodi, so maybe start off with the Guide and you might find where you are going wrong... https://kodi.wiki/view/HOW-TO:Create_Music_Library

Yes...totally did that. Can create library from local source, just not from Gdrive or OneCloud with repo plug-ins however they work fine in the Movies Section. Also the remote shares do not show up in sources in the Music sub-menu however they remain in the files Sub-menu as links to the remote servers via the generated localhost:8585 script. The scraper also iterates through the remote shares folders, however dosn't add anything.
I added the original Weezer album to the library locally and it created a music library, however when trying to edit the album information I have little to choose from...the scraper browser dosn't list a selection...just crashes back into the default. This may help with the problemn being diagnosed?
I was hoping someon had expirienced this already and there was a simple solution. My next steps are to:
- Download a portion of my remote share to see if it scrapes locally
- clean install a fresh copy, install remote share add-on only...and see if that works..in case there is a conflict.

I remember in the past chronology had alot to do with bugs early on due to conflict with install scripts.

.... I'll post results of my tests when I get to it.


RE: Kodi 19 not creating music db - Karellen - 2019-09-28

Ok. Can you provide a Debug Log which captures you trying to scan your remote drives.

I have no experience with either these add-ons or remote drives, so others will need to step in once you provide the Debug Log


RE: Kodi 19 not creating music db - M1lQU3 - 2019-09-28

Rather than posting the entire log file, here is the recurring snippet that happens for every entry I try to scrape from remote server...:

Code:
2019-09-27 23:54:57.533 T:2155870576 ERROR: CCurlFile::Stat - Failed: Couldn't connect to server(7) for http://localhost:8586/source/OneDrive/Brian%20Peterson%20%7C%20OneDrive%20Personal/Audio/MTV%20Unplugged/Cranberries%20-%20MTV%20Unplugged%20%5B1994%5D/
2019-09-27 23:54:57.533 T:2155870576 WARNING: Process directory 'http://localhost:8586/source/OneDrive/Brian%20Peterson%20%7C%20OneDrive%20Personal/Audio/MTV%20Unplugged/Cranberries%20-%20MTV%20Unplugged%20%5B1994%5D/' does not exist - skipping scan.
2019-09-27 23:54:57.536 T:2113927536 DEBUG: CurlFile::Open(0x7dffd3b8)

I access the remote server via a http web server instance through the 'add Music +' option through the files sub-menu.  This is also how I add video from the same remote source.


RE: Kodi 19 not creating music db - Karellen - 2019-09-28

oh, geez. I am not going to persist. We ask for items of information for a reason. I struggled to get a screenshot, I cannot get a log. I'll leave you in the hands of others for both your issues.


RE: Kodi 19 not creating music db - Klojum - 2019-09-28

For (not) creating the 'db', we will still need at least the whole first part of the debug log (wiki).

Accessing OneDrive files is above my paygrade.


RE: Kodi 19 not creating music db - M1lQU3 - 2019-09-28

(2019-09-28, 08:19)Klojum Wrote: For (not) creating the 'db', we will still need at least the whole first part of the debug log (wiki).

Accessing OneDrive files is above my paygrade.

Do you want the debug from a clean start-up?


RE: Kodi 19 not creating music db - Klojum - 2019-09-28

(2019-09-28, 08:25)M1lQU3 Wrote: Do you want the debug from a clean start-up?

Preferably, yes. Just don't remove/edit any parts.


RE: Kodi 19 not creating music db - M1lQU3 - 2019-09-29

(2019-09-28, 08:38)Klojum Wrote:
(2019-09-28, 08:25)M1lQU3 Wrote: Do you want the debug from a clean start-up?

Preferably, yes. Just don't remove/edit any parts. 

The strings are being turned into escaped strings with %20.....etc.. 2 different string interprets in one lookup.  How do I switch this?  Cant remember.


RE: Kodi 19 not creating music db - black_eagle - 2019-09-29

(2019-09-29, 06:26)M1lQU3 Wrote: The strings are being turned into escaped strings with %20.....etc.. 2 different string interprets in one lookup.  How do I switch this?  Cant remember.

Doesn't matter.  What does matter is a link to your debug log (wiki).  Without that, no one can help you and no one will attempt to help you either because you aren't providing the necessary information which has already been requested four times.


RE: Kodi 19 not creating music db - M1lQU3 - 2019-09-29

Here is a link to my debug...
Kodi.log


RE: Kodi 19 not creating music db - black_eagle - 2019-09-29

Have you actually tagged your music files with some data ?  I see a lot of

DEBUG: ScanTags - No tag found for: http://localhost:8586/source/OneDrive/Brian%20Peterson%20%7C%20OneDrive%20Personal/Audio/MTV%20Unplugged/Alice%20in%20Chains%20-%20Unplugged/%5B02%5D%20Brother%20-%20Alice%20In%20Chains.mp3 which would suggest that you haven't.

Kodi builds its library from the tags contained in the files so if there are no tags........  The video library does not build its library in the same way which might indicate why videos work and music doesn't.

Also, something is squiffy with your advancedsettings.xml file.  ERROR: Error loading special://profile/advancedsettings.xml, Line 14 Error reading end tag. which may or may not be relevant.

If you go to Music -> files, can you navigate and play something that way ?


RE: Kodi 19 not creating music db - M1lQU3 - 2019-09-29

(2019-09-29, 17:00)black_eagle Wrote: Have you actually tagged your music files with some data ?  I see a lot of

DEBUG: ScanTags - No tag found for: http://localhost:8586/source/OneDrive/Brian%20Peterson%20%7C%20OneDrive%20Personal/Audio/MTV%20Unplugged/Alice%20in%20Chains%20-%20Unplugged/%5B02%5D%20Brother%20-%20Alice%20In%20Chains.mp3 which would suggest that you haven't.

Kodi builds its library from the tags contained in the files so if there are no tags........  The video library does not build its library in the same way which might indicate why videos work and music doesn't.

Also, something is squiffy with your advancedsettings.xml file.  ERROR: Error loading special://profile/advancedsettings.xml, Line 14 Error reading end tag. which may or may not be relevant.

If you go to Music -> files, can you navigate and play something that way ?

Yes, I can definately play music that way.  Is there an easy way to tag my files on a remote server...for instance OneDrive?   Or will I need to download them all again.  I noticed some add-ons for this...any advice?


This forum uses Lukasz Tkacz MyBB addons.