Kodi Community Forum
raspberry pi zero w, kodi works with composite ntsc but it doesn't with composite pal - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Raspberry Pi (https://forum.kodi.tv/forumdisplay.php?fid=166)
---- Thread: raspberry pi zero w, kodi works with composite ntsc but it doesn't with composite pal (/showthread.php?tid=348205)

Pages: 1 2


raspberry pi zero w, kodi works with composite ntsc but it doesn't with composite pal - bbcaddict - 2019-10-09

As per the subject, raspbian buster with kodi 18.4.
kodi works fine with hdmi, fine with composite in ntsc mode but hangs with composite in pal mode (and the tv I want to use only accepts pal).

I uploaded the logs here (removing the timestamps so they're easier to diff)

with hdmi https://pastebin.com/EfRaY8NU
with composite video (pal) https://pastebin.com/RXM3HF6w

as you see the difference is that with composite kodi hangs after "NOTICE: Checking resolution 16".

In ntsc mode it's pretty much the same as hdmi, apart from the fact that if finds only one resolution.

I followed the advice here to upgrade the firmware but it still doesn't work.
Then I followed the advice here to downgrade the kernel/firmware but it's even worse: kodi doesn't even start ("Illegal instruction (core dumped)").

I also tried libreelec (stable) and it does exactly the same.


RE: raspberry pi zero w, kodi works with composite ntsc but it doesn't with composite pal - bbcaddict - 2019-10-11

I also tried the latest test build of libreelec with kodi 19 and it does exactly the same Undecided
I don't know if it's a firmware or kodi issue, after all the libreelec animation shows fine even with pal.


RE: raspberry pi zero w, kodi works with composite ntsc but it doesn't with composite pal - popcornmix - 2019-10-11

Does composite pal mode work for you with raspbian?


RE: raspberry pi zero w, kodi works with composite ntsc but it doesn't with composite pal - TJSilva - 2019-11-05

(2019-10-11, 19:24)popcornmix Wrote: Does composite pal mode work for you with raspbian?

Raspbian works, LibreELEC fails (Raspberry Pi 3B)

I'm having the same issue with all versions of LibreELEC since 9.1.502 (Kodi 18.4). I've even tried the latest nightlies from Milhouse, because they had more recent firmware and kernel, but the issue remains in those builds (#1104, for example).
This did not happen with LibreELEC 9.0.2 (Kodi 18.2), but it's very difficult to keep using that build because of the "not saving the overscan settings" bug.

After uncommenting "sdtv_mode=2" on /boot/config.txt, Raspbian Buster (2019-09-26) boots into the graphical mode and the TV detects the signal at 576i 50Hz.
After writing "sdtv_mode=2" on /flash/config.txt, LibreELEC doesn't finish loading Kodi: the LibreELEC splash screen loads completely, then hangs on a black screen and never shows the Kodi splash screen. The Linux part is working: I can SSH and edit /flash/config.txt, and also retrieve logs through the network shares (the Samba server is working).
After commenting "sdtv_mode=2" on /flash/config.txt and rebooting, LibreELEC loads Kodi (18.4 in LE 9.1.502, or 19-alpha in nightlies I've been testing), but the TV is at 480i 60Hz.

I've posted logs on this post on Milhouse's builds' thread.


RE: raspberry pi zero w, kodi works with composite ntsc but it doesn't with composite pal - popcornmix - 2019-11-05

Can reproduce. Have a fix which should be available as test firmware soon.


RE: raspberry pi zero w, kodi works with composite ntsc but it doesn't with composite pal - TJSilva - 2019-11-05

WOW! Amazing! Thank you very much!


RE: raspberry pi zero w, kodi works with composite ntsc but it doesn't with composite pal - popcornmix - 2019-11-06

Can you try updating firmware. Download:
https://github.com/raspberrypi/firmware/blob/master/boot/start4x.elf?raw=true
https://github.com/raspberrypi/firmware/blob/master/boot/fixup4x.dat?raw=true

rename to start.elf/fixup.dat and replace the ones on the boot partition of your sdcard (make of copy of the existing ones first).
Does that help?


RE: raspberry pi zero w, kodi works with composite ntsc but it doesn't with composite pal - TJSilva - 2019-11-07

It works! With the new firmware from the previous post, LibreELEC (Milhouse build #1104 / Kodi 19-alpha) now loads to the end in PAL analog mode with sdtv_mode=2 in config.txt!

But, there's another problem now. The video player (not the UI, just the "surface" or "overlay" where video is played) is pushed down, leaving about 1/3 of the screen black on top. The video is pushed down, so it's cropped on the bottom correspondingly. Since I still have the debug mode on, the white numbers that report memory statistics still appear in their usual place, but only appear a few frames at a time.

It may be related, or not, but the LibreELEC boot animation seems also to be pushed down by the same amount. This does not happen with the LibreELEC static image (after the rainbow but before the animation) and also not with the KODI splash screen, or, as I said, with the KODI UI.

Is this firmware safe to put in the 9.1.502 build? Just to make sure it's not an issue with the current 19-alpha-based builds?

edit: With the new firmware, 9.1.502 also boots in PAL mode (good!) and also has the video position shift (bad...). I'm attaching a photo. Notice the red box on the bottom right has been cut off. Oh, and the video is also out of position in NTSC mode, just less.
Image


RE: raspberry pi zero w, kodi works with composite ntsc but it doesn't with composite pal - TJSilva - 2019-11-07

OK, disregard. The new Milhouse #1106 build that has the fix integrated is working well so far, the video playback image and the LibreELEC boot animation are correctly placed in my preliminary tests.

[edit] in case that wasn't clear, it means that if you, fellow reader of this forum, are having this issue in 9.1.502, it can't be fixed with the above firmware.

You have to move to Milhouse builds greater than #1106 to get the fix and have analog PAL output from a LibreELEC on Raspberry Pi, with the caveat that those are development builds, can (potentially) cause breakage, and are moving *fast*.


RE: raspberry pi zero w, kodi works with composite ntsc but it doesn't with composite pal - popcornmix - 2019-11-07

I think I see the issue - try these files:
https://github.com/raspberrypi/firmware/blob/master/boot/start_x.elf?raw=true
https://github.com/raspberrypi/firmware/blob/master/boot/fixup_x.dat?raw=true

which should work with the older image.

I had pointed to the Pi4 firmware, but now see you were on Pi3.
The Pi4 firmware mostly works on older Pi's, but there are a few issues.


RE: raspberry pi zero w, kodi works with composite ntsc but it doesn't with composite pal - TJSilva - 2019-11-08

(2019-11-07, 20:10)popcornmix Wrote: I think I see the issue - try these files:
https://github.com/raspberrypi/firmware/blob/master/boot/start_x.elf?raw=true
https://github.com/raspberrypi/firmware/blob/master/boot/fixup_x.dat?raw=true

which should work with the older image.

I had pointed to the Pi4 firmware, but now see you were on Pi3.
The Pi4 firmware mostly works on older Pi's, but there are a few issues.
I confirm that this second set of firmware works properly on my Raspberry Pi 3B under LibreELEC 9.1.502. Which means I can leave the 19-alpha train for the moment Big Grin
So anyone having this problem on a Pi4 should try the first set of firmwares first?

I can't thank you enough. Regards, Tiago.


RE: raspberry pi zero w, kodi works with composite ntsc but it doesn't with composite pal - Daikath - 2019-11-09

I was just having this problem and this solved it! Thank you popcornmix!


RE: raspberry pi zero w, kodi works with composite ntsc but it doesn't with composite pal - bbcaddict - 2019-11-09

For some reason the forum didn't notify me of replies  Undecided (I checked and both the email and the settings were right).
Anyway, yesterday I updated the firmware and now pal output works Laugh .


RE: raspberry pi zero w, kodi works with composite ntsc but it doesn't with composite pal - Daikath - 2019-11-10

Edit. Just saw a solution posted above.


RE: raspberry pi zero w, kodi works with composite ntsc but it doesn't with composite pal - rastavibes - 2020-01-18

is this fixed on lastest firmware?
If I am using archlinux-arm, and perform a pacman -Syu, will I get a version with proper composite output?


This forum uses Lukasz Tkacz MyBB addons.