Kodi Community Forum
Release Amazon VOD [plugin.video.amazon[vod|-test]] - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Add-on Support (https://forum.kodi.tv/forumdisplay.php?fid=27)
+---- Forum: Video Add-ons (https://forum.kodi.tv/forumdisplay.php?fid=154)
---- Thread: Release Amazon VOD [plugin.video.amazon[vod|-test]] (/showthread.php?tid=349255)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36


RE: Amazon VOD [plugin.video.amazon[vod|-test]] - UncT - 2020-02-12

Is there an addon like the one for Android made for the PC (Windows) to get 4K. I can watch it in 4K on the TV's app but not in Kodi?


RE: Amazon VOD [plugin.video.amazon[vod|-test]] - Varstahl - 2020-02-12

No, the reproduction is blocked by Google. Short of piracy, that's not possible.


RE: Amazon VOD [plugin.video.amazon[vod|-test]] - dontknow.cris - 2020-02-15

Hi @Varsthal
Sorry if this was already asked, but I cannot find any solutions
I use an Amazon Fire TV Stick with Kodi 18.5: is there a way to get 4K video working? I can only get 1080p using inpustream or android native player


RE: Amazon VOD [plugin.video.amazon[vod|-test]] - Varstahl - 2020-02-15

Through Kodi you can only get 4K via native apps if I recall correctly. You can still use Kodi and the addon to browse and have everything there, and then when you select playback it will automatically open the native app.

Sadly, since this is a chokehold by design by Google and friends, there's nothing we can do about that. That's DRMs for you.


RE: Amazon VOD [plugin.video.amazon[vod|-test]] - [email protected] - 2020-02-16

Hi

anyone knows how to solve the  error

error:
No module named html.entities Traceback
and also can not update beautifulsoup4 .
I have running 4.6.3.1

updated via  pipConfusedudo pip install beautifulsoup4

but this is not reflected in kodi I think.

dependencies can not be resolved for Version 3.0.0....
2020-02-16 20:25:26.695 T:2538   ERROR: CAddonInstallJob[script.module.beautifulsoup4]: Die Abhängigkeit auf xbmc.python in Version 3.0.0 konnte nicht aufgelöst werden.









RE: Amazon VOD [plugin.video.amazon[vod|-test]] - Varstahl - 2020-02-16

You need to install the appropriate BeautifulSoup4 addon for the Kodi version you're running. Several times some addons ship with broken/incomplete/incompatible addon version. BS4 and htmllib are binary, so if you don't have the proper version it just won't work.

https://mirrors.kodi.tv/addons/leia/script.module.beautifulsoup4/
https://mirrors.kodi.tv/addons/leia/script.module.html5lib/

https://mirrors.kodi.tv/addons/matrix/script.module.beautifulsoup4/
https://mirrors.kodi.tv/addons/matrix/script.module.html5lib/


RE: Amazon VOD [plugin.video.amazon[vod|-test]] - Roby77 - 2020-02-17

I don't know if it's a bug of the plugin but with Milhouse build 15/02 (libreelec build for x64) plugin doesn't work correctly


RE: Amazon VOD [plugin.video.amazon[vod|-test]] - Roby77 - 2020-02-17

Nevermind it's a problem of Kodi


RE: Amazon VOD [plugin.video.amazon[vod|-test]] - Smallmountains - 2020-02-19

I'm running RPi3+ LibreElec 9.0.2 Kodi 18.2 Amazon VOD 0.8.1
The addon is installed but when entering my credentials I get an error no matter what method I choose to get my validation code.  No matter what method I use I get an almost immediate red "x" error...see log file for info. But the log file doesn't really tell me anything.

I have the addon installed and activated on my test installation on a Windows 10 laptop. No problem getting verified there but on the RPi...no good at all.

What can I do to figure out what I'm missing or what's broken?


RE: Amazon VOD [plugin.video.amazon[vod|-test]] - [email protected] - 2020-02-19

(2020-02-16, 21:46)Varstahl Wrote: You need to install the appropriate BeautifulSoup4 addon for the Kodi version you're running. Several times some addons ship with broken/incomplete/incompatible addon version. BS4 and htmllib are binary, so if you don't have the proper version it just won't work.

https://mirrors.kodi.tv/addons/leia/script.module.beautifulsoup4/
https://mirrors.kodi.tv/addons/leia/script.module.html5lib/

https://mirrors.kodi.tv/addons/matrix/script.module.beautifulsoup4/
https://mirrors.kodi.tv/addons/matrix/script.module.html5lib/
thanks will check this


RE: Amazon VOD [plugin.video.amazon[vod|-test]] - Varstahl - 2020-02-19

(2020-02-19, 02:24)Smallmountains Wrote: What can I do to figure out what I'm missing or what's broken?

Well, you know… you could post the logs. With debug mode activated, that'd be better. You find links with the info you need in the first post.


RE: Amazon VOD [plugin.video.amazon[vod|-test]] - Smallmountains - 2020-02-20

(2020-02-19, 15:00)Varstahl Wrote:
(2020-02-19, 02:24)Smallmountains Wrote: What can I do to figure out what I'm missing or what's broken?

Well, you know… you could post the logs. With debug mode activated, that'd be better. You find links with the info you need in the first post. 
Verbose logging enabled. Log can be seen [Here]


RE: Amazon VOD [plugin.video.amazon[vod|-test]] - Varstahl - 2020-02-20

It's a login issue, which might or might not be related to the VPN you're using. Another user reported some time ago the same issue, but without the login logs we couldn't check further. Along with the main log another file should have been generated, something like "avod-login". That contains the login form which is failing for you and/or the reason why it's failing. If you could post it somewhere, we'll take a look at it.


RE: Amazon VOD [plugin.video.amazon[vod|-test]] - Smallmountains - 2020-02-20

(2020-02-20, 02:13)Varstahl Wrote: It's a login issue, which might or might not be related to the VPN you're using. Another user reported some time ago the same issue, but without the login logs we couldn't check further. Along with the main log another file should have been generated, something like "avod-login". That contains the login form which is failing for you and/or the reason why it's failing. If you could post it somewhere, we'll take a look at it.
The VPN is not likely the issue. The VPN is set to turn off when this add on loads. Anyway, I've explicitly turned off the VPN and tested it. Same thing.  I get the Captcha, I supply my password and the captcha fine. The problems happens after I choose the method I want to receive the verification. It pops the error a second or two after I choose the method. I've tried all methods with the same result. I will try to figure out how to get that other log. I'm more limited on the RPi than other platforms.


RE: Amazon VOD [plugin.video.amazon[vod|-test]] - Prof Yaffle - 2020-02-20

Merely reminding everyone of our VPN policy (wiki). This isn't a VPN support forum, so bear that in mind, please: demonstrate a problem without the VPN installed/enabled, and all is well...


This forum uses Lukasz Tkacz MyBB addons.