Kodi Community Forum
Release Amazon VOD [plugin.video.amazon[vod|-test]] - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Add-on Support (https://forum.kodi.tv/forumdisplay.php?fid=27)
+---- Forum: Video Add-ons (https://forum.kodi.tv/forumdisplay.php?fid=154)
---- Thread: Release Amazon VOD [plugin.video.amazon[vod|-test]] (/showthread.php?tid=349255)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36

RE: Amazon VOD [plugin.video.amazon[vod|-test]] - calibos - 2020-06-09

(2020-06-08, 23:33)Varstahl Wrote: That might depend on a number of factors. The easier test is to disable "MPD alteration proxy" and trying again. Also you might want to read here in regard to AVOD and Android playback.

Disabled MPD. Also tried enabling 'Use Android app for 4K videos' in conjunction and in isolation from the MPD setting.

Same behaviour. Click the episode, Screen Dims, blue ring starts spinning. Playback Progress bar OSD at top of screen visible behind what looks like this deep tint/dimming overlay. Pressing Pause changes playback triangle to pause icon. Pressing stop immediately removes the dark tint overlay over the Kodi interface. 

I already have the Android Prime Video app installed and it works perfectly outside of KODI.

RE: Amazon VOD [plugin.video.amazon[vod|-test]] - Varstahl - 2020-06-09

Never heard of anything similar happening. By any chance, does the problem persist if you use the standard Estuary skin?

RE: Amazon VOD [plugin.video.amazon[vod|-test]] - calibos - 2020-06-09

(2020-06-09, 17:14)Varstahl Wrote: Never heard of anything similar happening. By any chance, does the problem persist if you use the standard Estuary skin?

No. Same behaviour.


When I selected Android instead of Input stream it didnt't work first time. However when I put it back to input stream and set Android as the fallback the video finally played. Set it Input Stream back to Android it now worked unlike the first time.....However stopping the video takes me to the Android Prime app home screen and trying to close that by clicking back or escape to close the prime window takes me back to the Android Home Screen not to KODI.

I think I'll revert to my original plan which was to use the original Netflix and Amazon Android apps set as favourites and added to the Home Screen Menu to be started from within KODI. At least when you close them it takes you back to KODI and doesn't dump me to the Android Home Screen. Not to worry. Its some peculiarity about my setup I imagine. My VirginTV Anywhere app integration into KODI was always going to have to be as external Android app started from a KODI Home Screen Menu item and interacted with via an Air Mouse Remote. I have no real issue with Netflix and Amazon Prime Video being the same. I am just thrilled and amazed I was able to even integrate them that way into KODI. 

Thanks for your help Varstahl.

RE: Amazon VOD [plugin.video.amazon[vod|-test]] - Roby77 - 2020-06-12

Plugin doesn't work anymore

Play failed check logs


Am I the only one ,?

RE: Amazon VOD [plugin.video.amazon[vod|-test]] - Varstahl - 2020-06-12

Looks like a connection time out. You should be able to disable the MPD alteration proxy at least temporarily. Might be a network hiccup plus my non having the proxy finished yet.

RE: Amazon VOD [plugin.video.amazon[vod|-test]] - Roby77 - 2020-06-12

really strange cause i don't set anything neither i changed plugin settings plus i have a gigabit connection on fiber 

Will try asap and check settings suggested , reset the plugin or downgrade Milhouse build

RE: Amazon VOD [plugin.video.amazon[vod|-test]] - Varstahl - 2020-06-12

That might actually happen just because the MPD is too large for the machine to parse it in a timely manner. The timeout is between Kodi and the local server.

RE: Amazon VOD [plugin.video.amazon[vod|-test]] - Roby77 - 2020-06-12

Disabled mpd and still have problem

Edit:downgraded Milhouse build fix it

RE: Amazon VOD [plugin.video.amazon[vod|-test]] - Roby77 - 2020-06-12

(2020-06-12, 10:34)Varstahl Wrote: That might actually happen just because the MPD is too large for the machine to parse it in a timely manner. The timeout is between Kodi and the local server.

User @xxxnelly posted a solution


RE: Amazon VOD [plugin.video.amazon[vod|-test]] - wings188 - 2020-06-14

(2019-11-15, 22:48)Varstahl Wrote: Image

Not affiliated with Amazon. Amazon, Prime, Amazon Prime and Prime Video are registered trademarks of Amazon Technologies, inc.

This addon supports Prime Video account for Germany, Japan, United Kingdom, United States (referred to as amazon.TLDs or TLDs) and all the countries served by PrimeVideo.com (PV).

Kodi 17+ and python 2.7 & 3 support. Kodi 18+ with InputStream.Adaptive recommended.

Stable: v0.8.5
Addon: plugin.video.amazonvod (not yet in Kodi repos)
Nightly: plugin.video.amazon-test
Nightly repo: GitHub Sandmann79/xbmc (direct links: Krypton/Leia, Matrix)

Captcha notice
Some of the captchas used by Amazon actually require you to put spaces in where blanks are present. Absence of spaces can actually invalidate an otherwise good challenge answer. Make sure to include spaces if needed.

Localisation (translations)
Is your language missing from our addon? Do you want to help? Follow this link to find information on how to help us.

Useful links
Readme (valuable information)
FAQ (solution to common troubles)
GH Wiki
issues (list of current open issues and enhancement requests)
File a new bug report

Recent changes (v0.8.5)
  • PV: fixed all the things Amazon broke
  • PV: added pagination options
  • TLD: fixed TV shows and watchlist
  • PV/TLD: updated localizations, added fr_CA

Known issues in stable
  • None Smile

Want to tip the creators of the addon and support its development?
Sandmann79 (author, DE/JP/US/UK support)
Varstahl (PrimeVideo author, international support)

Hello, where can I find the stable repo for this addon? I only see the nighly repo listed here and everywhere that I've looked for it.

RE: Amazon VOD [plugin.video.amazon[vod|-test]] - Bedwyr - 2020-06-20

(2019-12-21, 01:44)twiseva Wrote: So, I am running Leia 18.5 and have installed Amazon VOD. All is good, got to login ok -- can see watchlist, videos, etc BUT when I goto play any video I get a "HTTP Error" message popup.
Quoting this because I had a similar error that I solved and want to put on the record in case anyone is coming in from a search engine somewhere. I was also getting an HTTP error because I wasn't properly authenticated; I could browse movies but not play them. It turns out that I hadn't re-authenticated since I moved Amazon to a 2-factor app (Microsoft's, in fact). Logged in again, entered the captcha challenge, and entered the one time code from the app and all was well.

RE: Amazon VOD [plugin.video.amazon[vod|-test]] - Wagg - 2020-06-22

I might have asked this before, but is there a way to separate IMDB Channel content from the rest of the other content? Currently the IMDB Free content shows up in RED with all the other pay content which makes things a bit confusing. At least showing it in a different color, like BLUE would help things, if not a separate category if possible.

RE: Amazon VOD [plugin.video.amazon[vod|-test]] - azumukupoe - 2020-06-24

Quote:Add support for sharing from Amazon Prime Videos and from Arte (The European Culture Channel) to Kodihttps://kodi.tv/article/new-kore-version-v251

Is the update related to this plugin?

RE: Amazon VOD [plugin.video.amazon[vod|-test]] - calibos - 2020-06-24

Got this add-on working on a CoreElec KODI Odroid N2. After turning off Pageination and just letting the blur ring spin long enough as it caches/loads up the pages, I eventually get to the Lists which are then cached so the next time I enter that Catagorie it loads in in a second or 3. Content is playing fine unlike when I tried the Add-0n on an Androind 9.0 KODI install on another Odroid N2.

My only problem with the add-on now is that the POster Art is over scaled/zoomed in many of the views but the real biggy is that after going through each catagory and setting my preffered View Type (Infowall for Movies and Rightlist for TV Shows) when I exit that catagory and go back to it, the View type has reverted to ShowcaseHuh? This does not happen in the NEtflix Add-on where I set my preffered view type for each catagory and they stuck and survives reboots etc.

EDIT Found the View ID's for my preffered view types in my preffered SKin Aeon Nox Silvio but when I set those view ID's in the 'View' Tab of the Amazon VOD Add-on, they don't stick....although now confusingly, the default isn't showcase anymore, its Right List which is fine except I also what TriPanel for the Episode list but thats stuck/reverts back to Rightlist now. All very confusing. There is something wrong with the Custom View engine in the VOD Add-on.

RE: Amazon VOD [plugin.video.amazon[vod|-test]] - shaktoo - 2020-06-28

This addon is Working Brilliantly at my end. Nil issues as described by Other users.  Big Grin
Only problem is to do with Amazon limiting resolution in playback using "input stream adaptive " on windows as that limits resolution to SD.
Workarond is to use "android " or " browser "  instead and then it plays in HD1080p .
The Issue with this is that as playback opens in an external browser fullscreen window the remote control options are limited and I am unable to close the browser window ( unless i do ALT+F4)
If Varstahl or anyone else has expereince in using remote in this way & or making playback control much better would be appreciated.
What I am going to do is add AL+F4 function on my Harmony remote so it will close the broswer playback window and go back to kodi screen.
Will keep you updarted how it goes.

This forum uses Lukasz Tkacz MyBB addons.